TP-Link Archer T9UH v2

I am trying to get my new TP-Link Archer T9UH (v2) to work on a fresh installed Manjaro KDE (Kernel 5.10.2-2). I tried the different available rtl88xxau-aircrack-dkms-git packages without success.

Has anyone managed to get it reliable to work on a current system?

Have you made sure you have installed the linux510-headers and dkms ?
What is the error you get?

I did it under Linux Kernel. 5.9.16-1, I installed the 519 headers and dkm and after the rtl88xxau-aircrack-dkms-git packages. There were no error messages but the modem was not recognized.
After several attempts I did a clean new Manjaro installation and before I start over again, I tried to get some advice here first.

I have the same device.

Here: GitHub - aircrack-ng/rtl8812au: RTL8812AU/21AU and RTL8814AU driver with monitor mode and frame injection

they reported:

8814au chipset support is turned off. 8814au got itself a new, standalone driver in this link below

And in facts now I’m using AUR (en) - rtl8814au-aircrack-dkms-git and works as before.

Hi Dave,

Thanks for you infos.
So you would rather recommend using AUR (en) - rtl8814au-aircrack-dkms-git instead the rtl8812au?
And in any case I first need to install inux510-headers and dkms, right?
Thanks for your help, I am not a Linux expert, just a user trying to get his issues solved… :slight_smile:

Hi obruch,

Since I also have the TP-Link Archer T9UH I’m telling you what I did to make it works again :slight_smile:

And yes: to build the module, and to have it always functional at every kernel update, you need kernel’s headers and the dkms.

Thanks a lot D.Dave, I’ll give it a try

1 Like