TP-Link 401 Not Detected

I just built a whole new PC and installed Manjaro KDE 21.3.7-220816 on it.

My TP-Link TX401 10 gig add-in ethernet NIC is not detected. I downloaded the drivers from TP-Link’s website to try to manually build them, and though I’ve used Linux for years, I’ve never been that great at the more in-depth stuff in the command promp. The process fails spectacularly. (as soon as I issue the make command, I get a nice big wall of text i don’t understand, that seems to indicate that the command failed because it issued commands that were out of date or had incorrect syntax.)

While I could copy the result of that text here, I was hoping for any ideas on what I could do before I result to that, as it is rather overwhelming.

I put in a support ticket with TP-Link, but am still waiting on a competent response. (So far all i got was “we dont support linux” even though their product page clearly says they do, to which i argued, and now i’m waiting from their engineering deparment to get back with me.)

Interestingly, In the mean time I decided to experiment with other distros. I used Live USB installers for Garuda, Kubuntu, and Liunx Mint and in all three cases while booted to the live media, they saw the TP-Link TX 401 just fine (As a Marvell Aquantia AQC107, which I understand it is based on). Then as soon as the distribution was installed and I booted to the OS drive, the TX-401 was gone. So, 3 of the 4 distros I tried could see it at first, but then couldnt anymore - and one of them, Manjaro, just couldn’t see it at all.

Does anyone have any idea what the issue could be that this card could work fine on live media but then vanish once installed? (And alternatively, In case I can’t get this card to work as expected, can anyone else suggest a 10 gig ethernet nic that uses a pcie x4 connection that I wouldn’t have to mess around with too much to get working correctly?)

Oh, and if anyone is going to try to help and wants me to do things within Linux, please treat me like an absolute noob. Please don’t assume I know any commands or syntax other than “ls” and “cd”.

Hi @Gumpo ,
Welcome to the forum, I wonder whether you could read the following post in order to solve the problem. You could also post more information about you system whether something fails.
TX401 / AQC107 Network Adapter Not Able to Detect link

Hope this help, regards.

Thanks for the reply. I obviously did read that topic before posting this one. As the issue was different - Not detecting a link and not even showing up as a device are pretty different. I also googled/duckduckgo’d extensively.

Ultimately though, apparently the problem has solved itself. I’m not sure if it was anything I did (I installed every kernel and bounced between them all, as well as following multiple guides to try to install the driver manually that all seemed to fail…) but when I turned the system on today, it suddenly saw the TX401. I rebooted, and it vanished… That got me thinking. I turned the system off completely for a cold boot, and boom it was there again. Seems like it will only get detected if the system was turned on from a completely off state, not from a reboot. I had a situation like this with an old system not recognizing its add-in sound card unless it was from a cold boot as well, so I guess I should have thought about that before posting here. But you know, we always overlook simple things.

Hopefully my stupidity will help someone else in the future. :slight_smile:

Hi @Gumpo,

Sounds like a startup…bug…thing…OK, well it sounds like it doesn’t really get initialized…so make sure, in your BIOS/UEFI that fast startup/Fast boot/Secure startup (or all combinations of anything similar to it) is disabled.

Don’t think it will, but I hope it helps!



I just found something that might be it. I came across this website with instructions for installing the driver on Linux. It stated the driver is the Aquantia AQtion driver. Or something. So I searched for those in the AUR:

$ pamac search AQtion

$ pamac search Aquantia
atlantic-dkms                                                                                                                                                                                                                                  2.5.3-1  AUR
aquantia multigigabit nic driver - "development preview"

…and lo-and-behold! There’s something that looks like it fits. But there’s only one way to test it and that’s to try it. So install it with:

pamac build atlantic-dkms

Followed by a reboot and seeing if it works.

I sincerely hope it does!

I had the same problem. I cured it by shutting the system down, waited 30 seconds and turned it back on.
I found that most of the problems caused by hardware are eliminated by this process, whereas a reboot usually doesn’t help.