Touchscreen calibration

Hey there,

I tried to run xinput_calibrator to set up my external monitor (w/ touchscreen) in Manjaro without any luck. Sadly it was working fine in PopOS or Mint.

I also tried to follow this guide but get stuck when running verbose mode as I don’t get any debug line.

Here is my inxi:

  Kernel: 5.11.2-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.11-x86_64 
  root=UUID=3606155d-3089-42e2-9416-0f7f55d675bf ro quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: KDE Plasma 5.21.2 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Laptop System: HUAWEI product: HLYL-WXX9 v: M1090 serial: <filter> 
  Mobo: HUAWEI model: HLYL-WXX9-PCB v: M1090 serial: <filter> UEFI: HUAWEI 
  v: 1.07 date: 12/14/2020 
  ID-1: BAT1 charge: 56.1 Wh condition: 56.4/54.9 Wh (103%) volts: 8.7/7.6 
  model: DYNAPACK HB6081V1ECW-22T type: Li-ion serial: <filter> 
  status: Unknown cycles: 5 
  Device-1: hidpp_battery_0 model: Logitech MX Ergo Multi-Device Trackball 
  serial: <filter> charge: 100% (should be ignored) rechargeable: yes 
  status: Discharging 
  RAM: total: 15.08 GiB used: 4.35 GiB (28.9%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: 8-Core model: AMD Ryzen 7 4800H with Radeon Graphics bits: 64 
  type: MT MCP arch: Zen 2 family: 17 (23) model-id: 60 (96) stepping: 1 
  microcode: 8600104 L2 cache: 4 MiB bogomips: 92664 
  Speed: 1397 MHz min/max: 1400/2900 MHz boost: enabled Core speeds (MHz): 
  1: 1397 2: 1396 3: 1905 4: 1907 5: 1907 6: 1903 7: 1907 8: 1906 9: 1397 
  10: 1397 11: 1397 12: 1397 13: 1397 14: 1397 15: 4282 16: 4292 
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1 
  bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy 
  constant_tsc cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total cqm_occup_llc 
  cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c flushbyasid 
  fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb ibrs ibs irperf lahf_lm 
  lbrv lm mba mca mce misalignsse mmx mmxext monitor movbe msr mtrr mwaitx 
  nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae pat pausefilter 
  pclmulqdq pdpe1gb perfctr_core perfctr_llc perfctr_nb pfthreshold pge pni 
  popcnt pse pse36 rdpid rdpru rdrand rdseed rdt_a rdtscp rep_good sep sha_ni 
  skinit smap smca smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 stibp succor 
  svm svm_lock syscall tce topoext tsc tsc_scale umip v_vmsave_vmload vgif 
  vmcb_clean vme vmmcall wbnoinvd wdt xgetbv1 xsave xsavec xsaveerptr xsaveopt 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, 
  STIBP: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: AMD Renoir vendor: QUANTA driver: amdgpu v: kernel bus ID: 03:00.0 
  chip ID: 1002:1636 class ID: 0300 
  Device-2: Quanta ov9734_techfront_camera type: USB driver: uvcvideo 
  bus ID: 1-4:5 chip ID: 0408:1040 class ID: 0e02 serial: <filter> 
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: 
  loaded: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa 
  display ID: :0 screens: 1 
  Screen-1: 0 s-res: 3929x2016 s-dpi: 96 s-size: 1038x532mm (40.9x20.9") 
  s-diag: 1166mm (45.9") 
  Monitor-1: eDP res: 1920x1080 hz: 60 dpi: 137 size: 355x199mm (14.0x7.8") 
  diag: 407mm (16") 
  Monitor-2: DisplayPort-0 res: 1920x1080 hz: 60 dpi: 141 
  size: 345x194mm (13.6x7.6") diag: 396mm (15.6") 
  OpenGL: renderer: AMD RENOIR (DRM 3.40.0 5.11.2-1-MANJARO LLVM 11.1.0) 
  v: 4.6 Mesa 20.3.4 direct render: Yes 
  Device-1: AMD vendor: QUANTA driver: snd_hda_intel v: kernel bus ID: 03:00.1 
  chip ID: 1002:1637 class ID: 0403 
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor vendor: QUANTA 
  driver: N/A alternate: snd_pci_acp3x, snd_rn_pci_acp3x bus ID: 03:00.5 
  chip ID: 1022:15e2 class ID: 0480 
  Device-3: AMD Family 17h HD Audio vendor: QUANTA driver: snd_hda_intel 
  v: kernel bus ID: 03:00.6 chip ID: 1022:15e3 class ID: 0403 
  Sound Server: ALSA v: k5.11.2-1-MANJARO 
  Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter 
  vendor: & Tele RSH driver: rtw_8822ce v: N/A modules: rtw88_8822ce 
  port: 2000 bus ID: 01:00.0 chip ID: 10ec:c822 class ID: 0280 
  IF: wlp1s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8 
  bus ID: 3-4:4 chip ID: 1358:c123 class ID: e001 serial: <filter> 
  Message: Required tool hciconfig not installed. Check --recommends 
  Message: No RAID data was found. 
  Local Storage: total: 476.94 GiB used: 70.18 GiB (14.7%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital 
  model: PC SN730 SDBPNTY-512G-1027 size: 476.94 GiB block size: 
  physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 rotation: SSD 
  serial: <filter> rev: 11120000 temp: 42.9 C scheme: GPT 
  Message: No Optical or Floppy data was found. 
  ID-1: / raw size: 476.64 GiB size: 468.16 GiB (98.22%) 
  used: 70.18 GiB (15.0%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2 
  label: N/A uuid: 3606155d-3089-42e2-9416-0f7f55d675bf 
  ID-2: /boot/efi raw size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 312 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 label: N/A 
  uuid: BFA6-B0BB 
  ID-3: /run/timeshift/backup raw size: 476.64 GiB size: <superuser required> 
  used: <superuser required> fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2 
  label: N/A uuid: 3606155d-3089-42e2-9416-0f7f55d675bf 
  Alert: No Swap data was found. 
  Message: No Unmounted partitions found. 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 class ID: 0900 
  Hub-2: 1-1:2 info: Terminus USB 2.0 Hub ports: 4 rev: 2.0 speed: 480 Mb/s 
  chip ID: 1a40:0801 class ID: 0900 
  Device-1: 1-1.3:8 info: Silicon Works Multi-touch Device type: HID 
  driver: hid-multitouch,usbhid interfaces: 1 rev: 2.0 speed: 12 Mb/s 
  chip ID: 29bd:4101 class ID: 0300 
  Device-2: 1-1.4:6 info: QinHeng CH340 serial converter 
  type: <vendor specific> driver: ch341,ch341-uart interfaces: 1 rev: 1.1 
  speed: 12 Mb/s chip ID: 1a86:7523 class ID: ff00 
  Device-3: 1-2:3 info: Holtek USB Gaming Keyboard type: Keyboard,HID 
  driver: hid-generic,usbhid interfaces: 3 rev: 1.1 speed: 12 Mb/s 
  chip ID: 04d9:a0f8 class ID: 0300 
  Device-4: 1-4:5 info: Quanta ov9734_techfront_camera type: Video 
  driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s chip ID: 0408:1040 
  class ID: 0e02 serial: <filter> 
  Hub-3: 2-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 speed: 10 Gb/s 
  chip ID: 1d6b:0003 class ID: 0900 
  Hub-4: 3-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 class ID: 0900 
  Device-1: 3-1:2 info: Logitech Unifying Receiver type: Keyboard,Mouse,HID 
  driver: logitech-djreceiver,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s 
  chip ID: 046d:c52b class ID: 0300 
  Device-2: 3-3:3 info: Shenzhen Goodix Fingerprint Reader 
  type: Communication,CDC-Data driver: N/A interfaces: 2 rev: 2.0 
  speed: 12 Mb/s chip ID: 27c6:5117 class ID: 0a00 
  Device-3: 3-4:4 info: Realtek Bluetooth Radio type: Bluetooth driver: btusb 
  interfaces: 2 rev: 1.0 speed: 12 Mb/s chip ID: 1358:c123 class ID: e001 
  serial: <filter> 
  Hub-5: 4-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 speed: 10 Gb/s 
  chip ID: 1d6b:0003 class ID: 0900 
  System Temperatures: cpu: 58.5 C mobo: N/A gpu: amdgpu temp: 42.0 C 
  Fan Speeds (RPM): N/A 
  Processes: 339 Uptime: 1h 22m wakeups: 7 Init: systemd v: 247 Compilers: 
  gcc: 10.2.0 clang: 11.1.0 Packages: pacman: 1473 lib: 419 flatpak: 0 
  Shell: Bash v: 5.1.0 running in: konsole inxi: 3.3.01 

xrandr output:

Screen 0: minimum 320 x 200, current 3929 x 2016, maximum 16384 x 16384
eDP connected primary 1920x1080+2009+0 (normal left inverted right x axis y axis) 355mm x 199mm
   1920x1080     60.01*+
   1680x1050     60.01  
   1280x1024     60.01  
   1440x900      60.01  
   1280x800      60.01  
   1280x720      60.01  
   1024x768      60.01  
   800x600       60.01  
   640x480       60.01  
HDMI-A-0 disconnected (normal left inverted right x axis y axis)
DisplayPort-0 connected 1920x1080+0+936 (normal left inverted right x axis y axis) 345mm x 194mm
   3840x2160     59.98 +  60.00    50.00    59.94    30.00    30.00    25.00    24.00    29.97    23.98  
   2560x1600     59.99  
   2560x1440     60.00  
   2048x1536     60.02  
   1920x1440     60.00  
   1856x1392     60.00  
   1792x1344     60.00  
   2048x1152     60.00  
   1920x1200     59.88  
   1920x1080     60.00*   50.00  
   1600x1200     60.00  
   1680x1050     59.95  
   1680x945      60.02  
   1400x1050     59.98  
   1600x900      60.00  
   1280x1024     60.02  
   1440x900      59.89  
   1280x960      60.00  
   1366x768      59.79  
   1360x768      60.02  
   1280x800      59.81  
   1280x768      59.87  
   1280x720      60.00    50.00    59.94  
   1024x768      60.00  
   1024x576      59.97  
   800x600       60.32    56.25  
   720x576       50.00  
   848x480       60.00  
   720x480       60.00    59.94  
   640x480       60.00    59.94  
   720x400       70.08  

Oddly, when running xinput_calibrator --list it actually shows two devices:

Device "Silicon Works Multi-touch SW4101C Mouse" id=9
Device "Silicon Works Multi-touch SW4101C" id=19

The first (id=9) shows up in my input devices in system settings as game controller :face_with_raised_eyebrow:

Obviously I tried to run the calibrator for both without luck.

The touch function actually works and even the scrolling. It’s quite precise if I touch the bottom left angle of the display, as I get towards the center it starts messing up and if I touch the center it basically points to the top right corner of the display.

What should I do to get it working?