Touchpad stopped working - reinstalled and still not working

As the title says:
Had installed Manjaro (KDE) a few days ago, was messing around with the themes and at some point the touchpad simply stopped working. Mouse was working; touchpad wasn't broken (working in Windows ofc); looked everywhere online for something similar but all i could find were people saying to reinstall the xf86-input-synaptics package, which i did many times.
I own a Legion Y530 from lenovo so in order for my wi-fi to work i need to blacklist the ideapad_laptop module: while trying to get my touchpad to work I also tried enabling this again and it got it working for a bit, 2 or 3 bootups later was broken again and enabling/disabling ideapad_laptop didn't do anything besides breaking my wi-fi.
Now I sit here annoyed with a fresh install - touchpad still somehow not working - hoping one of you beautiful people can help me :')

Do you know if you might have run into a conflict with libinput? You can only have libinput or synaptics installed.
https://wiki.archlinux.org/index.php/Libinput

Even if not, you might give libinput a try instead of synaptics.

Have a look at this thread, it might help you as well: