Touchpad scrolling jerks back to starting position sometimes when third finger touches pad

  Kernel: 5.14.2-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.14-x86_64 
  root=UUID=ade649ba-48e8-4bd1-9e1c-7878c6f77246 rw quiet mitigations=off 
  nowatchdog pci=noaer cpufreq.default_governor=performance apparmor=1 
  security=apparmor udev.log_priority=3 acpi_osi=! acpi_osi=Linux 
  "acpi_osi=Windows 2009" nogpumanager i915.enable_gvt=1 pcie_port_pm=off 
  iommu=1 intel_iommu=on kvm.ignore_msrs=1 rd.driver.pre=vfio-pci 
  default_hugepagesz=1G hugepagesz=1G hugepages=0 transparent_hugepage=never 
  Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: Micro-Star product: GE75 Raider 8SE v: REV:1.0 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: Micro-Star model: MS-17E2 v: REV:1.0 serial: <filter> 
  UEFI: American Megatrends v: E17E2IMS.10E date: 03/28/2019 
  ID-1: BAT1 charge: 41.7 Wh (95.9%) condition: 43.5/53.4 Wh (81.4%) 
  volts: 11.9 min: 10.9 model: MSI BIF0_9 type: Li-ion serial: N/A 
  status: Unknown 
  Device-1: hidpp_battery_0 
  model: Logitech MX Vertical Advanced Ergonomic Mouse serial: <filter> 
  charge: 10% (should be ignored) rechargeable: yes status: Discharging 
  RAM: total: 31.2 GiB used: 5.66 GiB (18.1%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP 
  arch: Kaby Lake note: check family: 6 model-id: 9E (158) stepping: A (10) 
  microcode: EA cache: L2: 9 MiB bogomips: 52815 
  Speed: 4077 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 4077 2: 4094 
  3: 4101 4: 4048 5: 4100 6: 4050 7: 3990 8: 4057 9: 4100 10: 4101 11: 4090 
  12: 4099 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art 
  avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid 
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est 
  f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window 
  hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm 
  mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat 
  pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pts rdrand 
  rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1 sse4_2 
  ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme 
  vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf mitigation: PTE Inversion; VMX: vulnerable 
  Type: mds status: Vulnerable; SMT vulnerable 
  Type: meltdown status: Vulnerable 
  Type: spec_store_bypass status: Vulnerable 
  Type: spectre_v1 status: Vulnerable: __user pointer sanitization and 
  usercopy barriers only; no swapgs barriers 
  Type: spectre_v2 status: Vulnerable, IBPB: disabled, STIBP: disabled 
  Type: srbds status: Vulnerable 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Micro-Star MSI 
  driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:3e9b class-ID: 0300 
  Device-2: NVIDIA TU106M [GeForce RTX 2060 Mobile] vendor: Micro-Star MSI 
  driver: nvidia v: 470.63.01 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 
  chip-ID: 10de:1f11 class-ID: 0300 
  Device-3: Acer HD Webcam type: USB driver: N/A bus-ID: 1-13:5 
  chip-ID: 5986:211c class-ID: 0e02 
  Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: 
  loaded: modesetting,nvidia display-ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP-1-1 res: 1920x1080 hz: 144 dpi: 128 
  size: 382x215mm (15.0x8.5") diag: 438mm (17.3") 
  OpenGL: renderer: NVIDIA GeForce RTX 2060/PCIe/SSE2 
  v: 4.6.0 NVIDIA 470.63.01 direct render: Yes 
  Device-1: Intel Cannon Lake PCH cAVS vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl 
  bus-ID: 00:1f.3 chip-ID: 8086:a348 class-ID: 0403 
  Device-2: NVIDIA TU106 High Definition Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:10f9 
  class-ID: 0403 
  Sound Server-1: ALSA v: k5.14.2-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: no 
  Sound Server-4: PipeWire v: 0.3.35 running: yes 
  Device-1: Intel Cannon Lake PCH CNVi WiFi 
  vendor: Rivet Networks Killer Wireless-AC 1550i Wireless driver: iwlwifi 
  v: kernel port: 6000 bus-ID: 00:14.3 chip-ID: 8086:a370 class-ID: 0280 
  IF: wlo1 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  Device-2: Qualcomm Atheros Killer E2500 Gigabit Ethernet 
  vendor: Micro-Star MSI driver: alx v: kernel port: 3000 bus-ID: 05:00.0 
  chip-ID: 1969:e0b1 class-ID: 0200 
  IF: enp5s0 state: down mac: <filter> 
  IF-ID-1: nordlynx state: unknown speed: 10 Mbps duplex: full mac: N/A 
  IP v4: <filter> scope: global 
  WAN IP: <filter> 
  Message: No bluetooth data found. 
  Message: No logical block device data found. 
  Message: No RAID data found. 
  Local Storage: total: 2.07 TiB used: 1.31 TiB (63.0%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: RBUSNS8154P3256GJ 
  size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 15.8 Gb/s 
  lanes: 2 type: SSD serial: <filter> rev: E8FK11.C temp: 46.9 C scheme: GPT 
  ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital 
  model: WDS100T2B0B-00YS70 size: 931.51 GiB block-size: physical: 512 B 
  logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 00WD 
  scheme: GPT 
  ID-3: /dev/sdb maj-min: 8:16 vendor: KingSpec model: ACSC4M1TS25 
  size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  type: SSD serial: <filter> rev: 4H scheme: GPT 
  Message: No optical or floppy data found. 
  ID-1: / raw-size: 238.17 GiB size: 233.38 GiB (97.99%) 
  used: 137.84 GiB (59.1%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2 
  label: N/A uuid: ade649ba-48e8-4bd1-9e1c-7878c6f77246 
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 288 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 
  label: NO_LABEL uuid: B822-64D2 
  ID-3: /run/media/rabcor/KingSpec raw-size: 953.87 GiB 
  size: 953.4 GiB (99.95%) used: 582.31 GiB (61.1%) fs: xfs dev: /dev/sdb1 
  maj-min: 8:17 label: N/A uuid: 7081018e-cce8-4d7d-b093-bb681ff46b8e 
  ID-4: /run/media/rabcor/WD raw-size: 931.51 GiB size: 931.51 GiB (100.00%) 
  used: 617.38 GiB (66.3%) fs: f2fs dev: /dev/sda1 maj-min: 8:1 
  label: Western Digital uuid: ae81d12d-6838-4833-b47b-8dd120364382 
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: file size: 8 GiB used: 0 KiB (0.0%) priority: -2 
  file: /swapfile 
  Message: No unmounted partitions found. 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 1-2:2 info: Logitech Unifying Receiver type: Keyboard,Mouse,HID 
  driver: logitech-djreceiver,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s 
  power: 98mA chip-ID: 046d:c52b class-ID: 0300 
  Device-2: 1-7:3 info: Realtek RTS5129 Card Reader Controller 
  type: <vendor specific> driver: rtsx_usb,rtsx_usb_ms,rtsx_usb_sdmmc 
  interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 0bda:0129 
  class-ID: ff00 serial: <filter> 
  Device-3: 1-9:4 info: SteelSeries ApS SteelSeries KLC type: HID 
  driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s 
  power: 300mA chip-ID: 1038:1122 class-ID: 0300 
  Device-4: 1-13:5 info: Acer HD Webcam type: Video driver: N/A interfaces: 2 
  rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 5986:211c class-ID: 0e02 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 8 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  System Temperatures: cpu: 52.0 C mobo: N/A gpu: nvidia temp: 46 C 
  Fan Speeds (RPM): N/A 
  Processes: 368 Uptime: 1d 2h 16m wakeups: 20 Init: systemd v: 249 
  tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1471 
  lib: 422 flatpak: 0 Shell: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06

I am having an issue where if I use two finger scrolling to scroll, sometimes when I accidentally tap the touchpad with a third finger (this is not consistent, e.g. only happens sometimes, not always) the scrolling jerks/jumps back to where I initially started scrolling.

This is quite infuriating since it makes me lose track of which line I was reading.

I have no idea why it does this, I’m not using any gestures, nor do I even have any package for that installed.

The laptop is identified by xinput as:

SynPS/2 Synaptics TouchPad

However it used to (~2 years ago last I checked) be identified by xinput as:

CUST0001:00 06CB:CDA1 Touchpad

The driver I am using for it is libinput (default). I do not remember if I had this issue or not last time I used linux on this laptop around 2 years ago.

  1. Always provide an inxi --admin --verbosity=7 --filter --no-host --width, please? :pray:

  2. execute:

    pamac install synaptics

    and provide the output of the last command, please?

  3. Unrelated to your issue, but please read this as that’s too much if you don’t use hibernation and too little if you do… (probably a left-over from the time before you did the RAM upgrade… :grin: :wink:


  1. I updated the OP :slight_smile:

  2. a bit of a problem there…

    Error: target not found: synclient

    dug around a bit, found the package name is actually: xf86-input-synaptics, I installed that, and the output of the synclient command is:

    Couldn't find synaptics properties. No synaptics driver loaded?

    This is not particularly surprising, as I recall the synaptics client is a pretty old piece of now obsolete software, and my laptop is from 2019 making it pretty recent, it’s no wonder why my touchpad would not be supported by it. (Or maybe I just need to force X to use the synaptics driver for the touchpad via configs?)

  3. I don’t remember where I got the recommendations for this swapfile or what I was thinking when I made it, thanks for the advice. I don’t use hybernation though, nor do I plan to, the swap I have is just there as a safety net really.

  1. Thanks!

  2. My mistake!

    pamac install synaptics

    Yes, but it is to get information about your Synaptics touchpad easily as you didn’t provide any xinpit --list-props (that would be fine too)

  3. OK.

  4. Forgot to ask if you’ve tried one of the LTS kernels instead one of the stable development kernels?


xinput --list-props:

Device 'SynPS/2 Synaptics TouchPad':
        Device Enabled (189):   1
        Coordinate Transformation Matrix (191): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
        libinput Tapping Enabled (347): 0
        libinput Tapping Enabled Default (348): 0
        libinput Tapping Drag Enabled (349):    1
        libinput Tapping Drag Enabled Default (350):    1
        libinput Tapping Drag Lock Enabled (351):       0
        libinput Tapping Drag Lock Enabled Default (352):       0
        libinput Tapping Button Mapping Enabled (353):  1, 0
        libinput Tapping Button Mapping Default (354):  1, 0
        libinput Natural Scrolling Enabled (325):       0
        libinput Natural Scrolling Enabled Default (326):       0
        libinput Disable While Typing Enabled (355):    1
        libinput Disable While Typing Enabled Default (356):    1
        libinput Scroll Methods Available (327):        1, 1, 0
        libinput Scroll Method Enabled (328):   1, 0, 0
        libinput Scroll Method Enabled Default (329):   1, 0, 0
        libinput Accel Speed (336):     0.000000
        libinput Accel Speed Default (337):     0.000000
        libinput Accel Profiles Available (338):        1, 1
        libinput Accel Profile Enabled (339):   1, 0
        libinput Accel Profile Enabled Default (340):   1, 0
        libinput Left Handed Enabled (341):     0
        libinput Left Handed Enabled Default (342):     0
        libinput Send Events Modes Available (310):     1, 1
        libinput Send Events Mode Enabled (311):        0, 0
        libinput Send Events Mode Enabled Default (312):        0, 0
        Device Node (313):      "/dev/input/event15"
        Device Product ID (314):        2, 7
        libinput Drag Lock Buttons (343):       <no items>
        libinput Horizontal Scroll Enabled (344):       1
        libinput Scrolling Pixel Distance (345):        15
        libinput Scrolling Pixel Distance Default (346):        15

Also I suppose I should note about the touchpad that palm detect is not working for it on libinput (major pain in the ass tbh)

And also scrolling with the touchpad is choppy (or rather smooth scrolling does not work on the touchpad, works normally on my mouse though), I’m honestly thinking this is probably an issue with libinput though, maybe there’s an issue in how they handle touchpaad scrolling that causes this?

Tried 5.10 LTS and the older 4.14 LTS kernels, the latter pre-dates my laptop.

Situation unchanged for the touchpad on both kernels, reverting to 5.14.

I’m guessing it’s probably more of a libinput issue than a kernel issue.

1 Like

Try turning these off:


Tried this, it did not affect the issue either :frowning:

(I think this feature is actually the ability to drag & drop with tap-to-click on. Since I have no palm detect I have tap-to-click disabled in the first place).

1 Like

The only thing to do is to file a bug then…


1 Like

Made Report: MSI Touchpad Scrolling Problems (#670) · Issues · libinput / libinput

1 Like

The link you gave me is wrong & outdated, this is the correct link: Reporting bugs — libinput 1.19.0 documentation

Thought you’d wanna know.

That’s for Wayland bugs… According to your inxi you’re still on Xorg… (Unless you’re trying to tell me that the LibInput team swapped teams?)


This is what the libinput devs told me. :man_shrugging:

You can see it in the issue report thread.

I think the bottom line here is that libinput is libinput whether you’re on X or Wayland, as such the libinput docs are the same. Also libinput is originally a part of the wayland project if I recall correctly, so it makes sense their docs would be on the wayland.freedesktop site.

Maybe there are other docs for xf86-input-libinput, but that’s not where the actual issue lies in the first place (and I can’t actually find them, even the xf86-input-libinput git page itself suggests if there are bugs in libinput they should be filed on the wayland git, although that section of the readme is clearly outdated since libinput has it’s own gitlab page now)

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.