Touchpad requires 2 fingers to move cursor, 3 fingers to scroll etc

Hi there,
I have switched to Wayland because it was the only possibility to use my Wacom graphic tablet properly. Since it seams to be the new standard Window manager in Manjaro I was expecting everything to work. It performs very well and delivers much smoother animations and I finaly can pinch to zoom in Firefox. Everything worked fine until I experienced this very annoying bug:

After waking up from sleep my touchpad starts requiring an additional finger. Meaning that I can only move the cursor with two fingers, scroll with three etc. This does not occur after every sleep.
Sometimes it starts working again after a while. Sometimes when it does not I turn off extensions and activate them again or start the libinput debug-gui where all the touchpad actions are recognized correctly. But none of this commands seem to help instantly. Sometimes the Touchpad starts working after a while or I need to restart my computer. Restarting resolves the problem in every case.

My Notebook is a Dell Latitude 7410. It has the following Touchpad: DELL09BE:00 0488:120A

I am on Manjaro Gnome with the newest kernel.

Does anyone have an advance how to solve this issue?

Thanks in advance!

While I can offer little help with Wacom tablets, in general, here’s something to try in the meantime: Try switching to the current LTS kernel 6.1.xx via Manjaro Settings Manager, or whatever it equivalent is in Gnome. Cheers.

Hi Soundofthunder,
actually I am on the latest LTS kernel (6.1.55-1). Since the latest big update from yesterday my touchpad did not require an additional finger for every action. But it’s still too early to cheer.

To clarify, you switched to 6.1 since stating “I am on Manjaro Gnome with the newest kernel.”, and now the issue is moot?

I prefer using the latest LTS Kernel and had almost no issues in X11 with that. It only happens in Wayland. After the last major update I’m on Linux 6.1.60-1-MANJARO and GNOME 45. The bug occurs less often than before but is still unsolved.
Does anyone have the same problem? Did anyone find a permanent fix?

Best regards.

It might be worth trying kernel 6.6, which has now reached Stable.