Touchpad not working on Thinkpad p14s

Hello there,

First of all, please be patient, I’m a linux noob.
I installed the KDE spin alongside windows on my new thinkpad p14s.
Everything worked fine at the first few boots. However the next day the touchpad ceased to work, only the track point is working. Another weird thing is that since this issue is happening, a bash terminal is open on my desktop when I boot.
I saw a post about the exact same problem. I installed evtest as it was advised. Evtest detects the touchpad as “SynPS/2 Synaptics TouchPad”. Running a test doesn’t solve the issue though.
The touchpad is working fine in windows.
I tried changing the kernel from 5.8.18-1 to 5.9.1_rt19-1 and then to 5.9.11-3. That did not solve the issue.
What can I do except doing a fresh install, as this method won’t prevent the same issue to happen again. (In the previous post about the same issue, the only solution that came up was doing a fresh install).
Any help on the matter would be greatly appreciated.

Can you install xorg-xinput and post the output of xinput list-props "SynPS/2 Synaptics TouchPad"?


Sorry for not responding. The problem disappeared the next day and everything worked fine for 2 weeks.
Today the same issue came back. So here I am.

Thank you for your time. Here’s the screenshot of xinput.

Does sudo rmmod psmouse && sudo modprobe psmouse have any effect?

Nope :frowning: not even a line of text

No output is expected. Does the touchpad start working? If you start evtest on the touchpad, does it show events when you move your finger on the touchpad?

Trying to move the cursor with the touchpad do not show an event on evtest. However clicking on the touchpad does.

Can you try kernel 5.4, just to make sure this isn’t kernel related?

I had the exact same touchpad issue, also on a p14s, when trying to set up manjaro for the first time. Same xinput results, and same evtest results- showing events on touchpad clicking but not on trying to move the curser. Kernel version 5.9.16-1. I had decided to just use a mouse, but then the touchpad started working after rebooting.