Touchpad not working on Lenovo Ideapad 320

xinput list output:

|⎡ Virtual core pointer                    |id=2|[master pointer  (3)]|
|---|---|---|
|⎜   ↳ Virtual core XTEST pointer              |id=4|[slave  pointer  (2)]|
|⎜   ↳ SteelSeries SteelSeries Rival 600       |id=9|[slave  pointer  (2)]|
|⎜   ↳ SteelSeries SteelSeries Rival 600       |id=10|[slave  pointer  (2)]|
|⎣ Virtual core keyboard                   |id=3|[master keyboard (2)]|
|    ↳ Virtual core XTEST keyboard             |id=5|[slave  keyboard (3)]|
|    ↳ Power Button                            |id=6|[slave  keyboard (3)]|
|    ↳ Video Bus                               |id=7|[slave  keyboard (3)]|
|    ↳ Power Button                            |id=8|[slave  keyboard (3)]|
|    ↳ EasyCamera: EasyCamera                  |id=11|[slave  keyboard (3)]|
|    ↳ Ideapad extra buttons                   |id=12|[slave  keyboard (3)]|
|    ↳ AT Translated Set 2 keyboard            |id=13|[slave  keyboard (3)]|
|    ↳ SteelSeries SteelSeries Rival 600       |id=14|[slave  keyboard (3)]|

I tried installing the synaptics package but that did not work.

Touchpad worked fine on Windows 10 so I’m 100% it’s not dead.

plug a mouse in

That is the mouse. No touchpad is displayed in that xinput.
@Donatello4620 - Have a look here:
https://bugzilla.kernel.org/show_bug.cgi?id=151681
Not very conclusive but you might have to go by blacklisting i2c_hid too, then the synaptics driver might work.

Could you guide me how to do that exactly?

Not sure what is the cause in your case. There is a discussion here:


With another hint in the next comment. I think if you blacklist the i2c_hid we could see if the xinput will list the touchpad or not.
Try first from terminal:

sudo echo "blacklist i2c_hid" | sudo tee -a /etc/modprobe.d/blacklist.conf

that will create the file and set the blacklist to i2c_hid
reboot and report the output of xinput so we know if we move to the next step and how.

|⎡ Virtual core pointer                    |id=2|[master pointer  (3)]|
|---|---|---|
|⎜   ↳ Virtual core XTEST pointer              |id=4|[slave  pointer  (2)]|
|⎜   ↳ SteelSeries SteelSeries Rival 600       |id=9|[slave  pointer  (2)]|
|⎜   ↳ SteelSeries SteelSeries Rival 600       |id=10|[slave  pointer  (2)]|
|⎣ Virtual core keyboard                   |id=3|[master keyboard (2)]|
|    ↳ Virtual core XTEST keyboard             |id=5|[slave  keyboard (3)]|
|    ↳ Power Button                            |id=6|[slave  keyboard (3)]|
|    ↳ Video Bus                               |id=7|[slave  keyboard (3)]|
|    ↳ Power Button                            |id=8|[slave  keyboard (3)]|
|    ↳ EasyCamera: EasyCamera                  |id=11|[slave  keyboard (3)]|
|    ↳ Ideapad extra buttons                   |id=12|[slave  keyboard (3)]|
|    ↳ AT Translated Set 2 keyboard            |id=13|[slave  keyboard (3)]|
|    ↳ SteelSeries SteelSeries Rival 600       |id=14|[slave  keyboard (3)]|

You still have no touchpad in xinput output … so, does your laptop have a Fn+Fx (where x can be one of the numbers) to enable and disable the touchpad? Some options in bios to enable/disable it? What happens if you boot without the mouse connected?

I pressed fn+f6 (which has a touchpad symbol on it) but nothing happened
Tried every other fx key but still nothing … :confused:

if i boot without the mouse connected the problem presists.

did you check the xinput output ? I know is not working, but at least see if is detected.
Copy the output from terminal of:
mhwd -lh -d
and paste it to https://pastebin.com/ then share it here. I’ll take a look at it …

  • Yes I did, after every key press.

https://pastebin.com/Uch3PUZL

:slight_smile: Not there …
By any chance you have dual boot with some Windows? If yes, bot into windows and get the device ID for that toucpad. Also, make sure when you want to boot into Manjaro to shutdown Win, NOT reboot.
If you don;t have dual boot with Windows, boot in live media installer, without the mouse connected and let me know if there is reported from xinput or not.

in the manjaro live installer?
just a sidenote that it didn’t work there aswell

Just solved it by installing the 4.18 kernel.

However though, tap does not work, i have to manually use the left or right button on the touchpad to click on something.

Seeing this kernel is still experimental I’m guessing that will be resolved later on???
edit: nvm. the tapping does work if you enable it in the settings.

Elantech touchpad detected. It should work in 4.17, but will get better in newer ones. This touchpad vendor has started to conquer laptops since 3-4 years ago, for reasons I don’t know (cheaper, perhaps?). They don’t provide Linux support at all, so volunteers implement the driver on their own.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.