Touchpad not recognized on KDE using Wayland

When running Wayland on KDE, my laptop (Dell G7 7588) doesn’t properly recognize the touchpad. It’s still usable, but most features don’t work (including, but not limited to, tap to click). This error doesn’t happen when running an X11 session. If I go to the Touchpad settings in System Settings, there is a red error message that says “No touchpad found”.

I have tried the solution here found here, but it didn’t resolve the issue.

Adding this edit a year after the fact because the moderator response and self-selected “solution” still doesn’t sit well with me–

The response of “file the bug in the correct place, and if you don’t know how, get bent” is incredibly frustrating. Behavior like this in this forum is a big reason why I no longer recommend Manjaro to people. If you had linked the KDE bug tracker, the condescending tone could’ve been somewhat excusable as I could have gone and filed the bug in the correct place and talked with more professional individuals.

I certainly could’ve just intuited where I needed to go (which I incorrectly, but understandably, assumed would be the KDE GitHub issue board), but that kind of defeats the purpose of asking questions, doesn’t it?

Wayland is now the default Window Manager under Gnome but just an option under KDE to allow developers to run it and fix bugs.

  • If you’re a developer: You know that you should be filing a bug upstream.
  • If you’re not a developer, avoid Wayland like the plague COVID-19 :grin: and go back to Xorg.


I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back to your question after your issue has been solved and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

I’ve been running Plasma wayland on my laptop for a while and I have also seen this issue.

Well, not exactly your issue. In my case the touchpad does not work at all. :slight_smile:

It does not happen all the time, but once in a while it does. A reboot usually “fixes” it, but it is weird.

1 Like

Yeah, but you’re a dev!


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.