Touchpad lagging in Gnome

When I move my mouse cursor with touchpad from time to time (it’s very noticeable) my cursor stops moving. It freezes.

I usually use KDE plasma but I have problems with scaling there and I have touch screen in my laptop so I would like to give Gnome a chance.
I thought that It can be Wayland fault but In plasma Waland there is no problem.

:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    How to provide good information
    and press the three dots below your post and press the :pencil2: to give us more information so we can see what’s really going on.
    Now we know the symptom of the disease, but we need some more probing to know where the origin lies… :grin:
  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information for us to be able to help you. (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.


  Kernel: 5.13.15-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC 
  misobasedir=manjaro misolabel=MANJARO_GNOME_2113 quiet systemd.show_status=1 
  driver=nonfree nouveau.modeset=0 i915.modeset=1 radeon.modeset=1 
  Desktop: GNOME 40.4 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 40.1 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Convertible System: Acer product: Spin SP513-55N v: V1.16 
  serial: <filter> 
  Mobo: TGL model: Milgauss_TL v: V1.16 serial: <filter> UEFI: Insyde v: 1.16 
  date: 07/27/2021 
  ID-1: BAT0 charge: 29.6 Wh (53.7%) condition: 55.1/56.0 Wh (98.5%) 
  volts: 15.2 min: 15.4 model: SMP KT00407008 AP18C7M type: Li-poly 
  serial: <filter> status: Discharging 
  RAM: total: 15.43 GiB used: 2.82 GiB (18.3%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: Quad Core model: 11th Gen Intel Core i7-1165G7 bits: 64 type: MT MCP 
  arch: Tiger Lake family: 6 model-id: 8C (140) stepping: 1 microcode: 88 
  cache: L2: 12 MiB bogomips: 44864 
  Speed: 969 MHz min/max: 400/4700 MHz Core speeds (MHz): 1: 969 2: 464 3: 563 
  4: 881 5: 975 6: 455 7: 526 8: 870 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_capabilities 
  arch_perfmon art avx avx2 avx512_bitalg avx512_vbmi2 avx512_vnni 
  avx512_vp2intersect avx512_vpopcntdq avx512bw avx512cd avx512dq avx512f 
  avx512ifma avx512vbmi avx512vl bmi1 bmi2 bts cat_l2 cdp_l2 clflush 
  clflushopt clwb cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl 
  dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma 
  fpu fsgsbase fsrm fxsr gfni ht hwp hwp_act_window hwp_epp hwp_notify 
  hwp_pkg_req ibpb ibrs ibrs_enhanced ida intel_pt invpcid invpcid_single 
  lahf_lm lm mca mce md_clear mmx monitor movbe movdir64b movdiri msr mtrr 
  nonstop_tsc nopl nx ospke pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge 
  pku pln pni popcnt pse pse36 pts rdpid rdrand rdseed rdt_a rdtscp rep_good 
  sdbg sep sha_ni smap smep split_lock_detect ss ssbd sse sse2 sse4_1 sse4_2 
  ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer 
  tsc_known_freq umip vaes vme vmx vnmi vpclmulqdq vpid x2apic xgetbv1 xsave 
  xsavec xsaveopt xsaves xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] 
  vendor: Acer Incorporated ALI driver: i915 v: kernel bus-ID: 0000:00:02.0 
  chip-ID: 8086:9a49 class-ID: 0300 
  Device-2: Chicony HD WebCam type: USB driver: uvcvideo bus-ID: 3-6:3 
  chip-ID: 04f2:b5c5 class-ID: 0e02 serial: <filter> 
  Display: wayland server: 1.20.13 compositor: gnome-shell driver: 
  loaded: i915 note: n/a (using device driver) - try sudo/root display-ID: 0 
  resolution: <missing: xdpyinfo> 
  OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 21.2.1 
  direct render: Yes 
  Device-1: Intel Tiger Lake-LP Smart Sound Audio 
  vendor: Acer Incorporated ALI driver: sof-audio-pci-intel-tgl 
  alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 0000:00:1f.3 
  chip-ID: 8086:a0c8 class-ID: 0401 
  Sound Server-1: ALSA v: k5.13.15-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: yes 
  Sound Server-4: PipeWire v: 0.3.35 running: no 
  Device-1: Intel Wi-Fi 6 AX201 vendor: Rivet Networks driver: iwlwifi 
  v: kernel port: 3000 bus-ID: 0000:00:14.3 chip-ID: 8086:a0f0 class-ID: 0280 
  IF: wlp0s20f3 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8 
  bus-ID: 3-10:4 chip-ID: 8087:0026 class-ID: e001 
  Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends 
  Message: No logical block device data found. 
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd 
  v: 0.6 port: 3000 bus-ID: 0000:00:0e.0 chip-ID: 8086.9a0b rev: 
  class-ID: 0104 
  Local Storage: total: 960.17 GiB used: 0 KiB (0.0%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung 
  model: SSD 970 EVO Plus 1TB size: 931.51 GiB block-size: physical: 512 B 
  logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> 
  rev: 2B2QEXM7 temp: 33.9 C scheme: GPT 
  ID-2: /dev/sda maj-min: 8:0 type: USB vendor: SanDisk model: USB 3.2Gen1 
  size: 28.65 GiB block-size: physical: 512 B logical: 512 B type: N/A 
  serial: <filter> rev: 1.00 scheme: MBR 
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
  Message: No optical or floppy data found. 
  Message: No partition data found. 
  Alert: No swap data was found. 
  ID-1: /dev/nvme0n1p1 maj-min: 259:1 size: 500 MiB fs: vfat label: N/A 
  uuid: 326C-52CA 
  ID-2: /dev/nvme0n1p2 maj-min: 259:2 size: 431 GiB fs: ntfs label: WIN10 
  uuid: FC346C52346C11C6 
  ID-3: /dev/sda1 maj-min: 8:1 size: 2.9 GiB fs: iso9660 
  ID-4: /dev/sda2 maj-min: 8:2 size: 4 MiB fs: vfat label: MISO_EFI 
  uuid: E45F-2361 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 1 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Hub-3: 3-0:1 info: Full speed (or root) Hub ports: 12 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 3-1:2 info: Elan Micro ELAN:Fingerprint type: <vendor specific> 
  driver: N/A interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 100mA 
  chip-ID: 04f3:0c4f class-ID: 0000 
  Device-2: 3-6:3 info: Chicony HD WebCam type: Video driver: uvcvideo 
  interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 04f2:b5c5 
  class-ID: 0e02 serial: <filter> 
  Device-3: 3-10:4 info: Intel AX201 Bluetooth type: Bluetooth driver: btusb 
  interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0026 
  class-ID: e001 
  Hub-4: 4-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Device-1: 4-2:2 info: SanDisk Ultra Fit type: Mass Storage 
  driver: usb-storage interfaces: 1 rev: 3.2 speed: 5 Gb/s power: 896mA 
  chip-ID: 0781:5583 class-ID: 0806 serial: <filter> 
  System Temperatures: cpu: 47.0 C mobo: 31.0 C 
  Fan Speeds (RPM): N/A 
  Processes: 289 Uptime: 11m wakeups: 722 Init: systemd v: 249 tool: systemctl 
  Compilers: gcc: N/A Packages: pacman: 1182 lib: 293 flatpak: 0 Shell: Zsh 
  v: 5.8 running-in: gnome-terminal inxi: 3.3.06

I would try kernel 5.14 first and 5.10 next because of this. (a long article, but the link above is for the chapter you need to read.)

Also: are you running this from a live ISO? Because then you won’t be able to install any other kernels…


Yes it is the live system. But problem was the same in regular one.

I currently use KDE edition which is my favorite distro. Sadly in kde I have problem with scaling (its hidpi laptop).
Firefox is blurred (I managed to fix this)
Libtroffice don’t scale well.
And the worst is the problem with Virtualbox. Main window and guests are blurred.

Because of this gnome seems the best option. Firefox work out of the box, libreoffice has blurry interface but I have to live with this, and most importantly virtualbox works almost ok. Main window is sharp. Guest machines don’t have scaling but maybe I will be able to find the solution.

I don’t want to have two DEs so I can create system snpshot, install gnome and check how it work with other kernels

The oldest trick in the book is to lower the resolution: higher speed, better visibility!

But there you can:


Higher speed - true
But lower resolution = blurry interface

1 Like

Any update on this?
I seem to have the same problem on a brand new LG GRAM 16: I’ve installed Kubuntu and everything runs smooth, today I tried installing Manjaro GNOME and I see this evident lag when I move the touchpad. I tried both with X11 and Wayland and I basically see no difference

Solution: Manjaro KDE! :grin:

Not the perfect solution because I have HiDPI screen - problems with Firefox (was able to solve it), problems with LibreOffice and Virtualbox.
LO problems I was able to partially solve, but with VB I couldn’t find the solution.

Nothing new I’m affraid.
On Gnome I have lags. On Plasma, I have HiDPI issues.

1 Like

Yeah, you don’t like lowering your resolution, just responding to @lorebett


Just to be sure that I understand you.

I use computers for… a very long time.
There is something like native resolution.

If a screen native resolution is for example 1024x768, and you set it to 800x600 then everything on the screen is going to be larger but 800x600 is going to be upscaled to your screen size and that will produce a blurry picture.
This is what you want me to do?

I wanted to change resolutions just to be sure that it actually is blurred. But I can’t.
In Plasma settings I can change with scaling set up to 200% then the thumbnail says that resolution is:

When I change the scaling to 100% then “Laptop screen” shows 2256x1504
And I can’t choose anything in resolution setting

What I said was:

So on a laptop screen: most of the time, as they mostly only support 1 native resolution
On an external monitor: no, as they support multiple native resolutions:

E.G. in the below 3-monitor set-up:

xrandr -q
Screen 0: minimum 320 x 200, current 4480 x 1080, maximum 2560 x 2048
VGA connected 1280×768+1280+0 (normal left inverted right x axis y axis) 370mm x 222mm
   1280×768       59.9*+
   1280×960       60.0
   1280×720       75.0     60.0
   1024×768       75.0     72.0     70.1     60.0
   832×624        74.6
   800×600        72.2     75.0     60.3     56.2
   640×480        75.0     72.8     75.0     66.7     59.9
   720×400        70.1
LVDS connected 1280×800+0+0 (normal left inverted right x axis y axis) 380mm x 216mm
   3840×2160     144.0
   1280×800       60.0*+
   1024×768       60.0
   800×600        60.3
   640×480        59.9
DP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 382mm x 215mm
   1920x1080     60.02*+
  • The VGA monitor is running at 1280×768 instead of 1280×960 (its maximum)
  • The LVDS is running at 1280×800 instead of UHD (“4K”)
  • The laptop screen is running its only resolution it has.

But glxgears running on all 3 monitors is the same physical size.

If that is not good enough for you, xrandr has some scaling options as well:

   --scale x[xy]
          Changes  the  dimensions of the output picture.  If the y value
          is omitted, the x value will be used for both dimensions.  Val‐
          ues larger than 1 lead to a compressed screen (screen dimension
          bigger than the dimension of the output mode), and values  less
          than  1  lead to a zoom in on the output.  This option is actu‐
          ally a shortcut version of the --transform option.

   --scale-from wxh
          Specifies the size in pixels of the area of the framebuffer  to
          be  displayed on this output.  This option is actually a short‐
          cut version of the --transform option.

But you need to take a mathematical approach to your issue:

  • measure the physical size of your monitors,
  • divide by the number of pixels and then you get your DPI. (Dots Per Inch).
  • then scale down the highest resolution monitor so that it coincides with the lowest one.

Please note tha scaling can do only so much, so if you have a 31" FHD TV and a 13" UHD laptop, no amount of scaling is going to get you a satisfactory result: you have to sync your purchases to their physical constraints.


I think it’s really a problem of the kernel: I haven’t tried Manjaro KDE but I doubt that’d solve the problem.

On my computer the problem is completely solved by updating to Kernel 5.14! :slight_smile:

sudo mhwd-kernel --install linux514   

Not only the touchpad lagging went away: updating to that kernel also solved many repainting issues I was experiencing before :smiley:

On Kubuntu the kernel is 5.11, while by default on Manjaro is 5.13. I think the problem was really in kernel 5.13

1 Like

Actually I haven’t spoken about HDPI myself, but since you mention it, I found out that on this LG GRAM 16, the default resolution 2560x1600 (16:10) is not really manageable on GNOME: I can set the font scaling to 1.50 and that would be fine, but then QT applications (e.g., Kate or Albert) get really too big. Setting the font to something less makes most things unreadable. The solution I found was to set the resolution a little bit lower 1920x1200 (16:10) and font scaling to 1.30. With that, everything looks fine and I see no real blur with this lower resolution.

Comparing that with KDE (again Kubuntu, but I guess that’d work also with Manjaro KDE) I can leave the resolution to default one and I set the scaling to 175% and everything is fine (also with GTK applications).

Once again, looks like KDE can handle HDPI better than Gnome :wink: