Touchpad is unresponsive after updating

I updated my installation a week ago. After updating I closed the lid for about half an hour. After resuming from sleep the touchpad has been completely unresponsive and somehow it has persisted into my windows 10 installation. Does anybody know how to troubleshoot this? I’m desperate at this point.
Thanks in advance.

Does this also prevent the machine from going back into sleep mode?

… Without knowing what hardware you have, a stab in the dark:
sudo modprobe -r psmouse && sudo mpdprobe -a psmouse
A similar command may be appropriate depending on which touchpad you have.

Also, please have a read of this as it may help you to help us to help you:
How to provide good info :slight_smile:

It doesn’t prevent the machine from sleeping.
Thanks for your help but the psmouse commands didn’t seem to fix the problem.

  Kernel: 5.9.1-1-rt19-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-rt-x86_64 
  root=UUID=9aca094d-7ebe-4608-81e3-e63dc81f78be rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: KDE Plasma 5.20.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 
  dm: SDDM Distro: Manjaro Linux 
  Type: Laptop System: Acer product: Aspire A515-51G v: V1.15 serial: <filter> 
  Mobo: KBL model: Charmander_KL v: V1.15 serial: <filter> UEFI: Insyde 
  v: 1.15 date: 01/08/2018 
  ID-1: BAT1 charge: 23.7 Wh condition: 37.4/48.9 Wh (76%) volts: 16.4/15.2 
  model: COMPAL PABAS0241231 type: Li-ion serial: <filter> status: Charging 
  Info: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP 
  arch: Kaby Lake family: 6 model-id: 8E (142) stepping: A (10) microcode: E0 
  L2 cache: 6144 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 28808 
  Speed: 700 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 765 2: 797 3: 769 
  4: 745 5: 781 6: 745 7: 732 8: 780 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel UHD Graphics 620 vendor: Acer Incorporated ALI driver: i915 
  v: kernel bus ID: 00:02.0 chip ID: 8086:5917 
  Device-2: NVIDIA GP108M [GeForce MX150] vendor: Acer Incorporated ALI 
  driver: N/A alternate: nouveau bus ID: 01:00.0 chip ID: 10de:1d10 
  Device-3: Chicony HD WebCam type: USB driver: uvcvideo bus ID: 1-7:5 
  chip ID: 04f2:b5f7 
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: modesetting 
  display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x193mm (13.5x7.6") 
  diag: 394mm (15.5") 
  OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.2.3 
  direct render: Yes 
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Acer Incorporated ALI 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:9d71 
  Sound Server: ALSA v: k5.9.1-1-rt19-MANJARO 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Acer Incorporated ALI driver: r8169 v: kernel port: 3000 
  bus ID: 02:00.1 chip ID: 10ec:8168 
  IF: enp2s0f1 state: down mac: <filter> 
  Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter 
  vendor: Lite-On driver: ath10k_pci v: kernel port: 3000 bus ID: 03:00.0 
  chip ID: 168c:0042 
  IF: wlp3s0 state: up mac: <filter> 
  Device-3: Lite-On Qualcomm Atheros QCA9377 Bluetooth type: USB driver: btusb 
  bus ID: 1-5:4 chip ID: 04ca:3015 
  Local Storage: total: 2.05 TiB used: 1.85 TiB (90.0%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda vendor: Micron model: 1100 MTFDDAV256TBN size: 238.47 GiB 
  block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s serial: <filter> 
  rev: A020 scheme: GPT 
  ID-2: /dev/sdb type: USB vendor: Seagate model: Expansion size: 1.82 TiB 
  block size: physical: 4096 B logical: 512 B serial: <filter> rev: 0710 
  scheme: MBR 
  ID-1: / raw size: 35.26 GiB size: 34.46 GiB (97.72%) used: 26.38 GiB (76.6%) 
  fs: ext4 dev: /dev/sda5 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 54.0 C mobo: 27.8 C 
  Fan Speeds (RPM): N/A 
  Processes: 265 Uptime: 6m Memory: 7.65 GiB used: 2.06 GiB (26.9%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: 1335 pacman: 1327 
  lib: 363 flatpak: 0 snap: 8 Shell: Bash v: 5.0.18 running in: konsole 
  inxi: 3.1.08 

I came upon this discussion that seems similar to my problem but I’m not sure:

Does sudo rmmod i2c_hid && sudo modprobe i2c_hid solve the problem?

1 Like

I’d suggest that too along eith trying other kernels i.e. one of the LTS versions and not necessarily the latest version thereof. I have experienced issues with Acer Asppire trackpads (also Toshiba ones) and this might also be the case with the OP’s machine.

Plus those ACPI issues on the Toshiba machines… but that’s a subject for another thread …

I’ve tried pobrn’s solution and downgrading the kernel to 5.4 LTS but still no luck. At this point I don’t even care if I have to wipe my Manjaro installation and start over. I just need it to start working again in Windows.