Touch input for Dolphin etc. doesn't open the OSK due to wrong default values

Hi everyone,
I noticed that touch input for the Dolphin search bar doesn’t open the on-screen keyboard (OSK) due to a wrong default value of gtk-im-module.
You can check the value using this command dconf-editor /org/gnome/desktop/interface/gtk-im-module.
If it says gtk-im-context-simple you are likely also affected. Only wayland works with touch input.

I originally came from this issue in the Gnome bug tracker: OSK auto-open behaviour is inconsistent for nautilus and firefox (#6278) · Issues · GNOME / gnome-shell · GitLab
One dev recommended me that I should report this issue to the Manjaro team.
I decided to post it on the forums, because I’m not sure if this is really an issue that Manjaro can and wants to solve.

So if anybody can reproduce this, see it as some kind of “unofficial bug report”.

I don’t remember why we had gtk-im-module set to 'gtk-im-context-simple'. Apparently it’s not set by default. I’ve just removed it with manjaro-gnome-settings 20230316-1.

Great, thank you.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.