Отвалился интернет после перезагрузки


#21

О да, мне уже весело)))
В общем, не знаю зачем, но ради этого конфига я пезагрузил комп и вошел в линукс (хотя мог это сделать с винды, специально для таких целей установил ext2fsd), и пока интернет не пропал, успел выложить ссылку!:
https://pastebin.com/59SB9x9t


#22

Интересный кусочек… Мне к нему прислушаться?
[2017-08-10 12:04] [ALPM-SCRIPTLET] ************************************************************
[2017-08-10 12:04] [ALPM-SCRIPTLET] Remember to enable DKMS at boot with “systemctl enable dkms”
[2017-08-10 12:04] [ALPM-SCRIPTLET] ************************************************************


#23

Да да, там ещё нехватает linux49-headers. linux-rt-lts-manjaro-headers есть, значит должно было работать, елси бы загружалось ядро linux-rt-lts-manjaro. И кроме того была бы задана комманда sudo systemctl enable dkms.

пакет, который мог ухудшить ситуацию после апдейта - linux-firmware. можно попробовать
downgrade linux-firmware


#24

Интересности тут, не находит dkms сервис:
systemctl start dkms
Failed to start dkms.service: Unit dkms.service not found.
linux49-headers установил (linux-rt-lts-manjaro-headers снесся автоматом).

EDITED: Воу, воу, запустил speedtest, и я пожалуй сохраню тут ссылочку, чтоб я хотя-бы потом не думал что такая скорость это мой мираж! Конечно не те 44мб/сек. загрузка, но по сравнению с обычными ~5-7мб/сек. это просто небо и земля! http://beta.speedtest.net/result/6528303409


#25

надо наверно dkms установить


#26

Кароче, со скоростью непонятно что творится, сразу после запуска она иногда выдает такие результаты, что прямо диву дивуюсь, а вот через какое-то время - стабильные 5-7мб/сек…
И еще хорошая новость, я нашел способ “починить” интернет после того как все сети пропадают, просто выключить-включить вайфай кнопкой на клаве… Но разумеется помогает не на долго…
dkms сейчас установлю!


#27

Я просто подумал, раз оно мне предлогало его запустить, значит должен быть уже установлен)


#28

но в конце лога написано
[2017-08-10 12:15] [ALPM] removed dkms (2.4.0-2)


#29

Установил я dkms с пакет менеджера и…
Ничего не поменялось…
Подумал я что надо перезагрузить систему, перезагрузил, и…
Ничего не поменялось…
Все также говорит что unit dkms бла-ба-бла не найден!


#30

Ааа, понял, не заметил(


#31

нужно
sudo systemctl enable dkms
sudo systemctl start dkms


#32

До этого делал
sudo -i
systemctl start dkms
Теперь попробовал sudo systemctl start dkms - все тоже самое(
На всякий случай, вот скрин что dkms установлен: https://imgur.com/xCIgIkel.png


#33

а может и не надо его активировать через systemctl, Arch Wiki ничего об это не упоминает
https://wiki.archlinux.org/index.php/Dynamic_Kernel_Module_Support
https://wiki.archlinux.org/index.php/Dynamic_Kernel_Module_Support_(Русский)

просто поробуйте теперь установить rt3290sta-dkms
потом blacklist как выше и

sudo modprobe -r rt2900pci
sudo modprobe -r rt2800pci

и если следующий комманды нет в пакете

sudo dkms autoinstall

#34

Окей, рискну)


#35

Установил я dkms до того как вы дописали остальное, и результат уже “привычный”, все сети пропали…
Попробую снова установить, но дописав команды
sudo modprobe -r rt2900pci и sudo dkms autoinstall


#36

Установил rt3290sta-dkms, затем прописал это:
$ sudo modprobe -r rt2900pci
modprobe: FATAL: Module rt2900pci not found.
$ sudo modprobe -r rt2800pci
$ sudo dkms autoinstall
Перезагрузил - все “стандартно” сетей просто не было…


#37

вроде всё правильно, значит просто драйвер не работает.

попробуйте на авось downgrade linux-firmware.


#38

Говорит не такой команды…


#39

да нужно на будущее установить пакет downgrade

но можно и мануально
ls /var/cache/pacman/pkg/ | grep linux-firmware
у меня

eugen@mjaro ~> ls /var/cache/pacman/pkg/ | grep linux-firmware
linux-firmware-20170422.ade8332-1-any.pkg.tar.xz
linux-firmware-20170622.7d2c913-1-any.pkg.tar.xz
sudo pacman -U /var/cache/pacman/pkg/linux-firmware-20170422.ade8332-1-any.pkg.tar.xz

#40

Так, окей, откатил, что дальше? Пробовать еще раз установить тот rt3290sta-dkms?