搜狗拼音输入法安装问题


sudo pacman -S fcitx-sogoupinyin安装搜狗输入法,显示Couldn't determine full name for SGPYEUDC_1.TTE Couldn't get family name for SGPYEUDC_1.TTE
如何解决?

你的fcitx-sogoupinyin是從哪裡來的?Manjaro的repo裡面好像沒有?

archlinuxcn源

我安装也是这样的问题,死活无法输入中文,也无法切换输入法

我可以切换,但是使用的时候,没法弹出文字题词框

看这个能帮吗?

https://wiki.archlinux.org/index.php/Fcitx#Firefox_popup_menu_not_work

谢谢!这个网页也未提供想要的答案。问题应该出在安装最后的提示上
(8/8) Updating X fontdir indices...
Couldn't determine full name for SGPYEUDC_1.TTE
Couldn't get family name for SGPYEUDC_1.TTE

了解, 在ubuntu比较容易

https://pinyin.sogou.com/linux/?r=pinyin
http://ubuntuhandbook.org/index.php/2016/07/2-best-chinese-pinyin-im-ubuntu-16-04/

fcitx and KDE

For some reasons, KDE doesn't handle keyboard layouts properly. For example, if you switch from US (English) to LT (Lithuanian), all numbers on the keyboard should produce Lithuanian letters, but they still produce numbers as the output. This can be fixed by these steps:

  1. Turn off fcitx if it is running in the background.
  2. Disable stuff related to KDE:
  3. At System settings > Input devices > Layouts (tab) make sure that Configure layouts is unchecked.
  4. At System settings > Input devices > Advanced (tab) make sure that Configure keyboard options is unchecked.
  5. Start fcitx to start it. You can close the terminal - fcitx will still be running in the background.
  6. Set up your needed layouts (right click on the system tray icon, then Configure ).
  7. Right click on the system tray icon, then Exit

At this point you should have working layouts, native KDE layouts switch icon should appear and you can switch them by mouse scroll or click on it.

這個提示應該是字體的問題,我認為跟輸入法無關

1 Like

Forum kindly sponsored by