Today's unstable update broke my system - need help restoring it

Today of all days when I'm of course in a hurry and have the last time my system broke although it was rock solid for 3 years.

The issue is: I see grub's background wallpaper infinitely and have no indications of what is happening.

I logged in to Manjaro chroot but:

  • timeshift is unable to find backups (the last time I tried it there was no problem with it)
  • timeshift segfaults
  • when I try to access files that I need quickly for today's work, Dolphin in live session hangs indefinitely after I try to access mounted hard drive and on next launch attempts still hangs
  • when I try to access my home folders in the terminal through midnight commander it shows empty, the same when I want to access another partition (hdd), also empty
  • when I installed timeshift in live system, it also can't find backups on external hard drive and some options like hamburger menu won't work after click
  • the whole live session seems to be malfunctioning somehow, although I used it in the past and it was working fine before
  • consequent boot into live hanged indefinitely on mhwd script although previous boot few minutes ago worked fine...

Uh.. and did I mentioned I had no time and was in a hurry? Great, problem after problem.

I have no time to look at it closely right now and I have to recreate those files again because this will be quicker.

Hopefully, I find time later to check out what is going on, but I can't focus solely on it. Please, if you have any idea how to approach it, that would be great. Maybe when I will be calmer and have more time things will work correctly but, as usually, if there is no time, mysterious issues pop-up magically... sight

Did you try booting into an older kernel or the fallback kernel.

There has been recent reports of issues accessing external drives related to new kernels as well as tlp.

I tried kernel 4.19, standard boot and the fallback one. The same reslt, grub wallpaper and the cursor. I can log in to tty, so it's not that bad. Maybe I will try timeshift from there and maybe I will have the access to the files, but without gui I won't send them to the cloud :frowning: to access them on another device.

EDIT 1: From tty I can access timeshift and restore points but it always segefaults in commandline :frowning: In the past the same was happening but was able to use GUI and there was no problem with gui option.
Why can't timeshift work in commandline? Can I fix it somehow?

EDIT 2: Situation seems to be fixed now... I checked the updates, few additional packages were updated, nothing serious (at the first glance) so I thought it won't change anything and yet, after reboot, I got into the X session, so all seems good... Maybe the previous update missed important packages? Like for example qt5 base, which came just right now, but not in the morning...

I guess I have to create another topic for this timeshift segefault problem

I'm staying on unstable for the time being for the quickest Plasma 5.16 fixes. Testing seems to be so much more stable.

1 Like

Sounds like a partial update caused by mirror not completely synced.

Glad you are back up though ... testing branch is the best sweet spot for a primary system.

You can still get major Plasma upgrades earlier, just briefly switch branches to unstable and update, then change back to testing. This is what I did for 5.16 on my primary desktop ... after confirming on VM.

This is why clonezilla for image backups and rsync for file backups are a better option ... more reliable IMHO ... especially on encrypted systems where timeshift complains about encrypted /boot.

1 Like

I just did a dd image of /root and /home in 5 minutes rebooted and was running the image to test it out. There's no excuse for not imaging it's near failsafe.

1 Like

Yeah, probably that was the case.

The funny thing is: my system is NOT ENCRYPTED. So I can easily access the backuped files from anywhere.

Anyway, since I can't relay on timeshift, I need to find a replacement but I will do it in a new topic. I'm not sure if clonezilla meets my requirements.

RedoBackup is getting very old, but on older systems it still works well. It is super easy to use for creating images.

As promised, I created a new, although a bit boring and repetitive topic. It shouldn't grow big, I just need some propositions that meet my criteria so I can test them out.