To proceed, or go back to XFCE? That is the question

Hello folks-

After running xfce for quite a while, I decided to check out KDE Plasma. I’m using a laptop I take when traveling, so data loss or having to reconfig is no issue.

My laptop is a Lenovo P50, with a 4K monitor. Built in hybrid graphics with Intel/Nvidia.

I’ve had a few issues after install that I’ve not been able to resolve. In order of importance:

  1. No openCL available for darktable
  2. SDDM login screen is tiny. I’ve tried all the remedies I could find, no luck. The screen is tiny only on initial login, if the system goes to sleep, login screen is normal
  3. Grub menu is also tiny. That I can fix
  4. Grub menu no longer offers me Win10 boot. Windows is installed on a separate drive.

I’m still a bit of a beginner after a couple years of Linux use, and just wonder if the fixes (especially for openCL are achievable.

Thanks in advance for any guidance you can give.

What models and what driver you have installed? At least share inxi -Fazy

With proprietary drivers you might have to run prime-run darktable so it used the dGPU.

osprober is disabled by default in grub, but there are plenty of topics about it.
Edit the file /etc/default/grub and either comment the line where is mentioned


or simply add it at the end of the file, then run from terminal:
sudo update-grub


Thanks for taking the time to look at my post and respond.
Here is the output of the inxi -Fazy command:

> System:
>   Kernel: 5.13.13-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
>   parameters: BOOT_IMAGE=/boot/vmlinuz-5.13-x86_64 
>   root=UUID=13fc5171-e156-474f-82d4-af57a7500345 rw quiet 
>   resume=UUID=fef66dcd-a848-45bd-836a-453f7973262a udev.log_priority=3 
>   Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM 
>   Distro: Manjaro Linux base: Arch Linux 
> Machine:
>   Type: Laptop System: LENOVO product: 20EQS42M00 v: ThinkPad P50 
>   serial: <filter> Chassis: type: 10 serial: <filter> 
>   Mobo: LENOVO model: 20EQS42M00 v: SDK0J40697 WIN serial: <filter> 
>   UEFI: LENOVO v: N1EET90W (1.63 ) date: 10/21/2020 
> Battery:
>   ID-1: BAT0 charge: 77.7 Wh (96.9%) condition: 80.2/90.1 Wh (89.1%) 
>   volts: 12.4 min: 11.4 model: LGC 00NY492 type: Li-poly serial: <filter> 
>   status: Unknown 
>   Device-1: hidpp_battery_0 
>   model: Logitech Marathon Mouse/Performance Plus M705 serial: <filter> 
>   charge: 100% (should be ignored) rechargeable: yes status: Discharging 
> CPU:
>   Info: Quad Core model: Intel Xeon E3-1505M v5 bits: 64 type: MT MCP 
>   arch: Skylake-S family: 6 model-id: 5E (94) stepping: 3 microcode: EA cache: 
>   L2: 8 MiB 
>   flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
>   bogomips: 44817 
>   Speed: 800 MHz min/max: 800/3700 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 
>   4: 801 5: 800 6: 800 7: 800 8: 800 
>   Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
>   Type: l1tf 
>   mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
>   Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
>   Type: meltdown mitigation: PTI 
>   Type: spec_store_bypass 
>   mitigation: Speculative Store Bypass disabled via prctl and seccomp 
>   Type: spectre_v1 
>   mitigation: usercopy/swapgs barriers and __user pointer sanitization 
>   Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
>   IBRS_FW, STIBP: conditional, RSB filling 
>   Type: srbds mitigation: Microcode 
>   Type: tsx_async_abort mitigation: Clear CPU buffers; SMT vulnerable 
> Graphics:
>   Device-1: Intel HD Graphics P530 vendor: Lenovo driver: i915 v: kernel 
>   bus-ID: 00:02.0 chip-ID: 8086:191d class-ID: 0300 
>   Device-2: NVIDIA GM107GLM [Quadro M2000M] vendor: Lenovo driver: nouveau 
>   v: kernel bus-ID: 01:00.0 chip-ID: 10de:13b0 class-ID: 0300 
>   Device-3: Chicony Integrated Camera type: USB driver: uvcvideo bus-ID: 1-8:3 
>   chip-ID: 04f2:b596 class-ID: 0e02 
>   Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: 
>   loaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1 
>   Screen-1: 0 s-res: 1440x810 s-dpi: 96 s-size: 380x214mm (15.0x8.4") 
>   s-diag: 436mm (17.2") 
>   OpenGL: renderer: Mesa Intel HD Graphics P530 (SKL GT2) v: 4.6 Mesa 21.2.1 
>   direct render: Yes 
> Audio:
>   Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: Lenovo 
>   driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a170 
>   class-ID: 0403 
>   Device-2: NVIDIA GM107 High Definition Audio [GeForce 940MX] 
>   driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:0fbc 
>   class-ID: 0403 
>   Sound Server-1: ALSA v: k5.13.13-1-MANJARO running: yes 
>   Sound Server-2: JACK v: 1.9.19 running: no 
>   Sound Server-3: PulseAudio v: 15.0 running: yes 
>   Sound Server-4: PipeWire v: 0.3.34 running: yes 
> Network:
>   Device-1: Intel Ethernet I219-LM vendor: Lenovo driver: e1000e v: kernel 
>   port: efa0 bus-ID: 00:1f.6 chip-ID: 8086:15b7 class-ID: 0200 
>   IF: enp0s31f6 state: up speed: 100 Mbps duplex: full mac: <filter> 
>   Device-2: Intel Wireless 8260 driver: iwlwifi v: kernel port: 4000 
>   bus-ID: 04:00.0 chip-ID: 8086:24f3 class-ID: 0280 
>   IF: wlp4s0 state: down mac: <filter> 
> Bluetooth:
>   Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 
>   bus-ID: 1-14:6 chip-ID: 8087:0a2b class-ID: e001 
>   Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends 
> Drives:
>   Local Storage: total: 2.3 TiB used: 6.88 GiB (0.3%) 
>   SMART Message: Unable to run smartctl. Root privileges required. 
>   ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: MZSLW1T0HMLH-000L1 
>   size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
>   lanes: 4 type: SSD serial: <filter> rev: 3L0QCXY7 temp: 32.9 C scheme: GPT 
>   ID-2: /dev/nvme1n1 maj-min: 259:4 vendor: Seagate model: XPG GAMMIX S50 Lite 
>   size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s 
>   lanes: 4 type: SSD serial: <filter> rev: 82A7T9PA temp: 33.9 C scheme: GPT 
>   ID-3: /dev/sda maj-min: 8:0 vendor: Kingston model: SA400S37480G 
>   size: 447.13 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
>   type: SSD serial: <filter> rev: 1103 scheme: GPT 
> Partition:
>   ID-1: / raw-size: 919.4 GiB size: 903.9 GiB (98.31%) used: 6.88 GiB (0.8%) 
>   fs: ext4 dev: /dev/nvme1n1p2 maj-min: 259:6 
>   ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) 
>   used: 288 KiB (0.1%) fs: vfat dev: /dev/nvme1n1p1 maj-min: 259:5 
> Swap:
>   Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
>   ID-1: swap-1 type: partition size: 34.17 GiB used: 0 KiB (0.0%) priority: -2 
>   dev: /dev/nvme1n1p3 maj-min: 259:7 
> Sensors:
>   System Temperatures: cpu: 40.0 C mobo: N/A gpu: nouveau temp: 40.0 C 
>   Fan Speeds (RPM): fan-1: 2328 fan-2: 2331 
> Info:
>   Processes: 266 Uptime: 2m wakeups: 3 Memory: 31.06 GiB used: 1.2 GiB (3.9%) 
>   Init: systemd v: 248 tool: systemctl Compilers: gcc: N/A Packages: 
>   pacman: 1042 lib: 294 Shell: Zsh v: 5.8 default: Bash v: 5.1.8 
>   running-in: konsole inxi: 3.3.06 

The Manjaro Hardware Configuration panel shows video linux installed for the Quadro M2000 display controller, and video-linux for the p530 Intel display controller

when doing the install, I chose the opensource drivers option.

Are there other drivers I need to install? I think when I installed the XFCE system after getting this computer, I followed the ArchWiki and got things working, but forgot what I did. I know I used prime-switch, and assigned darktable to the Nvidia card.

What I get when I run the darktable -d opencl in the terminal, I get this:

>    /etc/sddm.conf.d  darktable -d opencl                                                                                                                               ✔ 
> 0.148166 [opencl_init] opencl related configuration options:
> 0.148181 [opencl_init] 
> 0.148184 [opencl_init] opencl: 1
> 0.148186 [opencl_init] opencl_scheduling_profile: 'default'
> 0.148188 [opencl_init] opencl_library: ''
> 0.148190 [opencl_init] opencl_memory_requirement: 768
> 0.148193 [opencl_init] opencl_memory_headroom: 400
> 0.148195 [opencl_init] opencl_device_priority: '*/!0,*/*/*/!0,*'
> 0.148197 [opencl_init] opencl_mandatory_timeout: 200
> 0.148200 [opencl_init] opencl_size_roundup: 16
> 0.148201 [opencl_init] opencl_async_pixelpipe: 0
> 0.148203 [opencl_init] opencl_synch_cache: active module
> 0.148205 [opencl_init] opencl_number_event_handles: 25
> 0.148207 [opencl_init] opencl_micro_nap: 1000
> 0.148209 [opencl_init] opencl_use_pinned_memory: 0
> 0.148211 [opencl_init] opencl_use_cpu_devices: 0
> 0.148212 [opencl_init] opencl_avoid_atomics: 0
> 0.148214 [opencl_init] 
> 0.148323 [opencl_init] could not find opencl runtime library 'libOpenCL'
> 0.148386 [opencl_init] could not find opencl runtime library ''
> 0.148449 [opencl_init] could not find opencl runtime library ''
> 0.148461 [opencl_init] no working opencl library found. Continue with opencl disabled
> 0.148464 [opencl_init] FINALLY: opencl is NOT AVAILABLE on this system.
> 0.148467 [opencl_init] initial status of opencl enabled flag is OFF.

SDDM- Tried the Sync button, no effect with the default theme.

created and populated two files, dpi.conf and hidpi.conf, rebooted, still no change in SDDM.

I think I had this same problem when I first installed my XFCE system, and solved it by switching to lightDm. May have to go this route again.

GRUB seems to be ok, other than the small size which I can fix.

One other issue is kdeWallet doesn’t seem to respond to being disabled by the wallet manager panel. Comes up asking me for a password most any time I do something.

Thanks again for your time.

yeah, free drivers … not much of help from those.
Nvidia will always work best with proprietary drivers.

1 Like

So after two days of trying to get this install working, and reading the Arch wiki on OpenCL and Nvidia, I had to give it up.

I installed Linux mint for now, and it installed Nvida drivers and Optimus in the task bar as part of the installation follow up. Switched to the Nvidia card and after reboot, darktable worked with openCl perfectly. Wish it were that easy in Manjaro. We’ll see how it goes on the laptop. Still have Manjaro running well on my desktop (with an AMD radeon card).

It should be as simple as right clicking the proper driver in Manjaro Settings Manager, and clicking install, or installing the system with proprietary drivers.

It is, you just need to open Manjaro Hardware Detection GUI in Manjaro Settings Manager, and select proprietary.

Nope, that didn’t work at all. Even tried a reinstall choosing proprietary drivers, still failed to allow access to OpenCL.

What nags at me is that I had everything running when I first installed Manjaro on this machine last spring.

I definitely own the fail for screwing up my system, and not being able to restore it. But I just ran out of ideas on how to make it work.

Part of the problem is that there is so much information out there that it’s tough to sift through it all, and find solutions. Really felt like I went down the rabbit hole on this one guys!

Luckily, no info was lost. Chalk it up to a learning experience. Like I said, my desktop install of Manjaro XFCE works great. No Nvidia on that machine. It was a bit of work to get openCL working on it, but it was doable.

Also, a minor point is that the Mint install enabled the wifi from the start, No need to plugin to Ethernet for the initial install. Nice touch.

Thanks again for all the suggestions.

Oh, I forgot, you need the opencl-nvidia package as well.

This is why I just stick with AMD, haven’t had issues using darktable with AMD. I just needed to use the free/open source driver from the kernel (automatic), and install opencl-amd from AUR, and darktable works with opencl without issues. No other setup required for me.

Yeah, tried that as well, no love. With this laptop, the Nvidia card is what is.

I do have problems with darktable on the Manjaro desktop with the AMD when doing a large number of processed image exports. After about 5 images, it creates artifacts in the exported files. Turning off opencl in darktable remedies the problem at the expense of speed. This appeared after a recent update of the kernel, open-cl, and darktable so it’s tough to trouble shoot.