TLP downgrade after last update

I forgot that I disabled module-suspend-on-idle in PulseAudio configuration because of crackling when changing loudness or start playing sound after the last update. I found that the new TLP is the culprit. After downgrading I have no problems anymore.

Did you merge the pacnew file? Did you check what has changed with the update and what you might need to adjust in the configuration?

Downgrading is not a solution on a rolling release distro.

A post was merged into an existing topic: Unable to login in remotely using ssh using rsa keys after last update

Just curious - why is this forum thread marked as Solved?

1 Like

Probably because of the massive split of message and a bug in the matrix, no post here is marked as solution but probably bad timing when moving posts or something like that triggered a bug and marked the thread as solved, let me try to mark a post as solution if I can, and unmark it then and see if it fixes things…

//EDIT: yeah I fixed it :rofl:


Yep. There was nothing to merge, except the comments. But what has it to do with my issue?

I agree, absolutely correct. I’ve downgraded tlp as a workaround and to isolate the problem.

I doubt it as if I recall correctly, the whole file has changed.

That’s /etc/pamac.conf.pacnew, you want /etc/tlp.conf.pacnew.

There is of course no tlp.conf.pacnew, because I downgraded it. I’ll check it next days.

Are you seriously thinking checking the Pamac config file is what was talked about?

The TLP config file, check its .pacnew, not the Pamac config file…


1 Like

Same as posts above here and there, messages related to the Stable announcement thread itself are in this thread about TLP, also my message above yours was posted before the two others before it, the thread split/move is a mess I don’t know how it works on Discourse but it is always done in a weird way (on other forum engine I know, it is pretty basic, you select the messages to move, and move them).

I’ve moved it because this is the original thread talking about TLP. Do you want these split off as their own topic?


According to the TLP documentation, power saving mode for audio is now active on AC. Excerpt from doc:

Timeout (in seconds) for the audio power saving mode (supports Intel HDA, AC97). A value of 1 is recommended for Linux desktop environments with PulseAudio, systems without PulseAudio may require 10. The value 0 disables power save.

Default when unconfigured:

1 (AC), 1 (BAT) - Version 1.4 and higher
0 (AC), 1 (BAT) - Version 1.3.1 and lower

Power saving mode may cause slight clicks or other disturbances in sound output, see the FAQ: Audio

1 for AC is required for automatic power down of Nvidia Optimus GPUs with nouveau driver

The recommendation of 1 for PulseAudio originates from the pulseaudio-discussion mailing list

In my case, a desktop PC with 5.1 speakers, the “slight clicks or other disturbances” was a “CRKBOOM”.

Solution for my issue: I added a file /etc/tlp.d/10-powersave.conf with content SOUND_POWER_SAVE_ON_AC=0. Alternatively, the setting could be done in /etc/tlp.conf.

I don’t really want anything, just pointing out that the following messages

are not related to TLP but to the announcement thread itself, where they originated, and I don’t understand why they were moved in the TLP thread, to me that makes no sense. But I don’t really care anyway they can stay here.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.