TLP does not change value

I have this line in my tlp.conf:


but cat /sys/devices/system/cpu/cpu0/cpufreq/energy_performance_preference


Changing tlp.conf does nothing. It is as if something
is overriding the tlp.conf settings … I think this
used to work :frowning:

I wonder if anyone has seen anything like this?

Some info:

kernel: 5.7.17-2-MANJARO x86_64
cpu: i7-8650U
machine: ThinkPad X1 Carbon 6th

Did you try to restart the service? Also you can try tlpui it’s a gui for tlp and can do that easily

restarted service many time trying various changes to tlp.conf (many reboots too)

tlpui allows me to select different CPU_HWP_ON_BAT values but the “changes” window remains blank and there is no effect. As I said, I can manually change these
values in sys/devices …

EDIT: I just watched the value of sys/devices/system/cpu/cpu0/cpufreq/energy_performance_preference get over written when I restart tlp with
balance_power even though I had manually set it to performance and even
though both ENERGY_PERF_POLICY_ON_BAT=performance and
CPU_HWP_ON_BAT=performance in tlp.conf.

My thinkpad seems to be possessed :slight_smile: (what setting am I
missing here?)

Sorry to reply to myself - but in case it’s helpful:

Erasing tlp.conf and reinstalling tlp fixed things. I guess
I had an old tlp.conf that did not get changed when tlp
was updated at some time. The new default tlp.conf has
some changes and - bottom line - I can now control the
cpu policies again with tlp.