[TLP] 2018-01-24 - Call for testing: Adding `pcieport` to runtime PM blacklist

After reading this thread which links to https://bugs.freedesktop.org/show_bug.cgi?id=103783 , adding pcieport to the TLP default runtime PM driver blacklist setting might fix work around a class of bugs with newer hardware, both for failure to resume from suspend and graphics issues.

There’s a new package, version 1.1-1.0, in unstable which includes other updates make by upstream. However, the one to test here is a single-line change to /etc/default/tlp:

sudo sed -i '/#RUNTIME_PM_DRIVER_BLACKLIST/c RUNTIME_PM_DRIVER_BLACKLIST="amdgpu nouveau nvidia radeon pcieport"' /etc/default/tlp

or in context:

# Exclude PCI(e) devices assigned to the listed drivers from Runtime PM.
# Default when unconfigured is "amdgpu nouveau nvidia radeon" which
# prevents accidential power-on of dGPU in hybrid graphics setups.
# Use "" to disable the feature completely.
# Separate multiple drivers with spaces.
RUNTIME_PM_DRIVER_BLACKLIST="amdgpu nouveau nvidia radeon pcieport"

Please test this change on your system (including reboots and suspends), whether or not you currently have any issues, to see what effect it has.

In testing so far on my machines it has had negligible, if any, effect. Which is good, as my systems work fine to begin with. :wink:

However, it has fixed at least two issues on others’ machines (see linked thread).

Therefore, it needs wider testing to check that it doesn’t interfere with currently-working systems and what effect it might have on systems with suspend or graphics issues.


Development thread:


Does the change have any effect on your system?

  • Yes, positive effect (post)
  • Yes, negative effect (post)
  • No noticeable effect (post some inxi)

0 voters

so this only works for hybrid setups, right? onboard intel graphics should be fine regardless?

I’ve tested it on my X230 and it appears to make zero difference for an Intel-only system, and my GT70 behaves no differently, but that worked fine with bumblebee anyway. It should only really affect newer systems (with hybrid graphics?) - but I don’t know, hence the “call for testing”. :wink:

I have an intel only system as well but for me (it seemingly) had a change - as I run gnome-shell under wayland someone else mileage may vary :wink:
But for me it - fixed ™ - the issue that after suspend to ram - when woken up again the lock screan was tearing as if the graphics buffer was read in a wired way;

(sorry hard to describe, it was flickering and the image was like torn apart and stiched together after a tour in a randomness generator)

But since I added pcieport to the blocklist as @jonathon suggested in the initial thread (he linked above) the issue is gone. No more tearing after resuming =D

Graphics:  Card: Intel HD Graphics 5500
           Display Server: wayland (X.Org 1.19.6 )
           drivers: intel (unloaded: modesetting,fbdev)
           Resolution: 1920x1080@59.96hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 5500 (Broadwell GT2)
           version: 4.5 Mesa 17.3.2
1 Like

After last update (19.01.2018) I start to have troubles with logging in my session after laptop’s sleep (>15 mins in idle state).
This workaround helped me.
I’m on Laptop with Intel 7th gen Graphics only. Kernel 4.14.
Thanks!

New package version 1.1-1.0 is on its way to unstable. This is based on the fresh TLP 1.1 release.

Is any effect on hibernation expected? Suspend works but I have troubles with the former and my system is quite new™

Only one way to check. :wink:

I completely remove TLP because I couldnt run Notebook Fan Controller NBFC because of TLP

@lxdlam You posted this change had a negative effect - what was it?

@mgundogdu Did you remove TLP after making this change? Or did you remove TLP before that to fix this other problem?

As I metioned in my last post, it caused that I can’t boot my computer in both situation.

So by removing this setting you can boot?

Yes. It back to the previous problem.

After installing and configuring NBFC I coudnt start the program but after removing TLP I could enabling NBFC smoothly.

OK - was that related to adding pcieport to the runtime PM blacklist?

Keep in mind that nbfc is an AUR package; I suspect it will (understandably) conflict with TLP’s power management.

1 Like

Hi, sorry for late response.
I have enabled ‘pcieport’ and nothing special happend, my computer runs smoothly.
It works fine in both reboot and suspend.

1 Like

I run NBFC together with TLP and have no problems. I can check if there’s some settings which I tweaked to avoid conflicts.

2 Likes

Haven’t seen anything which might conflict.
EDIT: note I don’t have the pcieport exclusion, so I’m not sure if that’s an issue or not.

Soooo… would you be able to test that?

Yes, give me a moment.

1 Like

Forum kindly sponsored by Bytemark