Timeshift restore broke GRUB : 'grub_key_is_interrupt'


#1

Anyone knows how to fix it? I did not expected a system restore to break my system. :frowning:


#2

need a bit more to go on.
did you restore because of a broken installation? if so what was wrong?
was grub working just before restore?
did you choose the option to restore grub when you started the restore?

for now you could see it your able to use a manjaro live usb to detect your current install and boot or you can load the live environment then:
manjaro-chroot -a
and depending on if you use uefi or bios (different procedure), restore grub from chroot.


#3

I had a perfectly-ish fine working system. I did s timeshift restore because I deleted some themes manually and replaced them with a fresh set from a fresh virtualbox install since I made a mess before.

But, probably because of rights or something since the themes came from another install, all icons went blanc, I did reinstall some of the adapta themes and things where working again but I then decided to just restore a backup from earlier to make things as it was before I started fiddling with the themes.

I did not change any restore options in the wizard that followed. I assumed the defaults should work. Seems they don’t.

I was dual-booting my Windows together with my Manjaro. In the meantime I found a boot repair utility but that only made Windows bootable again. So atleast I got that back.

Now I need to reinstall Grub again so I can choose Windows and Manjaro.

I did saw with the boot repair utility that it was preferred I decrypt my disks, but I never got the option to enter my password so I assume there it went wrong and only found Windows.

I guess now I need to find a way to fresh install Grub so I can have my Windows and Manjaro both bootable.

I used this tool: https://sourceforge.net/p/boot-repair/home/Home/


#4

manjaro’s grub can boot windows/other distro’s but not all other distro’s grub can boot manjaro.
follow this if your system uses UEFI:

assuming you use UEFI:
-boot into live environment
-connnect networking (wifi/ethernet/etc…)
sudo blkid -o list -c /dev/null
-take note of your drive layout, what partition the /efi/boot is located (usually sda1, but make sure)
-in terminal do the following:
mhwd-chroot -a
-enter pw for live environment “manjaro” and if prompted select which drive/partition manjaro is installed on, it should go something like thise:

[dglt@dglt-2 ~]$ manjaro-chroot -a
[sudo] password for dglt: 
==> Mounting (ManjaroLinux) [/dev/sdb2]
 --> mount: [/mnt]
 --> mount: [/mnt/boot/efi]
[dglt-2 /]# 

-you are now chrooted, and partitions mounted and now have control of your already installed manjaro. then do the following:
pacman -Syyu
pacman -S mtools os-prober
and install if they are not installed already, and then:
sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck
sudo update-grub
exit
exit
reboot
if all goes well, your manjaro grub should come right up and you should be able to boot manjaro or windows. good luck, let me know if it works out


#5

I don’t use UEFI. Would the normal way but much different?


#6

no, still not difficult, i mostly extracted that from the manjaro wiki page.
https://wiki.manjaro.org/index.php?title=Restore_the_GRUB_Bootloader#Overview


#7

here is where the directions are different, this is what you would do since you use bios and not uefi:
follow previous instruction, and after manjaro-chroot -a do the following:
pacman -Syyu
pacman -S mtools os-prober
and install if they are not installed already, and then:
sudo grub-install /dev/sda
grub-install --recheck /dev/sda
sudo update-grub
exit
exit
reboot


#8

Allright, will be trying this. Will report back. :slight_smile:

Thanks in advance for the help!


#9

good luck, let me know how it works out.


#10

When I get to the second line where it say’s “mhwd-chroot -a”, it say’s “command not found mhwd-chroot”.

I use the OpenBox live iso.


#11

Chroot seems to be there and accepts some commands but not the one from the wiki.


#12

sudo pacman -S manjaro-tools-base
and use
manjaro-chroot -a
its much simpler than mhwd-chroot


#13

Currently refreshing the database then I can install the tools and will follow the guide again!

Hope this is going to work. Manjaro is the first time that Linux is awesome for me and my games I want to play works.

Usually with the Ubuntu flavours in the past I would have already gave up but this time I am pushing forward. Time to learn!


#14

i know what your saying, none of the other distro’s ive tried even came close to manjaro


#15

Allright, installed and something happened. Weird error though:

“ERROR: You can’t mount 0!”

I do have my disks mounted and unlocked. Could that be the issue?


#16

yes, unmount them and let
manjaro-chroot -a
mount them


#17

They are unmounted but still get the same error. This is so confusing. The wiki isn’t very helpfull either in this case. The wiki assumes everything works perfectly I guess. :stuck_out_tongue:


#18

maybe reboot the live usb and try fresh from terminal
sudo manjaro-chroot -a


#19

Will do, but that probably means I need to install the tools again?


#20

Even the Manjaro Architect complains I need to mount the partitions first and when I do with the file manager it keeps saying the error.

Unless it wants me to mount the drives to a folder I need to manually create on the liveusb.