Timeshift-gtk dumps core

Today I ran timeshift under Ruah 21.3.7 then updated “add/remove software”
Noticed Linux was now Sikaris 22.0.0
So, I ran timeshift again but it now crashes every time.
Reboot and shutdown changed nothing.
Anyone else have this issue?

When they release a update that fixes the glib2 issue is it going to be noted here? Ask cause it would be a good heads up for us that will need to remove glib2 from IgnorePkg. Thanks

It’s already in Testing right now. :wink:

Thanks but I asked if it was going to be mentioned in this thread so peep can have a reminder to remove it from their ignore list.

If you put something on your ignore list you’ll still get notified (at least by pacman) fo the package and (more importantly) target version you’re ignoring.


Indeed, and by pamac too. They both tell you which packages are being ignored.


Thanks guys very good to know.

1 Like

I’m on unstable and Timeshift gui is still crashing. What glib2 update do you mean?

Let me know if updating to glib2-2.74.0-1.0 improve things …

Sorry, no, Timeshift gui still crashes for me with glib2-2.74.0-1.0

Don’t know if this is helpful, but there’s more crash info provided here:

1 Like

Seems it only fixes some issues with Gimp. Let’s see. Most likely a git-bisect on glib2 might help. I did once for a kernel issue: GitHub - philmmanjaro/linux41: Manjaro Kernel 4.1

1 Like

7 posts were split to a new topic: I found a man page

after “sudo pacman -Syuu” , I was going to say solved but I was wrong, false alarm, sorry

Lots of GB of data are left on my HDD, also the latest snapshot cannot be deleted.

In addition to that, I cannot make another manual snapshot due to the fact that each operation initiated by the user closes the GUI itself.

Should I provide logs from Timeshift now? I have no experience with Timeshift at all. Actually, I have used it for the first time in years.

Use the command line… :arrow_down:

sudo timeshift --create --comments "Your comments go here"

For more information, please read through the whole thread. :arrow_double_up:

1 Like

Hi @Jim.B,
Thank You, it works but it give Me an error message when trying to delete incomplete snapshots:

E: Failed to remove directory

I hope You take care of You :wink:

When cleaning up,

a snapshot can not be deleted by using rm !
(And not while you are inside the snapshot :wink: )
You have to use btrfs subvolume delete
because a snapshot is a construct of btrfs and not part of the filesystem by itself.

You find good Information about Btrfs in the wiki

btrfs subvolume delete --help 
1 Like

Go to the folder where your snapshots are stored. Find the folder thats incomplete and delete it, its likely the smallest one. You can use sudo rm -r /path/to/timeshift/bad/snapshot. Replace the path in that command with the path to the folder on your computer.

I had not read that you have btrfs… so as andreas85 said
There is also similar information at:

good luck

I haven’t posted before, but I have also suffered with problem the mentioned in this thread. I downgraded to glib 2.72.3-3 and that worked for several days, but today timeshift crashed again midway through a snapshot so maybe glib isn’t all that is going on here?
CLI still works.
Manjaro Stable rsync snapshots.