Timeshift-gtk dumps core

I take it from the strike through that yesterdays patch didn’t fix the issue? Then just pull your post.

No, I still experience random crashes using the Timeshift gui after the glib2 update to 2.74.0-2. But because this is also a seemingly random crash issue since the glib2 update to 2.74, I suspect the problem is glib2, not Timeshift.

You’d be right it’s glib2 at issue.

Timeshift keep doing its backup in the background although the gui crash.

But after reopen the gui the backup do not appears, and there is a folder in the timeshift snapshots (I deleted it with thunar-root).

Going to downgrade glib2.

After downgrading to glib2-2.72.3-3 timeshift do it’s job.

Same problem. The nice thing is that timeshift works on the command line. To make a snapshot open a terminal and use this command.
sudo timeshift --create --comments "A new backup"

To restore, in case it crashes use this command, it lets you select the snapshot.
sudo timeshift --restore

Snapshots created this way show up in the GUI.


me too. but I already had it.

My concern is, what about the residual snapshot created by the GUI that “finished” in the background after the GUI crashed?

timeshift --list

Num     Name                 Tags  Description                 
0    >  2022-08-20_09-17-41  O     Kernel 5.15.60, KDE 5.24.6 
1    >  2022-09-26_10-41-10  O     Kernel 5.15.60, KDE 5.24.6 

Compared to the actual directory listing…

du -hs /timeshift/snapshots/*

14G     /timeshift/snapshots/2022-08-20_09-17-41
1.9G    /timeshift/snapshots/2022-09-26_10-41-10
8.4G    /timeshift/snapshots/2022-10-06_10-41-15

Side note: This is from a Manjaro “Stable” system, since the Stable 2022-10-05 update was released.

The failed creation is only a partial snapshot, its incomplete, so it doesnt show because the application doesnt want you to try and use it to restore. That might create a failed system. Creating a new snapshot with the command line sudo timeshift --create --comments "A new backup" will also remove any of the failed partial snapshots. You could also just delete it from /timeshift/snapshots .

Removing snapshots (incomplete):
Removing '2022-10-06_10-09-54'...
Removed '2022-10-06_10-09-54'       

good afternoon Winnie:
Removed when you do another from the terminal

sorry, I forgot to say that you can also delete the snapshots not finished with :

sudo  timeshift --check
[sudo] contraseña para xavier: 
[Warning] Deleted invalid lock
Mounted '/dev/sda3' at '/run/timeshift/9919/backup'
Scheduled snapshots are disabled - Nothing to do!
Removing snapshots (incomplete):
Removing '2022-10-06_18-43-01'...
Removed '2022-10-06_18-43-01'                                                   

1 Like

Going to try it right now. :+1:

But on that note… how did this make it into Stable?

1 Like

Stable isnt perfect, heck nothing on this earth is perfect. Still the dev’s do a pretty good job with only minor hickup’s.

No dice:

sudo timeshift --create --comments "A new backup" --tags O
E: Unknown value specified for option --tags (O).
E: Expected values: O, B, H, D, W, M

I tried with copy + paste as well as manually entering the command carefully. (Yes, that is a capital “o”.)

EDIT: Removing --tag O allowed it to run. Backup completed successfully.

UPDATE: It did indeed remove the residual “failed” snapshot directory. :+1:

But this issue was known and never resolved before being pushed into Stable. It’s not like this was a mystery before the Stable updates were published.

I consider this one a big deal, as Timeshift is what users are instructed to use to make snapshots of their system and is included by default with a fresh Manjaro installation.

1 Like

After applying the 2022.10.05 update to Manjaro Stable, timeshift is behaving weirdly. As soon as I start making a backup — just for clarity, using the rsync method — the timeshift GUI crashes.

Nevertheless, it does start making a backup in the background. However, as far as timeshift itself is then concerned, the new backup does not exist. It shows up neither in the command-line list nor in the timeshift GUI when it is restarted.

[nx-74205:/dev/pts/3][/root] # timeshift --list
Mounted '/dev/sdb2' at '/run/timeshift/2932/backup'
Device : /dev/sdb2
UUID   : 1aedac7f-403b-4d85-9643-0d622be75453
Path   : /run/timeshift/2932/backup
Mode   : RSYNC
Status : OK
2 snapshots, 577.3 GB free

Num     Name                 Tags  Description                       
0    >  2022-09-18_10-48-00  O                                       
1    >  2022-10-06_10-55-00  O     skipped Plasma 5.24 LTS → 5.25  

Found stale mount for device '/dev/sdb2' at path '/run/timeshift/2932/backup'
Unmounted successfully

[nx-74205:/dev/pts/3][/root] # ll /mnt/timeshift/snapshots/
total 0
drwx------ 1 root root 112 Sep 18 10:50 2022-09-18_10-48-00
drwx------ 1 root root 112 Oct  6 10:57 2022-10-06_10-55-00
drwx------ 1 root root  60 Oct  6 12:45 2022-10-06_12-45-00
drwx------ 1 root root  60 Oct  6 12:51 2022-10-06_12-51-35

As you can see, it did indeed make the last two backups, but timeshift does not recognize them — it only shows the two older backups.

The following two people have also reported difficulties, albeit with different results.

1 Like

A thread ongoing over here.

1 Like

This is a nasty one. Apparently, using the command-line works fine. Wonder how it was caught in “Unstable” but not resolved before “Stable”?

I decided to go for it and update my secondary system to 2022-10-05. Besides cringing from the backwards changes to KDE, among other things, Timeshift-gtk crashed for me at around 80% completion of making a new backup.

While it did “finish” in the background, and in fact does show the timestamped directory under /timeshift/snapshots/, like @Aragorn said, it’s not detected nor usable by the Timeshift application.

EDIT: This was an earlier post that got merged into this thread. The posts above mine are more recent.

1 Like

I forgive them…they do a great job and linux mint is in charge of timeshift (I also forgive them for not updating glib2 :rofl:

To all my doubters, you can clearly see that I know fluent Spanish. :point_up_2:

no sabia lo del español, Winnie, entonces un saludo y un abrazo fuerte desde españa…cuidate

Today I ran timeshift under Ruah 21.3.7 then updated “add/remove software”
Noticed Linux was now Sikaris 22.0.0
So, I ran timeshift again but it now crashes every time.
Reboot and shutdown changed nothing.
Anyone else have this issue?

When they release a update that fixes the glib2 issue is it going to be noted here? Ask cause it would be a good heads up for us that will need to remove glib2 from IgnorePkg. Thanks