Timeshift doesn't create scheduled snapshots


#1

Hello!
I have a problem with Timeshift. As title says, scheduled snapshots are not created.
Manual ones work.
I ran through Timeshift wizard and set these options:

  1. Snapshot type: rsync.
  2. Snapshot levels: all checkboxes are set.
  3. Save path: /home/timeshift .
  4. Excluded home dirs.

I’m using up-to-date stable branch of Manjaro.

Any ideas or directions of where should I look?
Thanks.


#2

I would seriously recommend against saving backups to your home directory. That does not make much sense given that if you have a catastrophic hard drive or SSD failure you will not have any backups.

Systems like Timeshift are really designed for backups to an external device.

You will be snapshotting your ENTIRE system to your /home directory. I wonder if the reason it does not work is that you have filled up your home partition??

Open a terminal and type “df -h” and show us that output.


#3

Pretty sure that’s not the reason. Same settings worked perfectly in Linux Mint 19.
I have separate drives for / and /home.

df -h output
Filesystem      Size  Used Avail Use% Mounted on
dev              16G     0   16G   0% /dev
run              16G  1,8M   16G   1% /run
/dev/sdb1       423G  9,7G  392G   3% /
tmpfs            16G  598M   16G   4% /dev/shm
tmpfs            16G     0   16G   0% /sys/fs/cgroup
tmpfs            16G  8,1M   16G   1% /tmp
/dev/sdb3       511M  264K  511M   1% /boot/efi
/dev/sda1       916G   43G  827G   5% /home
tmpfs           3,2G   12K  3,2G   1% /run/user/120
tmpfs           3,2G   56K  3,2G   1% /run/user/1000

Maybe that’s something about Timeshift not running as service (if there’s any) or not added as cron job?


#4

Timeshift uses the good old cron. Manajro uses cornie as a cron implementation. It is installed by default on all official Editions. And it is one of the few services which are enabled by default. If you using a Community Edition or an Architect installation, you might want to check if cronie is running.

If you set up Timeshift correctly, you will have a file in /etc/cron.d which starts every hour a Timeshift process. This process checks if it needs to create a snapshot. This is depends on your settings in Timeshift.

Check if you can find the Timeshift cron file in /etc/cron.d and check if it is running.

journalctl -b -u cronie

You should see something like this every hour.

Nov 28 17:00:01 system1 CROND[8128]: (root) CMD (timeshift --check --scripted)

#5

Cronie was disabled for some reason. Enabling it did the trick. Thanks for your help!


[Stable Update] 2019-02-19 - Kernels, KDE, LibreOffice, Systemd, VirtualBox, Deepin, Qt, Firmwares, Wine
#6

I wonder why isn’t this working from the get-go with Timeshift. I set up Timeshift on my computer to backup on external hard drive and the cron simply works. I set it up on other installations to backup on the same hard drive and none works.

Shouldn’t Timeshift force cron jobs? How come Deja-Dup works without an issue but not Timeshift? Is this a Timeshift issue?


#7

For a custom isobuild if I edit this line:
enable_systemd=('bluetooth' 'ModemManager' 'NetworkManager' 'org.cups.cupsd' 'tlp' 'tlp-sleep' 'avahi-demon')

could I include Timeshift to work properly to do cronjobs?

Thanks!


#8

cronie???
what i use is

 enable_systemd=('avahi-daemon' 'bluetooth' 'cronie' 'ModemManager' 'connman' 'org.cups.cupsd' 'systemd-timesyncd' 'systemd-swap' 'zramswap' 'tlp' 'tlp-sleep' 'irqbalance' 'preload' 'ufw' 'haveged' 'gamemoded' 'libvirtd')

#9

Ah yes so this should do it right?


#10

should do it