Time is incorrect and i have no internet

Basically I just installed Manjaro and when i went to set up my internet it kept timing out. Someone said it could be because my clock is wrong(which it is), but nomatter what I try it won’t show the right time. I’ve tried everything the forms have said and even went to change it in the BIOS but it still wont work.
I’m as fresh as they come when it comes to linux, literally just installed it today so if we can keep it simple.

In xfce - click start button-settings-manjaro settings manager-Time and date

tried it, doesn’t work.

Dual boot with windows?..then

1 Like

im not dual booting. my time is 3:46 but it’s showing 7:51. idk what to do

Menu > manjaro-settings > time/date
Adjust time and set to automatic.
It will ask you for sudo pw.

still shows the same incorrect time. I tried reinstalling manjaro too but that didn’t help either.
When I do timedatectl status it says that system clock isn’t synchronised.


Remember to set up how the hardware clock should be adjusted.

The easiest method on Manjaro is to set the clock to utc and sync system clock to hardware. The system clock uses your configured timezone

sudo timedatectl set-local-rtc 0
sudo hwclock --systohc --utc
sudo systemctl enable --now systemd-timesyncd
1 Like

didn’t help. won’t change to the time i set it.

Mm what time is your bios set to?
try to adjust the time to the correct time in bios, save it and reboot
[edit] didn’t notice this is already something that is tried.
But if you can’t set the right time in bios there is definitely something wrong with your hardware

In the meantime you should be able to change the time like so…

“sudo timedatectl set-time 17:56:00”

Or if you need date as well, here’s the format. "sudo timedatectl set-time YYYY-MM-DD HH:MM:SS "