Thunderbolt 3 - no screen ; xfce - usb ports not working

I have a Caldigit TS3+
It was working under gnome ; but under xfce any usb ports connected to the dock don’t register on the laptop. and also as of yesterday my external display doesn’t connect either. Thinking maybe its a power issue ? any idea how to resolve ?

archwiki had this:

echo 1 > /sys/bus/wmi/devices/86CCFD48-205E-4A77-9C48-2021CBEDE341/force_power

I’m not saying its the solution, just that I’m trying anything…
but all i get is no file or directory .

Hi @zartarr88 :wink:

As you can read at the archwiki, there is native support for Gnome and KDE, but XFCE has nothing. You will need to use bolt or tbt to manage it on XFCE.

I do have tbt and bolt , tried both . The peripherals that I connect to the dock just don’t work. and Archwiki doesn’t go into detail on bolt/tbt commands and I am not understanding it.

I believe it might have to do with this IOMMU thing…
I don’t know the command to change this I’ve tried numerous combinations in boltctl .

 ● CalDigit, Inc. TS3 Plus
   ├─ type:          peripheral
   ├─ name:          TS3 Plus
   ├─ vendor:        CalDigit, Inc.
   ├─ uuid:          0017236c-55e3-3d00-ffff-ffffffffffff
   ├─ generation:    Thunderbolt 3
   ├─ status:        authorized
   │  ├─ domain:     c7010000-0080-8c0e-838c-0e21e8409a24
   │  ├─ rx speed:   40 Gb/s = 2 lanes * 20 Gb/s
   │  ├─ tx speed:   40 Gb/s = 2 lanes * 20 Gb/s
   │  └─ authflags:  none
   ├─ authorized:    Mon 18 Jan 2021 03:02:13 AM
   ├─ connected:     Mon 18 Jan 2021 03:02:13 AM
   └─ stored:        Mon 18 Jan 2021 01:37:00 AM
  ├─ policy:     iommu
  └─ key:        no

Furthermore I have more issues , all related to this external display.

  • when it goes to sleep sometimes it won’t wake up
  • sometimes it gets back in but there are artifacts , for instance 25% of screen is something else and the remainder is the background. Almost like there is a screen on top of a screen.