Thunderbird syncs caldav calendar after config mod (posting in case helpful)

Hi, I couldn’t get thunderbird (68.11.0 (64-bit)) to sync caldav calendars (I tried accounts from posteo and zoho). While I could add a calendar to thunderbird, a triangle constantly appeared with the message “momentarily not available”, when hovered over with mouse pointer. I tried these calendar accounts on windows thunderbird, and they worked. After much searching, I was able to fix the issue in my manjaro thunderbird by adding network.cookie.same-site.enabled as a boolean line (set to false) to about:config (edit > preferences > Config Editor. I had to remove the calendar account and re-add it. Then it began syncing. I don’t know if this change introduces any other problems or creates any undesirable security changes. Posting this in case it is helpful to others. (If there is anything harmful about it, I would like to know.) Here’s a discussion: Workarounds for Same-Site-Cookie bug with Thunderbird - howto - Nextcloud community The following link appears relevant: 1551821 - Get rid of pref network.cookie.same-site.enabled

That’s strange, I personally haven’t had any issues syncing CalDAV for Zoho, Posteo, or on Thunderbird.

Glad to hear it works without issue for some. Strange issue/fix for me.