Thunar too wide

For the past few days thunar has taken to opening its window approx 100px wider than my screen. It never did this before but now it does. If I press the maximise button it goes to the correct size but always forgets this on next start. This is what I have tried so far to no effect:
1] Downgrade thunar then upgrade again.
2] xfconf-query --channel thunar --property /misc-remember-geometry --create --type bool --set false then add correct window size into thunarrc (it seems to completely ignore anything written into thunarrc)
3] Reverse the above to get it to supposedly remember the last size (it doesn’t)
4] Dragging the window to the correct size and then closing with the quit menu item.
None of the above make any difference. Got any other ideas? (I don’t want to use devilspie, it didn’t need it before and it shouldn’t need it now).
I am using thunar 4.18 on testing.
PS - forgot to say, there are no other programs exhibiting this behaviour, only thunar.

Sounds similar to this problem: Manjaro update 22.0.0 broke thunar window settings

You might want to follow this thread in the xfce forum: Thunar 4.18.0 - Can't set custom window size / Desktop / Xfce Forums

@stargazer Thanks for finding those posts, I couldn’t! Guess I will just sit and wait for another version update then.

Some more info on this slight annoyance. I said previously that downgrading didn’t help, I was wrong. Thunar has a peculiarity in that even if it is not running, downgrading alone will not remove the current version, you have to downgrade and then run ‘thunar -q’ in a terminal otherwise starting thunar will start the previously installed version (you could probably reboot instead). Anyhow, I didn’t do this when I tested before hence my belief that the downgrade didn’t work. In fact any 4.16 version will work properly.
I got an update to 4.18.1-1 today and that hasn’t cured the oversize problem yet.

I can’t test the efficacy of this, but I’d at least try to
reset the settings for thunar to it’s defaults

killall xfsettingsd

perhaps also kill the thunar daemon process as well
killall Thunar

then remove it’s configuration:
rm ~/.config/xfce4/xfconf/xfce-perchannel-xml/thunar.xml

and replace it with the default:
cp /etc/skel/.config/xfce4/xfconf/xfce-perchannel-xml/thunar.xml ~/.config/xfce4/xfconf/xfce-perchannel-xml/thunar.xml
(this is one line!)

log out and back in
to restart the xfsettingsd and the thunar daemon process

Thanks for that, an intricate and cleverly thought out idea for which I thank you, sadly it doesn’t work, so I will just sit on version 4.16 until somebody sorts out the code for 4.18 which is probably where the problem lies. tbh the differences between the two are so minor I struggle to even notice them except that 4.16 works properly and 4.18 doesn’t.

Some more on this problem.
First up I noticed that if I opened my / folder with thunar, every single file and folder in there was owned by Nobody/nobody (owner/group). Obviously this is another fault as it should be root/root. I also noticed that if I open thunar as root it behaved exactly as it should - correct size window and correct ownership.

As there seems to have been no movement on this problem and indeed no reports of it at Xfce, I decided to work round it myself. I did this by uninstalling the thunar from the official repository (you have to use --nodeps for this otherwise it wants to remove xfdesktop which you really don’t want on an xfce system). I then installed from source thunar version 4.18.0git-40d0481c which behaves correctly in all respects.

Instructions are here for anyone with similar problems: thunar:dev:build_and_run [Xfce Wiki]
If you have anything like a dock shortcut for launching thunar you will have to amend this as it is now running from ~/thunar if you followed the instructions above.

I guess this is solved then although I still maintain that the official repository package is faulty somehow.

EDIT. In case anybody is insane enough to be trying this out for themselves, I have to give a warning. The above method worked well I until rebooted and then it left me with a large white box behind my cairo dock where wallpaper should be. This was solved by replacing xfdesktop with xfdesktop-devel.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.