Thunar: Issue After July 01/18 Update


#1

Right clicking on the desktop shortcut has 3 custom action. 1/Terminal 2/Thunar Root 3/Search.
Since the update all 3 are missing. BUT going to create them again I found they are still listed under ‘Edit/Configure custom actions’. Something has gone astray somewhere. How to get them working again?

edit: It may have something to do with the engrampa-thunar-plugin that was removed so the system could update.
This is only happening on the desktop shortcuts. Opening thunar then right click has the options available.


[Stable Update] 2018-07-01 - Kernels, KDE, LibreOffice, Browsers, Mesa, Systemd, Deepin
#2

I’m wondering if somehow the ‘desktop actions’ or whatever they call it in xfce got toggled…
Please look in ‘Desktop Settings’ or similar.
(maybe check if the actions work inside thunar vs desktop)

… also a good time to mention again that thunar probably should not be run as root.
But no one likes that note …


#3

I have no real idea as I am a KDE user. My first thought would be to check the permissions on the files and directories involved with custom actions.


#4

Just did a quick edit…not quick enough…slow down guys. :dizzy_face:
The issue is only happening on the desktop shortcuts. Opening thunar & right clicking still has the options there.


#5

Well then, check your desktop settings (or whatever) as mentioned :wink:

:star2: we are the speed you need :oncoming_automobile:

…oh yeah found in an old post (it is xfce after all so its probably about the same)
Settings Manager -> Desktop -> Menus Tab


#6

It’s the Thunar update.


#7

Thanks for that. I can rest easy & wait patiently for the fix. :alarm_clock:

@cscs I use thunar root as my typing is hideous & my memory sucks. Find it much easier to do a quick edit in thunar than the terminal.


closed #8

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.