Thunar GTK3 problem


I am using XFCE DE. Tried to install Thunar GTK3 and Thunar was removed. Now i cannot login to Manjaro. The welcome screen will come back again. Several error messages like the following appear on the screen:
43.783868] [drm:drm_atomic_helper_comit_cleanup_done [drm_kms_helper]] ERROR [CTRC:32:pipe A] flip_done timed out

how should I login to Manjaro and correct the Error?



Probably other gtk3 packages were also installed alongside thunar-gtk3 and other conflicting gtk2 packages removed, and since gtk3 is not really stable yet, this is what could have caused your issue.

Follow this guide to login to tty terminal, then remove thunar-gtk3 and install thunar, this will probably reinstall the previously removed gtk2 packages as well. If not, check in /var/log/pacman.log which packages (if any) were removed when you installed thunar-gtk3 and reinstall them manually.

To install thunar-gtk2 from the tty, which will also remove thunar-gtk3

sudo pacman -S thunar

then to reboot



Thank you so much for your prompt response and clear guide.
So far I was able to replace Thunar gtk3 with Thunar in tty and rebooted but the problem is still there. Am going to the next step to search manually. I will report the result here soon.
Best regards,


Completely reinstall XFCE

sudo pacman -S xfce4 xfce4-goodies

This should overwrite all the gtk3 stuff - may need to add --force to the command.


Hi muser,
Thank you again.
Found it hard to accesses to /var/log/… It says you do not have permission even when I am root. So I will follow Xircon suggestion for now. Thank you.


Hi Xircon,
Thank you. I did that and indeed several gtk3 packages were removed. but at the end it says : failed to prepare transactions (could not satisfy dependencies. i am going to reboot anyways to see what will happen.
Best regards,


You can do it with

cat /var/log/pacman.log | less

(cat shows the content of the file, less makes you able to scroll up-down it with the arrow keys)


Did you try with the --force on the end of the command??


Yes. the second time I did that. I will do it again and will post the last sentences.


Also install another DE as backup, I recommend LXDE or LXQT - if one will not boot, you have the other as backup to fix the first - if you see what I mean :smiley:

sudo pacman -S lxde


Good idea. Thanks.


I am installing lxde. After that can I completely remove XFCE and reinstall it again? Do I have to first backup my document files?


Dear Muser,
Still no success. What if I do the first steps of replacing thunar with thunar gtk3 on my another Manjaro computer to find out which files will be replaced and the correct those in the affected computer?


Does LXDE work? If yes, then no need to back up.

sudo pacman -Rsn xfce4-gtk3
sudo pacman -Rsn xfce4 xfce4-goodies
sudo pacman -S xfce4 xfce4-goodies

Post any errors.


Yes, lxde worked.


Since you are reinstalling xfce, that doesn’t seem relevant anymore, but you can do that just out of curiosity if you want, without actually installing thunar-gtk3 of course.


Good, so you have a working machine, try the commands to uninstall, then reinstall. Avoid xfce4-gtk3 it is a sh1t storm at the minute.

I would also run

rm -rf /home/YOUR-USER-NAME/.config/xfce4

Before reinstall - you can always copy the defaults from /etc/skel/.config


Rsn xfce-gtk3 and Rsn xfce cfxe-goodies do not work.


Good - all gtk3 packages are gone.


I am not sure! it says removing libxfce4ui-gtk3 breaks dependencies ‘libxfce4 ui’