ThinkPad X380 doesn't go into standby

I've had this problem for a while now. When I try to go into sleep mode, the laptop attempts to and then the login screen is shown again. This is really annoying, because sometimes have to try for ten times until it finally goes to sleep. I carry the laptop in the backpack getting warm sometimes. I thought this was a kernel issue, but it has been persisting for a few months now. It doesn't occur when I use Windows 10, so it is not a hardware issue. Can anyone help with this?

This is very new hardware so you should be using the most recent kernel.

Which kernel are you using? If it's not 5.1 or 5.2 then please try those.

As I have no info about your machine Link , I suggest update your bios and activate in bios settings linux sleep mode.

For firmware-update install and set up fwupd.
For bios-update go to your model support site and download latest bios.iso .
Convert the iso with geteltorito to a usb stick.

2 Likes

Please post:

inxi -Fxxxz

I think solved it by disabling EHCI and XHCI wake-up. I found this and applied this. I assume that since my laptop has a built-in Wacom tablet, which is recognized as a USB device, it makes the laptop wake up instantaneously.

2 Likes

Forum kindly sponsored by