Thinkpad X1 Extreme. External monitor not working

I have a Thinkpad X1 Extreme and installed Manjaro 18.0.2 xfce. It is currently using the bumblebee graphics.

The problem is my external monitor is not working when hooked to my usb-c port. I already know from reading elsewhere that the hdmi will not work since it is not using nvidia.

However, I also tried an ethernet cable converted to usb-c and that works when plugged in. What could be causing the ext monitor to not work through usb-c but ethernet to work? How do I go about fixing this?

An important part to read is here
https://wiki.archlinux.org/index.php/DisplayLink
Also there was a fix as you can see here, there is a file you can use

or simply add it as /etc/X11/xorg.conf.d/evdidevice.conf with this content:

Section "OutputClass"
	Identifier "DisplayLink"
	MatchDriver "evdi"
	Driver "modesetting"
	Option  "AccelMethod" "none"
EndSection

Hey, i have the same issue that i want to use usb-c to hdmi output for an external monitor however I cannot got DisplayLink to run in the first place, could you maybe explain how you got it working ?

For error info:
I tried to install displaylink from aur via: yay -S displaylink
after the package was done installing, i got the first error message after running
sudo systemctl start displaylink.service

-> “displaylink.service: Failed with result ‘exit-code’ 1”

I did some research and found this thread with apparently the same error as mine:

however the following recommendation to manually reinstall evdi did not help me…
since at the step sudo dkms build -m evdi -v 1.6.0
i get another error message:
Error! echo
Your kernel headers for kernel 4.19.24-1-MANJARO cannot be found at
/usr/lib/modules/4.19.24-1-MANJARO/build or /usr/lib/modules/4.19.24-1-MANJARO/source.

Any help would be greatly appreciated :slight_smile:

And, did you installed the linux419-headers for it then try again?

I have checked the build folderrwhich is specified in the error message
and there are no linux419 files, also i do not have a source folder in …/4.19.24-1-MANJARO/

mhwd-kernel -li

yields:

Currently running: 4.19.24-1-MANJARO (linux419)
The following kernels are installed in your system:

  • linux419

So i guess they are installed already or not ?

My friend, linux419 kernel is installed otherwise you could not boot into it, but linux419-headers is something else: Header files and scripts for building modules for Linux419 kernel

Because you need to install linux419-headersin order to have them :slight_smile:

Ok! thank you very much for that clarification,

So far i have managed to install the linux419 headers and evdi 1.6.0 + displaylink.

After adding the .conf file which you mentioned earlier, rebooting and running systemctl status displaylink.service, displaylink.service seems to be active. However xrandr --listproviders only shows 1 instead of 2 providers, mentioned in the arch wiki article also when connecting the usb-c to hdmi cable nothing happens.

Thank you very much for your patience and support so far !

Chiming in. I use two external 4K monitors and they worked out of the box.

Just in case, X1 Extreme outputs are wired to nVidia dGPU. I don’t use Bumblebee for various reasons, I enable dGPU if I need external monitors or want to play games and disable it while on the battery to conserve some power. That being said, I run Optimus setup with the latest non-free nVidia driver.

After I enabled nVidia chip - both monitors were detected. I used arandr tool to configure the monitor positions and autorandr to save the configuration. That was it. Just in case, monitors are connected with USB-C to DP cables. xrandr shows external screens under DP-0 and DP-1 names, while internal screen is eDP-1-1.

hey, Can you tell me in detail, I don’t quite understand。

Hey ! :slight_smile: thanks very much for your advice, i think I’ll try your suggestion without bumblebee and see if it works !

This problem is still not fixed for me but I think I may have misunderstood the suggestions before. I put off this question and was waiting for the xorg server to be updated.

Now I am using
X.Org X Server 1.20.5
according to
/var/log/Xorg.0.log

It seems I may need to get displaylink working first.
According to pamac, I have
displaylink 5.2.14-1
but it seems to also give a build option which failed for me with error:

==> Removing existing $srcdir/ directory...
==> Extracting sources...
-> Extracting displaylink-driver-5.2.14.zip with bsdtar
==> Removing existing $pkgdir/ directory...
==> Entering fakeroot environment...
==> Starting package()...
Adding udev rule for DisplayLink DL-3xxx/5xxx devices
Installing DLM systemd service
Extracting DisplayLink Driver Package
xfce4-terminal: Unknown option "-title"
==> ERROR: A failure occurred in package().
Aborting...

Is that the right way to go about getting displaylink setup? Or am I supposed to follow
https://wiki.archlinux.org/index.php/DisplayLink
That tells me to install the displaylink driver from
https://aur.archlinux.org/packages/displaylink/
I'm not sure what to do on that page as the git clone url
https://aur.archlinux.org/displaylink.git
is 404 and that page has also been flagged as out-of-date.

Another question is is displaylink necessary to get an external monitor working or is there another way?

Forum kindly sponsored by Bytemark