Thinkpad Ultradock no sound trough DP T440P

I tried some configuration changes, i tried out different distros arch, Manjaro, openSUS but no one worked. I tried to change some configurations from old outdated guides and I deleted alsa configs and regenerated them.

My ThinkPad is an t440p an ultradock (these older ones without USB C) and everything works fine on Linux i am currently using Manjaro gnome but as I said it was with arch the same. So my issue is i don’t get any sound from the Dockingstation Displayport. Probably would be interesting if the laptop itself gets audio from Displayport but i have no mini so cable. The headphone jack and the USB plugs work perfect but as i use my monitor for my Xbox too it’s not really a solution to replace the plug every time.
ah and in sound the option HDMI/DISPLAYPORT 2 is shown but if i use it it only gives me internal audio. BTW i got the same issue on other debian based distros and on arch. Would be great if someone could help me :=)

Welcome to Manjaro forum

Please post more information about ALSA configuration

sudo --upload

here alsa-project(org/db/?f=598518b209948c098694e1943b5b1321a89bdf51

change the ( to . as i cannot post links

1 Like
!!ALSA/HDA dmesg

[    2.469990] snd_hda_intel: probe of 0000:00:03.0 failed with error -2

ALSA data is showing a configuration file /etc/asound.conf

!!ALSA configuration files

!!System wide config file (/etc/asound.conf)

Manjaro usually has ALSA configuration set by pulseaudio-alsa to use PulseAudio by default
(or pipewire-alsa for PipeWire)

I suggest you remove this additional configuration file

sudo rm /etc/asound.conf