Thinkpad Touchscreen Intermittently Stops Working

Hi I’ve installed Manjaro GNOME on a thinkpad with a touchscreen. The touchscreen only works if the laptop is plugged in on boot. If I unplug the power-cable, it stops working. If i turn on without it plugged in, it stops working. It also stopped working when i let the laptop go to sleep. My guess is that power settings are affecting it in some way but I don’t know how to investigate and can’t find similar issues elsewhere.

I’ve tried to provide as much information as I can with these commands taken off forums but if there are other searches I can run that are more helpful, please let me know.
udevadm info --export-db | awk '/ID_INPUT_TOUCHSCREEN=1/' RS= | grep "^E: DEVPATH="

E: DEVPATH=/devices/pci0000:00/0000:00:08.1/0000:06:00.4/usb4/4-2/4-2.3/4-2.3:1.0/0003:04F3:2398.0001/input/input22
E: DEVPATH=/devices/pci0000:00/0000:00:08.1/0000:06:00.4/usb4/4-2/4-2.3/4-2.3:1.0/0003:04F3:2398.0001/input/input22/event17
E: DEVPATH=/devices/pci0000:00/0000:00:08.1/0000:06:00.4/usb4/4-2/4-2.3/4-2.3:1.0/0003:04F3:2398.0001/input/input22/mouse2

xinput --list

⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ ELAN Touchscreen                        	id=11	[slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad              	id=14	[slave  pointer  (2)]
⎜   ↳ TPPS/2 IBM TrackPoint                   	id=15	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Power Button                            	id=6	[slave  keyboard (3)]
    ↳ Video Bus                               	id=7	[slave  keyboard (3)]
    ↳ Power Button                            	id=8	[slave  keyboard (3)]
    ↳ Sleep Button                            	id=9	[slave  keyboard (3)]
    ↳ Integrated IR Camera: Integrate         	id=10	[slave  keyboard (3)]
    ↳ Integrated Camera: Integrated C         	id=12	[slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard            	id=13	[slave  keyboard (3)]
    ↳ ThinkPad Extra Buttons                  	id=16	[slave  keyboard (3)]

inxi -v7azy

System:
  Kernel: 5.15.78-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=ba46f1e4-1894-4721-a6ee-94aab25c119f rw quiet splash apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: GNOME v: 43.1 tk: GTK v: 3.24.34 wm: gnome-shell dm: GDM v: 43.0
    Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Laptop System: LENOVO product: 20MVS14401 v: ThinkPad A485
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: LENOVO model: 20MVS14401 v: SDK0J40697 WIN
    serial: <superuser required> UEFI: LENOVO v: R0WET48W (1.16 )
    date: 01/03/2019
Battery:
  ID-1: BAT1 charge: 18.4 Wh (98.9%) condition: 18.6/23.6 Wh (78.6%)
    volts: 12.5 min: 11.4 model: LGC 11 01AV423 type: Li-ion serial: <filter>
    status: charging cycles: 5
Memory:
  RAM: total: 14.54 GiB used: 2.99 GiB (20.6%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
CPU:
  Info: model: AMD Ryzen 5 PRO 2500U w/ Radeon Vega Mobile Gfx bits: 64
    type: MT MCP arch: Zen level: v3 note: check built: 2017-19 process: GF 14nm
    family: 0x17 (23) model-id: 0x11 (17) stepping: 0 microcode: 0x8101007
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 384 KiB desc: d-4x32 KiB; i-4x64 KiB L2: 2 MiB desc: 4x512 KiB L3: 4 MiB
    desc: 1x4 MiB
  Speed (MHz): avg: 1418 high: 1557 min/max: 1600/2000 boost: enabled
    scaling: driver: acpi-cpufreq governor: ondemand cores: 1: 1402 2: 1369
    3: 1464 4: 1392 5: 1426 6: 1369 7: 1557 8: 1369 bogomips: 31949
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
    bmi2 bpext clflush clflushopt clzero cmov cmp_legacy constant_tsc cpb
    cpuid cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c
    flushbyasid fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb irperf
    lahf_lm lbrv lm mca mce misalignsse mmx mmxext monitor movbe msr mtrr
    mwaitx nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae pat
    pausefilter pclmulqdq pdpe1gb perfctr_core perfctr_llc perfctr_nb
    pfthreshold pge pni popcnt pse pse36 rapl rdrand rdseed rdtscp rep_good
    sep sev sev_es sha_ni skinit smap smca sme smep ssbd sse sse2 sse4_1
    sse4_2 sse4a ssse3 succor svm svm_lock syscall tce topoext tsc tsc_scale
    v_vmsave_vmload vgif vmcb_clean vme vmmcall wdt xgetbv1 xsave xsavec
    xsaveerptr xsaveopt xsaves
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT vulnerable
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    disabled, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Raven Ridge [Radeon Vega Series / Radeon Mobile Series]
    vendor: Lenovo driver: amdgpu v: kernel arch: GCN-5 code: Vega
    process: GF 14nm built: 2017-20 pcie: gen: 3 speed: 8 GT/s lanes: 16 ports:
    active: eDP-1 empty: DP-1,DP-2,HDMI-A-1 bus-ID: 06:00.0 chip-ID: 1002:15dd
    class-ID: 0300 temp: 49.0 C
  Device-2: Acer Integrated IR Camera type: USB driver: uvcvideo
    bus-ID: 4-2.1:5 chip-ID: 5986:1141 class-ID: 0e02 serial: <filter>
  Device-3: Acer SunplusIT Integrated Camera type: USB driver: uvcvideo
    bus-ID: 4-2.4:8 chip-ID: 5986:2113 class-ID: 0e02
  Display: x11 server: X.org v: 1.21.1.4 with: Xwayland v: 22.1.5
    compositor: gnome-shell driver: X: loaded: amdgpu
    unloaded: modesetting,radeon alternate: fbdev,vesa dri: radeonsi
    gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-size: <missing: xdpyinfo>
  Monitor-1: eDP-1 mapped: eDP model: InfoVision Optronics/Kunshan 0x057d
    built: 2017 res: 1920x1080 hz: 60 dpi: 158 gamma: 1.2
    size: 309x174mm (12.17x6.85") diag: 355mm (14") ratio: 16:9 modes:
    max: 1920x1080 min: 640x480
  API: OpenGL v: 4.6 Mesa 22.2.3 renderer: AMD Radeon Vega 8 Graphics (raven
    LLVM 14.0.6 DRM 3.42 5.15.78-1-MANJARO) direct render: Yes
Audio:
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 06:00.1 chip-ID: 1002:15de class-ID: 0403
  Device-2: AMD Family 17h/19h HD Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 06:00.6
    chip-ID: 1022:15e3 class-ID: 0403
  Sound API: ALSA v: k5.15.78-1-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.21 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.59 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: 3400 bus-ID: 04:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp4s0f0 state: down mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: 2000 bus-ID: 05:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp5s0 state: down mac: <filter>
  IF-ID-1: wlp2s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
Bluetooth:
  Message: No bluetooth data found.
Logical:
  Message: No logical block device data found.
RAID:
  Message: No RAID data found.
Drives:
  Local Storage: total: 238.47 GiB used: 69.5 GiB (29.1%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Sabrent model: N/A
    size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: RKT303.3 temp: 26.9 C scheme: GPT
  Message: No optical or floppy data found.
Partition:
  ID-1: / raw-size: 238.17 GiB size: 233.38 GiB (97.99%) used: 69.5 GiB (29.8%)
    fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2 label: N/A
    uuid: ba46f1e4-1894-4721-a6ee-94aab25c119f
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 312 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
    label: NO_LABEL uuid: 3D50-A4ED
Swap:
  Alert: No swap data was found.
Unmounted:
  Message: No unmounted partitions found.
USB:
  Hub-1: 1-0:1 info: Full speed or root hub ports: 1 rev: 2.0 speed: 480 Mb/s
    chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 2-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-3: 3-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-4: 4-0:1 info: Hi-speed hub with single TT ports: 2 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-5: 4-1:2 info: Genesys Logic Hub ports: 4 rev: 2.0 speed: 480 Mb/s
    power: 100mA chip-ID: 05e3:0610 class-ID: 0900
  Device-1: 4-1.1:4 info: Synaptics Metallica MIS Touch Fingerprint Reader
    type: <vendor specific> driver: N/A interfaces: 1 rev: 2.0 speed: 12 Mb/s
    power: 100mA chip-ID: 06cb:009a class-ID: ff00 serial: <filter>
  Hub-6: 4-2:3 info: Genesys Logic Hub ports: 4 rev: 2.0 speed: 480 Mb/s
    power: 100mA chip-ID: 05e3:0610 class-ID: 0900
  Device-1: 4-2.1:5 info: Acer Integrated IR Camera type: Video
    driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 5986:1141 class-ID: 0e02 serial: <filter>
  Device-2: 4-2.3:7 info: Elan Micro Touchscreen type: HID
    driver: hid-multitouch,usbhid interfaces: 1 rev: 2.0 speed: 12 Mb/s
    power: 100mA chip-ID: 04f3:2398 class-ID: 0300
  Device-3: 4-2.4:8 info: Acer SunplusIT Integrated Camera type: Video
    driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 5986:2113 class-ID: 0e02
  Hub-7: 5-0:1 info: Super-speed hub ports: 1 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
Sensors:
  System Temperatures: cpu: 49.0 C mobo: N/A gpu: amdgpu temp: 49.0 C
  Fan Speeds (RPM): fan-1: 0
Info:
  Processes: 281 Uptime: 13m wakeups: 1 Init: systemd v: 251 default: graphical
  tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: 1453
  pm: pacman pkgs: 1447 libs: 356 tools: gnome-software,pamac,yay pm: flatpak
  pkgs: 6 Shell: fish v: 3.5.1 default: Zsh v: 5.9 running-in: alacritty
  inxi: 3.3.23

Hi, does it work, if you execute:

sudo modprobe -r hid-multitouch

before suspend, and

sudo modprobe hid-multitouch

after the resume?

Thanks for the suggestion! That command seems to have no effect on the problem, unfortunately.

I’ve just figured out the problem. I had installed and enabled laptop-mode-tools to try and get better battery performance. I just uninstalled it, and the problem with the touchscreen has good. I thought i had already disabled laptop mode but apparently I hadn’t done it properly.