Thinkpad T490 New Resolution Not Filling Screen


I am new to linux (coming from macos). I am using a T490 thinkpad and I am running the XFCE version.

Everything is working fine when I am using resolution 1920x1080. But whenever I change the resolution to anything else the screen is not filled — there are black stripes to the sides.



Screen 0: minimum 8 x 8, current 1280 x 1024, maximum 32767 x 32767
eDP1 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 310mm x 170mm panning 1280x1024+0+0
   1920x1080     60.01 +  59.93  
   1680x1050     59.95    59.88  
   1400x1050     59.98  
   1600x900      60.00    59.95    59.82  
   1280x1024     60.02* 
   1400x900      59.96    59.88  
   1280x960      60.00  
   1368x768      60.00    59.88    59.85  
   1280x800      59.81    59.91  
   1280x720      59.86    60.00    59.74  
   1024x768      60.00  
   1024x576      60.00    59.90    59.82  
   960x540       60.00    59.63    59.82  
   800x600       60.32    56.25  
   864x486       60.00    59.92    59.57  
   640x480       59.94  
   720x405       59.51    60.00    58.99  
   640x360       59.84    59.32    60.00  
DP1 disconnected (normal left inverted right x axis y axis)
DP2 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

I tried to follow solutions I have seen online such as setting the underscan off, but my xrandr utility does not have the “underscan” option. Specifically, when I run

xrandr --output eDP1 --mode 1280x1024 --set underscan off

it returns

X Error of failed request: BadName (named color or font does not exist)
Major opcode of failed request: 140 (RANDR)
Minor opcode of failed request: 11 (RRQueryOutputProperty)
Serial number of failed request: 39
Current serial number in output stream: 39

Any help will be greatly appreciated.


While this doesnt address your query … why do you want to scale the resolution down?

I don’t know that I have a good answer for you. Sometimes it is easier on my eyes.

A bit late in the day but, Recently acquired a W530 Thinkpad with FHD display, text was ridiculously tiny, sharp but tiny! All I did was increase all the 10 point fonts to 14 points and that worked fine for me. The same thing can be done with web browsers via their preferences.
Hope this helps.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.