ThinkPad Pro Dock USB 3.0 external display not detected

gnome
dock
lenovo
dual-monitor
#1

Hi everyone!

I am total new in the world of linux, but I enjoy to work with it from the first second!
So at this point I need your help.

I have got a lenovo Thinkpad E470 Notebook and a Thinkpad Pro Dock USB 3.0 (40A7). Every thing works fine, excepting the display. It seems if the additional Display is not found while using it through the dock. If i connect it directly to my laptop via HDMI everything works fine!

Maybe you have some ideas for me!?

A small summary of the setup follows:

Dock and Laptop are connected via USB 3.0.
The output-port of the dock is an DVI Port, and is directly connected to the secondary display.

Notebook: Lenovo Thinkpad E470
intel i7 th Gen
intel/nvidia hybrid graphic (Nvidia Geforce 940MX) - driver video-hybrid-intel-nvidia-bublebee
Desktop Environment Gnome
Kernel 4.19.16-1

Dock: Lenovo Thinkpad Pro Dock USB 3.0 (40A7)

Console Out: xrandr -q

Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
eDP1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 310mm x 170mm
_ 1920x1080 60.02*+ 59.93 48.00 _
_ 1680x1050 59.88 _
_ 1400x1050 59.98 _
_ 1600x900 60.00 59.95 59.82 _
_ 1280x1024 60.02 _
_ 1400x900 59.96 59.88 _
_ 1280x960 60.00 _
_ 1368x768 60.00 59.88 59.85 _
_ 1280x800 59.81 59.91 _
_ 1280x720 59.86 60.00 59.74 _
_ 1024x768 60.00 _
_ 1024x576 60.00 59.90 59.82 _
_ 960x540 60.00 59.63 59.82 _
_ 800x600 60.32 56.25 _
_ 864x486 60.00 59.92 59.57 _
_ 640x480 59.94 _
_ 720x405 59.51 60.00 58.99 _
_ 640x360 59.84 59.32 60.00 _
DP1 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
HDMI2 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

I hope someone can help me.
Thank you!
greets mb_zirsch

#2

is that xrandr -q output done while its on the dock or off?




did you do a forum search first? always a good idea. most problems are solved easily this way.

#3

Hi!
First thank you for you reply!
I started this question because I have read all these threads first, unhappily without success.

While the dock is on.

Now i checked also the driver settings including the xorg.conf.nvidia file. I also checked if bumblebee is working well.

But there is something which i do not understand. After rebooting and running $screenfetch no GPU was found


Then I tried $sudo optirun intel-virtual-output
Now the GPU was found!

Do you have an idea why this is happening?

#4

bumblebee will keep the nvidia card powered down unless you run something with
primusrun $command
or
optirun $command
it does this to save power, so if you run screenfetch and nothing is using the nvidia card its not going to show

#5

One reason could be that the output is connected to dGPU/nvidia. intel-virtual-output is used to make secondary or external GPUs visible.

#6

Oh now it makes sense, why my matlab simulink simulation is not as fast as usual! So if i start applications with $optirun the gpu will be used for computation. (I am a noob ^^). Thank you for this information.

What does it mean “is connected to dGPU/nvidia”? So you think it is maybe a GPU/nvidia configuration problem.

When I start the nvidia settings,( $ sudo optirun -b none nvidia-settings -c :8 ) this error occurs:

(nvidia-settings:2931): GLib-GObject-CRITICAL **: 11:25:16.390: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
GPU at BusId 0x1 doesn't have a supported video decoder

after the prompt starts normal.

But it seems no external monitor is found:

#7

Have you checked Gnome Control Center for monitors?

#8

Jep, it makes no difference if connected or not!

#9

You should post info and logs as advised in this tutorial

1 Like
#10

You linked my thread that wasn’t resolved. I didn’t feel like doing the leg work to look into why Budgie wasn’t working, so I gave up on it and am using Manjaro KDE instead. Considering Ubuntu Budgie and every other Manjaro flavor, from my testing, works flawlessly, the issue is with Manjaro Budgie configuration alone.

Multiple monitor support aside, I do prefer Budgie over KDE, but I have work I’m trying to get done so KDE is what I settled on. I’d be happy if someone resolved this issue w/ Budgie of course.

closed #11

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.