Thinkpad Helix 1st generation - Reboot instead of shutdown after wake up from suspend

Hi everyone,

i’ve got a 1st gen Thinkpad Helix running Manjaro Gnome Stable.
Everything works fine, except one issue:

if system doesn’t go to sleep, shutdown (either via GUI menu or shutdown -h) works as intended.
After any wake up after suspend, any shutdown attempt will end with a reboot.
After that, i can proceed with actual shutdown.

I’ve done some research, tried popular fixes that didn’t work for me:

  • no wake-on-lan option or fast boot option in bios
  • tried with wlan on or off
  • tried shudown -P

I don’t have laptop-mode-tools installed, as i use tlp.

Could someone help me investigating this?

Inxy -Fazy:
  Kernel: 5.10.79-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64
  root=UUID=40606aa6-f68c-46e3-b37b-109b454aceb5 rw
  psmouse.synaptics_intertouch=0 quiet
  resume=UUID=1de4f70d-bd82-4733-84bc-796ce745c852 udev.log_priority=3
  Desktop: GNOME 41.1 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 41.0
  Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 36981A4 v: ThinkPad Helix
  serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: LENOVO model: 36981A4 v: Win8 STD DPK TPG serial: <superuser required>
  UEFI: LENOVO v: GFET65WW (1.44 ) date: 09/16/2019
  ID-1: BAT0 charge: 16.5 Wh (62.5%) condition: 26.4/42.0 Wh (62.9%)
  volts: 11.1 min: 11.1 model: SMP 45N1103 type: Li-poly serial: <filter>
  status: Discharging
  ID-2: BAT1 charge: 0.3 Wh (3.2%) condition: 9.3/28.1 Wh (33.3%) volts: 15.1
  min: 14.8 model: SMP 45N1101 type: Li-poly serial: <filter> status: Unknown
  Info: Dual Core model: Intel Core i5-3337U bits: 64 type: MT MCP
  arch: Ivy Bridge family: 6 model-id: 3A (58) stepping: 9 microcode: 21
  cache: L1: 128 KiB L2: 512 KiB L3: 3 MiB
  flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 14368
  Speed: 1618 MHz min/max: 800/2700 MHz Core speeds (MHz): 1: 1031 2: 1056
  3: 870 4: 968
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported
  Type: l1tf mitigation: PTE Inversion
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
  IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds status: Vulnerable: No microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Lenovo driver: i915
  v: kernel bus-ID: 00:02.0 chip-ID: 8086:0166 class-ID: 0300
  Device-2: Lite-On Integrated Camera type: USB driver: uvcvideo
  bus-ID: 1-1.6:4 chip-ID: 04ca:7028 class-ID: 0e02
  Device-3: Lite-On Integrated Rear Camera type: USB driver: uvcvideo
  bus-ID: 2-1.3:3 chip-ID: 04ca:7027 class-ID: 0e02
  Display: wayland server: compositor: gnome-shell driver:
  loaded: i915 note: n/a (using device driver) - try sudo/root display-ID: 0
  resolution: <missing: xdpyinfo>
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2)
  v: 4.2 Mesa 21.2.5 compat-v: 3.0 direct render: Yes
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Lenovo
  driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20
  class-ID: 0403
  Sound Server-1: ALSA v: k5.10.79-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.40 running: yes
  Device-1: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi
  v: kernel bus-ID: 03:00.0 chip-ID: 8086:0085 class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  Local Storage: total: 238.47 GiB used: 24.54 GiB (10.3%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: THNSNF256GMCS
  size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
  type: SSD serial: <filter> rev: N102 scheme: GPT
  ID-1: / raw-size: 224.12 GiB size: 219.54 GiB (97.96%)
  used: 24.54 GiB (11.2%) fs: ext4 dev: /dev/sda1 maj-min: 8:1
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
  used: 288 KiB (0.1%) fs: vfat dev: /dev/sda3 maj-min: 8:3
  Kernel: swappiness: 10 (default 60) cache-pressure: 50 (default 100)
  ID-1: swap-1 type: partition size: 4 GiB used: 0 KiB (0.0%) priority: -2
  dev: /dev/sda2 maj-min: 8:2
  System Temperatures: cpu: 49.0 C mobo: 0.0 C
  Fan Speeds (RPM): cpu: 0
  Processes: 226 Uptime: 8m wakeups: 3 Memory: 3.66 GiB used: 1.56 GiB (42.6%)
  Init: systemd v: 249 tool: systemctl Compilers: gcc: 11.1.0 Packages: 1200
  pacman: 1190 lib: 343 flatpak: 10 Shell: Bash v: 5.1.8
  running-in: gnome-terminal inxi: 3.3.09


issue seems gone since i set into /etc/tlp.conf


i hope this can be useful for other user of this nice old device