Thinkpad E585 Boot Disk Black Screen

laptop
amdgpu
xfce
installation
ryzen

#7

No problem. I should mention I just tested the boot disk on my Intel/Nvidia desktop and it worked perfectly.


#8

ok, this is one way you could try, delete everything between
after driver=free and before misobasedir=
it will look something like this:
driver=free nomodeset misobasedir=manjaro
if nomodeset does not work try aspi_osi=! instead


visual aid of what to erase


#10

Still getting the black screen, unfortunately. Should I just start from square one and burn another disk image?


#11

no, the usb seems fine, you said it boot on another system right?


#12

Yes, on main windows PC it worked great, no problems at all.


#13

instead of deleting anything try just adding acpi_osi=! acpi_osi="Windows 2015"
in the same area as the other parameters with a space between each like the rest of them are

so we know it works, i wouldnt get worried. im sure one of these parameters will work. im looking now to see if i can find one meant for a similar system to yours


#14

Ok, so just add both of those parameters between the ones where I deleted everything, but this time without deleting anything. Does placement matter, or just anywhere in between driver=free and misobasedir=manjaro? Do I want both in there at once or to try them separately?


#15

ok, your not the only one with this issue with your exact laptop and there is a special parameter you need for any linux to boot properly
ivrs_ioapic[32]=00:14.0
add this parameter right after driver=free just remember to leave a space before and after each parameter
ctrl+x

note: make sure you dont mistake 00:14.0 for 00:14:0 , its hard for some to see the difference at first


#16

So far I’m still stuck. I’ll give it another go and make sure I didn’t misspell anything.


#17

further reading in a very difficult to read blog that lenovo links to as a solution, it lists:
ivrs_ioapic[32]=00:14.0 ivrs_ioapic[33]=00:00.1
you may want to try this with/without deleting the other parameters

but if that too fails, just try adding iommu=softto the parameters that are there. its another parameter shown as a fix for your model and ive seen it used here on the forum previously with succcess.

after you get it installed, to make the boot parameter permanent, from command line:
if you run into the same problem after install/reboot you can edit the grub command line similar to how you did it on the installer iso.
*at the grub selection select manjaro, dont hit enter, hit " e " then on the “Linux” line delete only the word quiet and replace it with number 3 with a space before and after. dont erase "rw"
ctrl+x to boot
enter login/pw
and then:
sudo nano /etc/default/grub
edit the following line adding in whichever parameter/s work leaving a space between each
GRUB_CMDLINE_LINUX_DEFAULT="parameters-go-here"
ctrl+x , y, enter to save
sudo update-grub

here are some links of reference:
https://evilazrael.de/node/401



#18

Oh my gosh, it worked! Thanks so much!
You helped me for a whole 3 hours. If I can give you a review or some kind of points (I don’t how things work here) I’d be very happy to do so.
I’m gonna start installing and hopefully I don’t have any more issues.
Again, thanks so much for your help!


#19

:thinking::thinking::thinking: oh the possibilities. jk. thanks are good enough.

just dont miss the last part about making the kernel parameters permanent. after you install and reboot you may run into the same issue. if you do run into that problem (probably will), now you know what parameter to use its simple. i’ll edit the above post with the instructions and add how to get manjaro to boot straight to command line so you can log in, edit/update grub.


#20

Got it. I’ll check out the instructions.
Thanks, and have a great night!


#21

welcome to manjaro, enjoy. everything should be good from here.

@Arparagus , btw which of those parameter/s i listed did the trick?


#22

I typed in both of those without deleting anything.

Now I’m having even more fun, though. After doing the above just now I’m running into the black screen again. Do I also need to use the boot-disk solution before booting to the desktop, or just replace “quiet” with the number 3?

I just noticed the Linux line is part of an else statement. Is it possible one of the parameters in the lines above is keeping the else statement from executing?


#23

you can do either one, at grub, hit " e "and add
ivrs_ioapic[32]=00:14.0 ivrs_ioapic[33]=00:00.1 to the linux boot line.

or replace “quiet” with “3” and then it will bring you right to a tty, login and edit/update grub. either way you do it. to make it permanent you will need to edit/update grub. after that you wont have this problem anymore.


#24

Ok, now I’ve got it. Everything’s finally working all the way!


#25

good to hear, may i suggest now that you have it setup and working properly that you create a backup. timeshift is easy to use and can run rsync backups periodically on it own in the background and in the event you are playing around with something and manjaro stops working you can use timeshift to go back to any point that was created. its in the manjaro repo, there also some other backup/snapshot utilities but i just recommend what i know works well.


#26

Sounds like a plan. I’ll definitely get that set up asap. I’ll make a copy of this forum too just in case, 'cause I’m terrible at remembering this kind of stuff.


#27

i use this forum as a library of info/past solutions to problems. a quick forum search can usually fix 90+% of problems. and the community here are the best when it comes to helping a deserving newcomer. your particular laptop just so happened to need some kernel parameter specific to it that ive never seen before until i found them on that blog page about your laptop.