Thinkorswim Java Issue

Is anyone here familiar with Thinkorswim and the java oracle Java issue upon installation? I am a extreme novice with Linux. Running KDE Plasma here.

I can no longer find forum posts from other sites where they talked indepth regarding this issue. However, what I do remember is that Thinkorswim has updated to a new java? Or something along those lines.

My issue is that I am entirely new to Linux and very unsure as to how to update my system to this new oracle java version.

I apologize if this is vague, I am reaching here. Hoping that someone out there will be familiar with this issue.

Several months ago, I installed Think or Swim (ToS) using the file provided by TD Ameritrade. There was an issue for a short time with Java warnings, but that was eventually patched with an update via the ToS updater during the log in phase. I don’t remember whether or not I installed any new Java versions. Here’s what I have installed regarding runtime environments:

And common files:

Ok I ensured that I had those all installed. But still I have no success.

The ToS directory located within Home, has a “uninstall” konsole looking file within it. When I double click this, the uninstaller for ToS runs. However in the process of uninstalling I actually got this error:

java.lang.UnsupportedClassVersionError: com/devexperts/jnlp/installerCallback: Unsupported major.minor version 52.0

Also when I run the “launcher.jar” I receive this error:

“Zulu OpenJDK 11.0.10 or later is required to run application. Please manually update java and ensure it is the first java available in your system path”

Would anyone have any idea why I cant even run the Uninstaller?

As I was discussing in another thread > Thinkorswim Java Issue - #2 by leebut

I was attempting to install TD Ameritrades trading platform, Thinkorswim (TOS) However I seemed to run into a Java update issue which prevented me from installing (for the time being)

I want to simply uninstall TOS, and try a fresh install (after following the advice from the other thread) But the issues is that running the TOS uninstaller, I am then greeted with a error notification regarding a unsupptedClassVersionError issue.

So can I get around this by force uninstalling through the konsole some how?

When the app is created using Java - it is most likely running as a set of jar-files and installation is usually not necessary as jar files are self-contained and only requires a corresponding jdk.

You can have several versions of JDK installed - my initial guess is that your app needs an earlier version like JDK 11.

sudo pacman -Syu jdk11-openjdk

You can see your installed environments

 archlinux-java status

You can then set which one is active e.g. v11

sudo archlinux-java set java-11-openjdk

If the app in question requires an even older Java version then Java 7 and Java 8 is also available.

1 Like

I ran

archlinux-java status

And this is the result:

Available Java environments:
java-7-openjdk/jre (default)

Do you think I should just go ahead and begin testing with all my available java versions?

1 Like


I got TOS working by using

sudo archlinux-java set java-11-openjdk

I think I needed Java-11 set as my current Java environment.

1 Like

Java 8 is default on my PC, so I guess Java 7 was too old.

Available Java environments:
  java-8-openjdk (default)

Glad you got it working.

1 Like

Thanks for those commands. :slight_smile:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.