There are no partitions to install on


I wiped my old HDD today and installed Manjaro on it. After that I tried to boot it on my old computer, which has no other drives or OS. After booting up without any problems, it doesn’t seem to find the one and only drive in said computer. “There are no partitions to install on” it says. I tried to check my UEFI BIOS settings and already had AHCI enabled and fast boot disabled. It’s really confusing because it boots up perfecly and I can also find the drive in the booted Manjaro’s file manager. Any suggestions?

In the LiveISO, go into the gparted GUI, and check if you can see the drive. If you see it, in gparted, create a new partition table for that HDD, select GPT. This will also wipe the whole drive again.

See if that does anything.

Gparted detects the drive but can’t create a new partition table. It says that 1 partition is already active on the drive. I also can’t unmount the damn thing, it says"/run/miso/bootmnt target is busy."

can open a terminal and reports

inxi -Fza 
sudo parted -l 
sudo journalctl -b0 -p4