The wise way of combining Manjaro KDE and Windows 10?


First, the fundamental system info:

~ >>> inxi --admin --verbosity=7 --filter --width                                               
  Kernel: 5.4.188-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64
    root=UUID=befa46fa-af6a-4e1b-812b-f4986fb67877 rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: KDE Plasma v: 5.24.4 tk: Qt v: 5.15.3 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 20CK003HMD v: ThinkPad T550
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: LENOVO model: 20CK003HMD v: SDK0J40705 WIN
    serial: <superuser required> UEFI: LENOVO v: N11ET54W (1.30 )
    date: 09/01/2021
  ID-1: BAT0 charge: 36.6 Wh (100.0%) condition: 36.6/44.4 Wh (82.4%)
    volts: 12.8 min: 11.2 model: SANYO 45N1741 type: Li-poly serial: <filter>
    status: full
  ID-2: BAT1 charge: 18.3 Wh (100.0%) condition: 18.3/23.5 Wh (77.9%)
    volts: 12.6 min: 11.4 model: LGC 45N1127 type: Li-ion serial: <filter>
    status: full
  RAM: total: 15.52 GiB used: 4.47 GiB (28.8%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core i5-5200U bits: 64 type: MT MCP arch: Broadwell
    family: 6 model-id: 0x3D (61) stepping: 4 microcode: 0x2F
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 1218 high: 1834 min/max: 500/2700 scaling:
    driver: intel_pstate governor: powersave cores: 1: 819 2: 1088 3: 1132
    4: 1834 bogomips: 17567
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon
    avx avx2 bmi1 bmi2 bts clflush cmov constant_tsc cpuid cpuid_fault cx16 cx8
    de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority
    flush_l1d fma fpu fsgsbase fxsr ht ibpb ibrs ida intel_pt invpcid
    invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe msr mtrr
    nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln
    pni popcnt pse pse36 pti pts rdrand rdseed rdtscp rep_good sdbg sep smap
    smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow
    tsc tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic xsave xsaveopt
    xtopology xtpr
  Type: itlb_multihit status: KVM: Vulnerable
  Type: l1tf mitigation: PTE Inversion
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel HD Graphics 5500 vendor: Lenovo driver: i915 v: kernel
    ports: active: eDP-1 empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0
    chip-ID: 8086:1616 class-ID: 0300
  Device-2: Chicony Integrated Camera type: USB driver: uvcvideo
    bus-ID: 2-8:6 chip-ID: 04f2:b449 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,vesa gpu: i915 display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: AU Optronics 0x35ed built: 2013 res: 1920x1080
    hz: 60 dpi: 142 gamma: 1.2 size: 344x193mm (13.54x7.6") diag: 394mm (15.5")
    ratio: 16:9 modes: 1920x1080
  OpenGL: renderer: Mesa Intel HD Graphics 5500 (BDW GT2) v: 4.6 Mesa 21.3.8
    direct render: Yes
  Device-1: Intel Broadwell-U Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel bus-ID: 00:03.0 chip-ID: 8086:160c class-ID: 0403
  Device-2: Intel Wildcat Point-LP High Definition Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9ca0
    class-ID: 0403
  Sound Server-1: ALSA v: k5.4.188-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.49 running: yes
  Device-1: Intel Ethernet I218-V vendor: Lenovo driver: e1000e v: 3.2.6-k
    port: 3080 bus-ID: 00:19.0 chip-ID: 8086:15a3 class-ID: 0200
  IF: enp0s25 state: down mac: <filter>
  Device-2: Intel Wireless 7265 driver: iwlwifi v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 8086:095b class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
    bus-ID: 2-7:5 chip-ID: 8087:0a2a class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 297.07 GiB used: 170.62 GiB (57.4%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD PM851 2.5 7mm 256GB
    size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 8D0Q scheme: GPT
  ID-2: /dev/sdc maj-min: 8:32 type: USB model: N/A size: 58.59 GiB
    block-size: physical: 512 B logical: 512 B type: N/A serial: <filter>
    rev: 2.00 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  Message: No optical or floppy data found.
  ID-1: / raw-size: 238.17 GiB size: 233.43 GiB (98.01%)
    used: 166.31 GiB (71.2%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A
    uuid: befa46fa-af6a-4e1b-812b-f4986fb67877
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 280 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: N/A
    uuid: 29DA-2764
  ID-3: /run/timeshift/backup raw-size: 58.59 GiB size: 57.37 GiB (97.92%)
    used: 4.31 GiB (7.5%) fs: ext4 dev: /dev/sdc1 maj-min: 8:33 label: N/A
    uuid: 9f62bec8-7bfb-4152-8ce5-1d77041b8fe7
  Alert: No swap data was found.
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Full speed or root hub ports: 3 rev: 2.0 speed: 480 Mb/s
    chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-1:2 info: Intel Integrated Hub ports: 8 rev: 2.0 speed: 480 Mb/s
    chip-ID: 8087:8001 class-ID: 0900
  Hub-3: 2-0:1 info: Hi-speed hub with single TT ports: 11 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 2-2:7 info: USB Disk 2.0 type: Mass Storage driver: usb-storage
    interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 100mA chip-ID: ffff:5678
    class-ID: 0806 serial: <filter>
  Device-2: 2-5:3 info: Alcor Micro AU9540 Smartcard Reader type: Smart Card
    driver: N/A interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 50mA
    chip-ID: 058f:9540 class-ID: 0b00
  Device-3: 2-6:4 info: Validity Sensors VFS 5011 fingerprint sensor
    type: <vendor specific> driver: N/A interfaces: 1 rev: 1.1 speed: 12 Mb/s
    power: 100mA chip-ID: 138a:0017 class-ID: ff00 serial: <filter>
  Device-4: 2-7:5 info: Intel Bluetooth wireless interface type: Bluetooth
    driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA
    chip-ID: 8087:0a2a class-ID: e001
  Device-5: 2-8:6 info: Chicony Integrated Camera type: Video
    driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 04f2:b449 class-ID: 0e02 serial: <filter>
  Hub-4: 3-0:1 info: Super-speed hub ports: 4 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 43.0 C pch: 41.5 C mobo: 0.0 C
  Fan Speeds (RPM): cpu: 0
  Processes: 253 Uptime: 3h 24m wakeups: 1 Init: systemd v: 250
  tool: systemctl Compilers: gcc: 11.2.0 clang: 13.0.1 Packages: 1553
  pacman: 1536 lib: 445 flatpak: 5 snap: 12 Shell: Zsh v: 5.8.1 default: Bash
  v: 5.1.16 running-in: konsole inxi: 3.3.15

Now some context info:
After my searching for good guides on how to flash a bricked mobile phone using Linux Manjaro stranded, I have decided to have both Windows 10 and Manjaro in my laptop. (I have already all needed resources to flash inside Windows.)

How to do this partitioning the wisest way? As I have come to understand, one should first install Windows 10, then Manjaro subsequently, this because Windows tends to override partitions made prior to it. Is this correct?

This is how I think I should do it:

  1. Backup. I am using Timeshift’s snapshot.
  2. Reformat my laptop.
  3. Making the Windows partition - where I will be doing the flashing.
  4. Making the Manjaro partition.

What do you say? What I worry about is that simply adding a Windows 10 partition now could cause serious problems. I’d rather try not to take any risks.

I’d also love to learn what is the safest way to make use of the Timeshift snapshot once the new Manjaro KDE partition is installed and working?

Thanks, guys!

Kind Regards,

Where are you backing up to? Snapshots are not “backups” in the truest sense of the word.

What about your user’s home folder?

Once you format the drive and partition all over again from scratch (such as letting the Windows installer do its thing), then you lose everything on the laptop.

You didn’t mention whether or not you actually backed up your important data (even all of your data) to another source.

1 Like

If it is just for unbricking a phone (or attempting to …)
you could simply use a virtual machine (VirtualBox for example)

Microsoft even has ready to use VirtualBox images available for download
so deployment is very quick and does not even involve any installation.
I’d have to dig a little where to find it - but these are fully functional images for testing and developing Internet Explorer aka Edge
and are free to download and use and even licensed (for a limited amount of time).
Nothing illegal or shady.

You’ll find it by yourself … if you are interested in going that route I’ll dig up the link tomorrow if you can’t find it.

I was in a similar situation 4-5 months ago
but in the end the Windows tools didn’t help - some trial and error with adb and heimdall did the trick at the end :wink:

here is the link:

Virtual Machines - Microsoft Edge Developer

1 Like

This is correct. Install win10 first. Then install linux

1 Like

You have install Plasma Manjaro. There is an app named kpartition

1 Like

Thanks for helping me out, Winnie.

For pics, txts and such I already use cloud and external HD. But I would like to be able to, after the dual partition Windows/Manjaro, get right back into the full Manjaro settings I have already built. I get your point about snapshots, so in that specific sense is Clonecilla the better choice?

I don’t dare using the home folder in case something goes wrong during the process. I need a method that is foolproof. I am in a hurry, so I have no time for big mistakes this time.

For cloud I use MEGA and it syncs all data I am really afraid of loosing. At certain points I transfer from MEGA to an external drive.

Thanks for helping me out, Nachlese!

That idea is really interesting. I find it rather troublesome it didn’t cross my mind yesterday, as I do know about VB. But are you actually saying I can install, say, VirutalBox, after which I can install Windows 10, after which I can run Windows-based flashing tools? Of so, I think I would go for that method, because I have no genuine interest whatsoever of supporting Microsoft in any way whatsoever. I need to keep my association with that corp at an absolute minimum.

So, I tried flashing the Linux way, but I cannot, it seems, find the right file for "Download-XML in the SP Flash Tool. I have tried all recent versions and the problem remains the same: I have no idea where to find the wanted “./download_agent/flash.xml” in the load. I have searched and searched - and found literally nothing. See pic:

If you have the time, please tell me more about how you succeeded, including aspects of adb and heimdall?

Thanks for the link. It was indeed the one I just now was looking at. I will look at MSEdge on Win10 (x64) Stable 1809 on VM platform Virutal Box.

Thanks for helping me out, kearney!

Yes, I was pondering using the KDE Partition Manager. But I put it aside as I am in a hurry and I need to not make any serious mistakes.

You install a virtualization software
like VirtualBox
download the virtual machine image
they even provide instructions how to deploy it - but that is the standard way as also documented everywhere else

It’s not really an installation - it’s much faster.
You basically just extract the image and are done.

and then you can use it just like a real installation of windows

pass through your USB controller or just the one port that you need to the virtual machine
install and use your software
just as you would in a real install.

I have no knowledge about the tool that you included a picture of.
I was putting LineageOS onto a Samsung phone (A3 2016) when the flashing went wrong.
I don’t know whether the tools I used (heimdall, adb) are even appropriate for your phone - and it was a trial and error process which I didn’t document, so I don’t know exactly what it was that fixed it in the end. I don’t recall.

Perhaps I can help - and be it even only with hints - if you tell more about what you need to do/what you want to achieve.

1 Like

So a friend pointed me to this site from where I downloaded and tried these flash tools:

Download and install went all fine, but problems start as soon as it wants that flash.xml file. I have found no relevant description of it anywhere. I have been told, though, that drivers and support for flashing is much better with Windows than with Linux. Which I find odd. Or at least, I have no idea why it is so (if it is).

What I want to achieve:

  1. Originally my MAIN-GOALwas this:
    Learn to flash a bricked phone (Volla Phone X). That phone came with Ubuntu Touch OS, and I wanted to switch to the Volla OS, so I was advised to use Ubuntu’s UBports installer. I believe I flashed wrong OS, though - a sorry mistake, sigh. Then phone went all dead. No response at all.

  2. To learn flashing, however, I believe I need to make use of a smart phone flash tool (URL above) to awaken the phone. I need to get back into the phone. I have not succeeded in this, I always strand at that flash.xml file about which I find nothing.

  3. Which brings me to this issue described in this post: to correctly and fool-proof-safely partition my Lenovo into a Windows and a Manjaro. You are now telling me I could use a virtual machine, which sounds way better in my ears, than spending lots of time re-formatting and re-partitioning my laptop.

I believe this is what I want / need.

I’m sorry, but I cannot help you with that phone - lack of personal experience
with that phone and with the tools.
But since it was running some Linux variant
there probably is Support out there (fora like this here)
I’m totally unfamiliar with anything but flashing Android phones
and flashing some routers with OpenWRT to replace the original software …

There is almost always a way to recover from a brick - but it might involve getting actual hardware access and might be really work intensive.

Good luck!

1 Like

Thanks for your kind help!

So in any case you have got me thinking about trying out the virtual machine method.

Have a good day!

The best and safest way is to have Windows and Manjaro on two seperate discs (two UEFI paritions, each for a disc). That is how I have set it up 7 years ago and have no issues with it.

So basically, WIndows disc already existed, I just added SSD disc, where I installed Manjaro, poitned in GRUB to the Manjaro’s GRUB UEFI path and all runs correctly.


Thanks for helping me out, Michal!

Let me recap so as to ensure I really understand what you are saying.

  1. Secure stuff I want to keep, using cloud or external device.
  2. Download Windows 10 and Manjaro KDE, say, on 2 separate flashdrives.
  3. Reformat the laptop.
  4. Partition laptop, by way of flashdrive, into Windows OR Manjaro.
  5. Partition the second flashdrive OR external SSD into Windows OR Manjaro.

If this is correct:
Perhaps the easiest was to just keep my system as is and buy an SSD putting Windows 10 there?

I will also have to research another possible method mentioned by @Nachlese: namely to keep system as is, but do the tasks in a virtual machine set up for Windows.

Either of those two options are better than getting crazy with resizing, formatting, and/or reinstalling operating systems on your existing (and working) setup.

You can even get a cheap SSD just for Windows, since you won’t really be using Windows much.

The virtual machine method can work, so long as you don’t mind the extra space being used up on your current home partition just to hold the VM image.


If you already have Manjaro installed and are willing to buy a new SSD, then there is no need to re-format or re-install your current OS install. However, for safety reasons, do a backup first or sync your files with cloud.

  • Plug in the new SSD.
  • Add flash drive with Windows Install, reboot to it (by changing boot settings in BIOS), so the install would start, install Windows normally on a new SSD.
  • Now, this part will differ dependtly on your firmware, but basically you need to go to BIOS boot settings, chose curent OS install (Manjaro).
  • Start Manjaro, be sure you have os-prober enabled, if not, enable it.
  • Update GRUB, so os-prober would start detecting new systems.

If everything works fine, Windows should appear on GRUBs menu.

Again, since Windows is on seperate drive, there is no need to mess with the current install, but to be on a safe side, do a backup first.

In my case, I had HDD with WIndows 10, added SSD and installed Manjaro on it. Since I don’t use Windows (maybe once a year), I decreased size of its parition, and the new space I got, formatted to ext4 and use for keeping files (symliked to my home folder).


Yes, that’s probably the safest. I will first try out the VM as I do have interest in learning more about it. What VM do you recommend?

Yes. I will do that, thank you!

Would you mind describing to me how I enable the OS-prober? And how I update GRUB?

@Nachlese mentioned VirtualBox twice in this thread. The VM image itself is provided by Microsoft (also mentioned in this thread.)

1 Like

Yes, I have now installed VirtualBox. Getting ready to set it up with Windows 10. Looking forward to it. If it gets too time-consuming, I will simply buy a cheap Windows laptop. But I am still curious about doing flashing from whatever Linux distro, though I will have to postpone that project for later.

I thus closes off this topic.

Thank you to all of you, guys!