The unmounted partition caused manjaro to refuse to turn on

This is also a weird setting. Why not sticking to the standard?

tmpfs  /tmp  tmpfs  rw,nodev,nosuid  0  0

or just eliminating a setting for /tmp…

Well, there’s your problem. You tried to resize it, and “it didn’t work” — whatever that means — and now you’ve destroyed your partition. Given that it has been destroyed but that it didn’t have the nofail mount option for it, the system is trying to mount it but cannot find it, and then it hangs.

/tmp shouldn’t even need to be in /etc/fstab, because it is mounted by systemd by default.

@DanEm, for now, remove the line for the destroyed partition from your /etc/fstab and the system will boot again.

Yes, I just edited my post, I was not yet ready with my comment…

1 Like

I didn’t change anything and the swap works.

You can also drive your car on the wrong side of the road and it works… :wink:

1 Like

I just add nofail options and work.

I followed an online installation guide that said it was better to create partitions on tmp.

@DanEm, why don’t you focus on the key info you received:

I also did this, but the first solution also helped.

I doubt whether you’ll be able to mount it again, though. But at least your system boots again.

You cannot “create partitions on /tmp. In systemd-based distributions such as Manjaro, /tmp is a tmpfs by default. This means that the contents of /tmp reside in virtual memory — mostly in RAM, but they can be paged out to the swap device if necessary.

systemd sets up /tmp as a tmpfs when the system boots. There is no need for you to add a second mount for /tmp in /etc/fstab, because it will only obscure the original mount (by systemd) and hide what was already in there before /etc/fstab got processed.

Precious knowledge. So I have to change my partitions configuration. Thank you for quick help Mr. Aragorn. Glory to reunited Reunited Gondor and Arnor!

1 Like

If tmpfs should not be in fstab or with 1777 option, maybe someone from the developer team should communicate it with the calamares team or customize it.

Because right now, this is the default on every new manjaro installation (at least 2 months ago).

A Team member saying that default configs are wrong is not exactly a confidence booster for new users. Leaves the impression nobody knows what the other one is doing and that absolutely nobody tests things before pushing them to production.

I can confirm this going back to March 2023. This exact line is on my system too and I’m certain I didn’t put it there manually. The created and modified timestamps of my /etc/fstab match when I installed Manjaro, same as other basic files in /etc like os-release and hostname.

1 Like

About swap. On the manjaro wiki dedicated to fstab is wrong configuration on the picture in the section Example File link. I got this configuration during installation so something is wrong.

1 Like

And tmpfs with 1777 option is also on that wiki page :thinking:

1 Like

The calamares developers are unfortunately not amenable to advice from experienced users.

@philm added me to their Telegram group because he felt I could bring some useful experience to the table — he’s in there too — but they’ve made it very clear to me that they consider themselves smarter than myself, and I was asked to leave the group by its admin because he’s got some OCD-elitist issue about the channel being only for developers.

I do not have /tmp in my /etc/fstab, and it’s still being mounted at boot time. Therefore, it is unnecessary to add it to /etc/fstab.

systemd sets it up by itself. The only systemd-based distribution where it doesn’t is openSUSE, but they’ve done very strange things with their filesystem hierarchy, and it has become such a mess that they haven’t even bothered to clean it up anymore in years.

Those configs are not developed by Manjaro. calamares is an independent GNU/Linux installer used by many different distributions, among which EndeavourOS, Garuda, Artix, Chakra, OpenMandriva, Netrunner, Neon, Lubuntu, et al.

The permissions are correct, albeit unnecessary, given that tmpfs is a POSIX-compatible filesystem, and that only the permissions on the mountpoint need to be set to 1777, because the content of the filesystem will as such inherit the permissions from the parent directory, i.e. the mountpoint.

This is from my system…

[aragorn] >  ls -l / | grep 'tmp'
drwxrwxrwt  21 root root  720 Sep 14 00:03 tmp

[aragorn] >  mount | grep '/tmp'
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,nr_inodes=1048576,inode64)

[aragorn] >  grep '/tmp' /etc/fstab

[aragorn] > 

As you can see for yourself, it is not in my /etc/fstab, and yet it’s mounted with the proper permissions.

I believe the point is that OP is getting questions about why they have this weird setting, when they didn’t put it there, Manjaro did. It’s very confusing, if not maddening, for someone who needs help to be confronted with questions about why the default settings are there. Doubly so when the people asking are the supposed experts.

1 Like

Not directly. The calamares developers did that.

Like I said, calamares is not a Manjaro creation, but we use it, just as most of the software in our repositories comes straight from Arch without any modification. We only test it for much longer than Arch proper does.

The Manjaro community is made up of volunteers. We are not getting paid to offer assistance here, and none of us have proclaimed ourselves to be experts, although some of us do have much more experience than others.

Not to toot my own horn, but I have been exclusively running GNU/Linux on servers and workstations for over 24 years now and I’ve worked with proprietary UNIX systems in the 1990s — yes, I’m that old — but even I don’t know everything, and I’m not even a Manjaro developer, nor for that matter a calamares developer.

As I wrote higher up, @philm added me to the calamares developer channel on Telegram because he felt I could bring experience and knowledge to the table, but they asked me to leave again because I’m not “one of them”. So then what can we do, other than protest?

It’s not like I haven’t told the calamares developers that they were wrong in adding noatime to the entry for swap, or that /tmp is already mounted by systemd. I’ve told them all that, and repeatedly so. The problem is that they didn’t want to hear it from “an outsider”.

Humans… :roll_eyes:

If that record in fstab is unnecessary, may be someone could do something about that Manjaro wiki page… I don’t know… Edit it may be… Or is it also maintained by the calamares developers?

No, it is maintained by community members, but only a few of them have editing access to the Wiki, and not everyone is always available. In fact, it’s been a while since I’ve seen any of them around here.

Feel free to post a thread about it in the Wiki category, though. It’s actually all off-topic for this thread here.

Edit: There, I’ve done it myself… :arrow_down:

I think this thread here has now run its course and may safely be closed. :wink: