The package manager freezes if I type 3 or more characters in the search bar

Pretty much what the title says, I didnt do anything special at all, I think there was a small one file update yesterday though I dont really remember if I did or what the update was.

what I have tested, I opened up the terminal and sudo pacman -Syu to check if maybe something is conflicting nope, nothing.

I rebooted the system still have the issue.

not sure what else I could provide.

The problem is that it probably also searches the AUR, so there’s networking involved. If the AUR doesn’t respond quickly, you’ll experience this problem. Also, if it searches too often, your IP will be temporarily blocked from the AUR.

The “Add/Remove Software” program is pamac, not pacman.

this has never happened to me before, I barely used the aur, literally today I decided I want to install a new program vscode, and just typing the first 3 characters it worked but after that it freezes its not searching the aur because I havent pressed enter to actually search for it.

It’s happening to a lot of people atm, pamac is stuttering for me as well. As others have said the AUR is down atm and that is causing the lag

Oh okay, I did do a search before I made this post, good I guess to know its not just me, well thanks for the infomation!

Pamac relies on the search api provided by AUR web page. This search api is throttled and is appears to be overloaded by requests from AUR-helpers so the best advise is to learn the arch way.

It is very likely that some users has instructed their AUR helper to check for updates to AUR PKGBUILDs so the best you can do is to disable this functionality - so you don’t contribute to the uncessary load on AUR.

Use the AUR web interface - find the package - use the git clone url

git clone <https://aur.archlinux.org/pkgname.git

Then cd into the folder and build the package

cd pkgname

Build and install

makepkg -is
1 Like
1 Like