The ol' installer hang at 93% 18.0.4

New to Manjaro and - even after 15 years - new to Linux. Tried installing 18.0.4 on my (old) MSI 970A-G43 mobo. (Latest BIOS.) I got the hang at 93% which others have reported in the past.

As others have noted, it appears to be a NIC problem, since the NIC goes off line just as the Installer starts the pacman-mirrors -Syyuu stuff. (Per the log file, below.)

I didn't see a way to disable a possible offending RealTek driver from within Manajaro live. (Booted from USB.) For example, someone said to go to Hardware to remove it. But I don't see any category for the NIC in Hardware. (And, too, mine is not a WiFi NIC.)

Per a suggestion in this forum, I ran sudo -E calamares -d to capture a log file.

I don't see a way to attach a file here. So here's the link to it:

jumpshare.com/v/0SnEKrNpaKO3HNQuy3eY

I'm not looking to become a Linux geek. I would just like to get Manjaro installed so that I can run Resolve. So if you have a suggestion for me, please explain step by step what I need to try.

TIA.

1 Like

Weird, I have in one of my computers the exact same motherboard and I had zero issue with any of the Manjaro installers. Silicon lottery? :wink:

Anyhow, to turn off the nic. It's in Integrated peripherals....

Also, make sure you have the latest BIOS.

https://www.msi.com/Motherboard/support/970A-G43#down-bios

Thanks. That's easy enough to do. I read that the Installer doesn't need to be on-line to work, altho I see that the GUI Installer picks up my City when I'm on line. (I tried the Command Line version of the Installer. The wiki is way out of date and the Command Line installer was too complicated for this Linux newbee.)

BTW, I just upgraded to an AMD-FX8350 on this mobo. I don't know what CPU you've to in yours. But I wonder if that is the difference between why Manjaro installed for you, but not for me. (Like, too fast?)

1 Like

Oh, and yes, I have the latest BIOS. (Else wouldn't have been able to install the 8350.)

1 Like

FX6300. I have an 8350 in a box in my closet... somewhere. I had no end of power issues with that on this board. The vrms overheat. And that would be because it might not support that CPU.
The listing is only for BIOS A.0 and I never could find a listing for A.6 (latest BIOS).
Anyways, I went back to the 6300 for this computer (Frank) and it's been fine.


Also, just a note. Call me paranoid, but it's better if you pastebin/dpaste the log or just copy/pasta it here using the </> button when you reply/post.
Or you can use three backticks ``` (under the ESC key) before and after the pasted section.
:grin:

1 Like

Try booting the install media without the ethernet cable plugged in and run the installer.

1 Like

sometimes the installer hangs at various % ... keep waiting about 30 minutes, or get a different iso/de, and tweak around your boot settings...

I waited 30 minutes on the hang - no joy.

I did try the gnome iso. (Had started first with KDE.) No joy there either.

As for tweaking around my boot settings - well, you see, that is starting to get into Linux geeky things. One has to know what to add in order to tweak. (Altho, at the suggesting of someone else who had the 93% hang, I did delete the noveau and intel gpu lines.) Some people suggested changing the NIC driver at boot. But I have no idea what to type to make that happen.

I am about to try to two easy tips - no ethernet cable and disable my NIC in BIOS. Will report back.

Okay, the good news is that I got Manjaro installed. The trick that worked was to disable the NIC in the BIOS. Then, after the install finished (and it blew thru the 93% part this way) I had to click on something in the bottom right of the screen (I don't remember what it was) to get the NIC recognized.

(Sorry, I didn't try simply pulling the Ethernet cable while leaving the NIC enabled in BIOS.)

The driver that installs in Manjaro is the infamous r8169.

Windows reports it as a 8168.

So perhaps that's the problem?

My MSI 970A-G43 User Guide (European version, but board bought in the USA) says it's a Realtek 8111E.

Interestingly, when I first started my testing this morning, I forgot to plug the USB flash drive to boot Live. To my surprise, Manjaro started up from my hard drive - although I did not have NIC support.

So, apparently, even when the installer freezes at 93%, enough of the OS gets installed to boot.

The bad news is that Resolve wouldn't run. As a minimum, I need OpenCL drivers. I went to Nvidia's CUDA page and tried to download an appropriate SKD for Manjaro. But no Arch Distribution listed.

BlackMagic says that the its Linux flavor of Resolve 16 was designed to work with CentOS. So I guess I'll have to try that next.

Thanks for your help here.

1 Like

For @SinisterBrain, since this thread will disappear in 3 months I'll go off topic.I was initially going to go with the AMD FX-8320E, the 95W version of the 8 core. As you correctly noted, the list of supported CPU's on MSI's website for the initial BIOS does not show the 8350 as being supported.

But then I was searching around the web and found numerous ppl on youtube running the 8350 on this mobo with the latest BIOS Rev. I did see that some had overheating problems with the VRM. But I had been running an overclocked Phenom II X4 with at least the same 125 W TDP with no problems. (Possibly 145 W.) So I took a chance with the 8350.

I dunno - maybe some MSI boards use different VRM's. Or maybe it's the power supply. But I've been running my new 8350 for a few weeks now, mild overclock, all cores running 100% for minutes at a time, and no problems. (Had to increase my RAM voltage from 1.50 to 1.55v. That was all.)

I was noodling around in youtube and found a spanish guy who got Resolve to work with Manjaro. It looks like all that he did was tell an Nvidia control panel to download the opencl driver. But it's too hard to see exactly what he's doing on the video.

Then I found another guy who used something called a snapshot to get all the dependencies needed to run Resove on Manjaro. https://aur.archlinux.org/packages/davinci-resolve/

So I guess I'm gonna hack around some more. (Wish linux weren't this hard.)

1 Like

Can I ask why you don't just download the opencl-nvidia package from the repos?

6 multilib/lib32-opencl-nvidia-390xx 390.129-1 (12.9 MiB 59.7 MiB) 
    OpenCL implemention for NVIDIA (32-bit)
5 multilib/lib32-opencl-nvidia-340xx 340.107-1 (10.7 MiB 38.5 MiB) 
    OpenCL implemention for NVIDIA (32-bit)
4 multilib/lib32-opencl-nvidia 1:430.40-1 (13.9 MiB 72.6 MiB) 
    OpenCL implemention for NVIDIA (32-bit)
3 extra/opencl-nvidia-390xx 390.129-1 (12.5 MiB 60.7 MiB) 
    OpenCL implemention for NVIDIA
2 extra/opencl-nvidia-340xx 340.107-1 (10.1 MiB 37.6 MiB) 
    OpenCL implemention for NVIDIA
1 extra/opencl-nvidia 1:430.40-1 (13.2 MiB 74.9 MiB) 
    OpenCL implemention for NVIDIA

Versions might be a little different as I'm on Testing branch

Your luck is apparently better than mine. :wink:
I thought there might be a variation in the VRMs as well but I've built several computers for other using that board (long time ago) and from my limited sample size, all the VRMs are the same.
I did send an email to MSI yesterday however asking for an updated CPU compatibility sheet but who knows if they care enough about an EOL mobo?
RE: Psu. I never skimp on my PSUs. That's asking for trouble. Seasonics and Corsairs (Channelwell usually) are my usual choices.

Maybe I'll dig out the 8350 this weekend and see if things have changed.
I've noticed my temps and cpu utilization in Linux is much more sane than in Windows. Plus, I have a much better cooling setup now than my first try.

1 Like

I think I tried something like that, but it kept saying that I had a conflict.

I found a page in wiki.arch about that, that I needed a generic header file. When I installed that, Resolve worked. (So apparently I had opencl somewhere in my system.)

However, even tho Resolve seemed to work, I could not open .mov files that I used to be able to open in earlier versions of Resolve.

I'm going to give up on Resolve and Linux. At least until you come to my house and hack it for me. :slight_smile:

Will see if I can hack an install into Win8.1. (It's Win10 only, but some say it can be installed in Win8.1.)