The modem shows no carrier

is new message for last build dev

Always the message, but less recursive, despite the updates

The problem remains present even in unstable.
The problem is mainly that it eats the battery

Can you post your carrier you have? Also, that message is related to mobile data, it is WIP at the moment and does not affect calls or sms/text. Most likely introduced due to our work with Canonical and KDE e.V.:

Upstream work can be tracked here:

1 Like

reinstall: before sav: calendori/vard phonebook
indeed when I turn off mobile-data I no longer have an alert.
plasma-mobile : 20210317

stop mobile-data blocks the restart of the telephone link ;
On the other hand when you restart you have to do sudo systemctl restart ofonoctl
APN Internet
Nom : Free
APN : free
MCC : 208
MNC : 15

Nom : Free MMS
APN : mmsfree
MCC : 208
MNC : 15
Type d’APN : mms

Centre de message SMS

How to configure MMS .svp

Hello, the 2021/03/19 last update plasma-mobile.

I only have one message telling me a problem with the mode and it is only after a reboot, otherwise the recursive messages on disappeared.

That’s nice to know. :slight_smile:

Sounds like this is known and being handled, but wanted to put forward my experience as well anyway.

I’m also getting this notification. I’m not 100% sure what the cause is yet as it’s not all the time, but when it happens it tends to notify me every 5 minutes with the following:

Modem (quectelqmi_0)
The modem shows no carrier

I’m with Honest Mobile (UK), but I’m roaming and connecting to Proximus (Belgium) cell sites.

I’ve also noticed another issue in a similar area.
I get the following notification occasionally:

Modem (quectelqmi_0)
IP configuration was unavailable

When this occurs, I lose signal and must restart the phone again to get it back.

1 Like

Just got the new pinephone beta edition. Was getting “modem shows no carrier” mobile data did not work. I could make phone calls okay.

sudo systemctl status ofonoctl
and it reports
inactive (dead)
Trying to online a modem that's not powered on

sudo systemctl restart ofonoctl

Get’s me a promising:

Brought quectelqmi_0 online

But still I get no data/internet connectivity.

Any ideas?
(I hope this helps somebody.)

1 Like

Update on my side of things:

I contacted my phone service provider (Honest Mobile) linking them to my original comment. Just to ask if they had any thoughts or logs/diagnostics that might’ve hinted at a problem interfacing with the service from my phone/SIM.

Afraid I can’t see anything odd in the logs so suspect you’ve a software issue but I will keep monitoring!

I expected that to be honest, but figured it’d be good to check.

Just a heads-up, I’ve had the problem with these notifications, my signal dropping, or being unable to use data with all versions named above.

Upgrading to Manjaro-ARM-plasma-mobile-pinephone-dev-20210530.img.xz has resolved the issues for me.

1 Like

Ahh, and this one was me judging too soon as well.
Sorry, I’ll wait at least 48 hours before concluding in future, my fault for being impatient.

Usually, the phone signal dropped within a few minutes to an hour. This time, I could use the phone for hours on data perfectly fine, but it happened again last night while I was asleep.

“The modem shows no carrier” notifications didn’t occur, however I did get “IP configuration was unavailable”, and my signal/data was gone. Had to restart the device to get it back.

I have similar issues. I get the no carrier message too. I can make a phone call but no data.

And wifi goes down if the phone goes into power saving/sleep. Update downloads will come to a halt unless I keep the screen active… or kill upower and powerdevil.

So i just got a Pinephone last sunday. It of course had Manjaro plasma edition installed on it. I use Straight Talk in America for my phone service. I couldn’t get any 4G connection, but i could make calls and send text messages. There was nothing showing up in Access points under mobile settings. So i installed Manjaro Phosh, and i was able to put in my APN settings through their interface. I couldn’t figure out how to put in my APN address into the plasma settings.

The settings i use for my Straight Talk (SIM CARD For Verizon Phones)

Name = Tracfone
APN = tracfone.vzwentp

That’s because it’s not implemented yet. If your carrier needs you to put in the details, Plasma Mobile is not for you yet. :frowning:

1 Like

Yeah i had read their roadmap for plasma right after i had wrote this post lol.

hi . getting the same message , modem shows no carrier , here in Australia and with telstra . can make calls n text but that’s it

1 Like

In australia as well, but with optus (amaysim). I get a message from optus stating ‘a message you tried to send/recieve has failed because you don’t have credit’. Can switch to phosh and send texts fine. I also see the ‘The modem shows no carrier’ message