The manjaro-sway iso is mostly unresponsive on my ThinkPad E540. Should it work better?

i’m inclined to believe sway and wayland are working for other folks. i wonder why not for me? Are sTinkPads not happy on wayland? This vid gave me (false?) hope. My e540’s quite a bit newer than that one afterall. Haven’t gone and tried ubu as of yet tho.

Configure NVIDIA (non-free) settings and load them on Startup suggests how to switch between free and nonfree drivers, but it requires a reboot. Is there a way to do so with the iso?

manjaro-sway-21.1.0-211230-linux515.iso boots up, my keyboard and mouse work, i can use either one to change the language or dismiss the installer, mod+? toggles the help just fine, but neither mod+enter nor mod+d bring up a shell or a launcher, and after trying them, nothing further appears in either journalctl or dmesg and no new or changed files appear within /tmp/** /home/** /var/log/**. Same lack of response whether i boot up with or without my 2nd and 3rd displays attached. Any ideas?

i’m on a ThinkPad e540.
Here’s the sway live environment dmesg:
Here’s the sway live environment journalctl:
Neither inxi nor xrandr are in the sway iso. Here they are on my installed KDE system:

 # inxi --admin --verbosity=7 --filter --width
  Kernel: 5.16.0-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.16-x86_64
    root=UUID=b2d9c25b-03ab-4676-ae6e-cc4dce724d09 rw panic=30
  Desktop: N/A wm: kwin_x11 vt: 1 dm: startx Distro: Manjaro Linux
    base: Arch Linux
  Type: Laptop System: LENOVO product: 20C6008SUS v: ThinkPad Edge E540
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: LENOVO model: 20C6008SUS v: 0B98401 WIN serial: <superuser required>
    UEFI: LENOVO v: J9ETA2WW (2.28 ) date: 06/20/2018
  ID-1: BAT0 charge: 17.6 Wh (51.6%) condition: 34.1/52.8 Wh (64.5%)
    volts: 11.3 min: 11.1 model: LGC LNV-45N1 type: Li-ion serial: <filter>
    status: Not charging
  RAM: total: 7.65 GiB used: 3.13 GiB (40.9%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core i5-4200M bits: 64 type: MT MCP arch: Haswell
    family: 6 model-id: 0x3C (60) stepping: 3 microcode: 0x28
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 2494 high: 2495 min/max: 800/3100 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 2494 2: 2495 3: 2494
    4: 2495 bogomips: 19961
  Flags: abm acpi aes aperfmperf apic arat arch_perfmon avx avx2 bmi1 bmi2
    bts clflush cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64
    dtherm dts epb erms est f16c flush_l1d fma fpu fsgsbase fxsr ht ibpb ibrs
    ida invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe
    msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs
    pge pln pni popcnt pse pse36 pti pts rdrand rdtscp rep_good sdbg sep smep
    ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tsc tsc_adjust
    tsc_deadline_timer vme xsave xsaveopt xtopology xtpr
  Type: itlb_multihit status: KVM: VMX unsupported
  Type: l1tf mitigation: PTE Inversion
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
    IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel 4th Gen Core Processor Integrated Graphics vendor: Lenovo
    driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:0416 class-ID: 0300
  Device-2: Realtek Integrated Camera type: USB driver: uvcvideo
    bus-ID: 3-12:7 chip-ID: 0bda:5719 class-ID: 0e02 serial: <filter>
  Display: server: X.Org compositor: kwin_x11 driver:
    loaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x2616 s-dpi: 96 s-size: 507x691mm (20.0x27.2")
    s-diag: 857mm (33.7")
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio
    vendor: Lenovo driver: snd_hda_intel v: kernel bus-ID: 00:03.0
    chip-ID: 8086:0c0c class-ID: 0403
  Device-2: Intel 8 Series/C220 Series High Definition Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:8c20
    class-ID: 0403
  Device-3: SteelSeries ApS SteelSeries Arctis 7 type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-1:2 chip-ID: 1038:12ad
    class-ID: 0300
  Sound Server-1: ALSA v: k5.16.0-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.40 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel port: 3000 bus-ID: 03:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Intel Wireless 7260 driver: iwlwifi v: kernel bus-ID: 04:00.0
    chip-ID: 8086:08b2 class-ID: 0280
  IF: wlp4s0 state: down mac: <filter>
  WAN IP: <filter>
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
    bus-ID: 3-7:5 chip-ID: 8087:07dc class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 465.76 GiB used: 147.97 GiB (31.8%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: HGST (Hitachi) model: HTS725050A7E635
    size: 465.76 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: A8Z0 scheme: GPT
  Optical-1: /dev/sr0 vendor: ■■■■■■■■ model: DVD-RAM UJ8E2 rev: 1.00
    dev-links: cdrom
  Features: speed: 24 multisession: yes audio: yes dvd: yes
    rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
  ID-1: / raw-size: 415.84 GiB size: 408.31 GiB (98.19%)
    used: 147.93 GiB (36.2%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A
    uuid: b2d9c25b-03ab-4676-ae6e-cc4dce724d09
  ID-2: /boot/efi raw-size: 476 MiB size: 475.1 MiB (99.80%)
    used: 38.7 MiB (8.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: N/A
    uuid: 1FEA-1CC9
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: file size: 16 GiB used: 0 KiB (0.0%) priority: -2
    file: /f/swapfile
  ID-1: /dev/sda3 maj-min: 8:3 size: 16.76 GiB fs: ntfs label: N/A
    uuid: 03FDF2F31548EC3F
  Hub-1: 1-0:1 info: Full speed or root hub ports: 3 rev: 2.0 speed: 480 Mb/s
    chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:8008 class-ID: 0900
  Hub-3: 2-0:1 info: Full speed or root hub ports: 3 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-4: 2-1:2 info: Intel Integrated Rate Matching Hub ports: 8 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:8000 class-ID: 0900
  Hub-5: 3-0:1 info: Hi-speed hub with single TT ports: 14 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-1:2 info: SteelSeries ApS SteelSeries Arctis 7 type: Audio,HID
    driver: hid-generic,snd-usb-audio,usbhid interfaces: 6 rev: 1.1
    speed: 12 Mb/s power: 100mA chip-ID: 1038:12ad class-ID: 0300
  Device-2: 3-2:3 info: Dell KB216 Wired Keyboard type: Keyboard,HID
    driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 1.5 Mb/s
    power: 100mA chip-ID: 413c:2113 class-ID: 0300
  Device-3: 3-6:4 info: Dell Optical Wheel Mouse type: Mouse
    driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 1.5 Mb/s
    power: 100mA chip-ID: 413c:3012 class-ID: 0301
  Device-4: 3-7:5 info: Intel Bluetooth wireless interface type: Bluetooth
    driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA
    chip-ID: 8087:07dc class-ID: e001
  Device-5: 3-11:6 info: Validity Sensors VFS5011 Fingerprint Reader
    type: <vendor specific> driver: N/A interfaces: 1 rev: 1.1 speed: 12 Mb/s
    power: 100mA chip-ID: 138a:0011 class-ID: ff00 serial: <filter>
  Device-6: 3-12:7 info: Realtek Integrated Camera type: Video
    driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 0bda:5719 class-ID: 0e02 serial: <filter>
  Hub-6: 4-0:1 info: Super-speed hub ports: 6 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 55.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 0
  Processes: 213 Uptime: 1h 9m wakeups: 1 Init: systemd v: 249 tool: systemctl
  Compilers: gcc: N/A Packages: pacman: 1142 lib: 312 Shell: Bash v: 5.1.12
  running-in: tmux-master2021 inxi: 3.3.11

 # xrandr
Screen 0: minimum 320 x 200, current 1920 x 2616, maximum 16384 x 16384
eDP-1 connected primary 1366x768+552+1848 (normal left inverted right x axis y axis) 344mm x 193mm
   1366x768      60.01*+
   1280x720      60.00    59.99    59.86    59.74  
   1024x768      60.04    60.00  
   960x720       60.00  
   928x696       60.05  
   896x672       60.01  
   1024x576      59.95    59.96    59.90    59.82  
   960x600       59.93    60.00  
   960x540       59.96    59.99    59.63    59.82  
   800x600       60.00    60.32    56.25  
   840x525       60.01    59.88  
   864x486       59.92    59.57  
   700x525       59.98  
   800x450       59.95    59.82  
   640x512       60.02  
   700x450       59.96    59.88  
   640x480       60.00    59.94  
   720x405       59.51    58.99  
   684x384       59.88    59.85  
   640x400       59.88    59.98  
   640x360       59.86    59.83    59.84    59.32  
   512x384       60.00  
   512x288       60.00    59.92  
   480x270       59.63    59.82  
   400x300       60.32    56.34  
   432x243       59.92    59.57  
   320x240       60.05  
   360x202       59.51    59.13  
   320x180       59.84    59.32  
VGA-1 connected 1366x768+553+1080 (normal left inverted right x axis y axis) 256mm x 274mm
   1360x768      59.95*   60.02  
   1024x768      75.03    70.07    60.00  
   800x600       85.06    72.19    75.00    60.32    57.90    56.25  
   640x480       75.00    72.81    59.94  
   720x400       70.08  
HDMI-1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 698mm x 392mm
   1920x1080     60.00*+  59.94    30.00    24.00    29.97    23.98  
   1920x1080i    60.00    59.94  
   1680x1050     59.88  
   1280x1024     75.02    60.02  
   1440x900      59.90  
   1280x960      60.00  
   1360x768      60.02  
   1280x800      59.91  
   1152x864      75.00  
   1280x720      60.00    60.00    30.00    59.94    29.97    24.00    23.98  
   1024x768      75.03    70.07    60.00  
   800x600       72.19    75.00    60.32  
   720x480       60.00    59.94  
   720x480i      60.00    59.94  
   640x480       75.00    72.81    60.00    59.94  
   720x400       70.08  
DP-1 disconnected (normal left inverted right x axis y axis)

if any further info might help, i’ll be glad to provide…

Please see:

Please also edit your topic title to reflect what the issue is you’d like help with.

1 Like

i edited it a bit. Good yet?

1 Like

I have a thinkpad W540 (core i7 4700mq) (similar in specs to your E540) that came with a Nvidia Quadro K1100M. The newest nvidia driver that supports that is 418. Nvidia did not introduce Optimus support (aka the ability to use the descrete graphics card in combination with the integrated graphics) for their hardware on linux until the 450 driver (aka they never even finished implementing support for their hardware on linux during the lifetime of said hardware - i won’t be getting nvidia again anytime soon).

I never had a good performance experience trying to use the Nvidia graphics on my laptop (bumblebee was the best experience using it, but it does not support vulkan). I would expect roughly the same experience on an E540 as well.

I had a much better experience going with open-source drivers for intel, and completely ignoring the nvidia hardware. I haven’t tried Sway on it, but I use Xfce (uses X11, not wayland) and it’s quite snappy. I didn’t have to do any special tweaking or configuring to get that snappy performance. Don’t expect to run any fancy games on it tho. N64 games run well through retroarch. Some Gamecube games also run well through dolphin-emu

Nvidia and Sway don’t play nice, I guess that is the problem. I switched notebook due to that.

check my inxi output above. no nvidia! other e540 lappies may have nvidia but this one has intel.