The last update kills my network gateway

Hello, forummates!

After the last update of this system, I ran into a problem: when Manjaro connects to my network, the router goes for a full reboot. There is with a 2 different PC. I tried 2 different network adapters:
An integrated:

~> lspci | grep Ethernet
05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 16)

an usb device:

~>lsusb | grep Ethernet 
Bus 001 Device 003: ID 0fe6:9700 ICS Advent DM9601 Fast Ethernet Adapter

When life-USB( with Manjaro 21.3.7) connects to this network, there are no problems.

How does it works? Can someone direct me to the desired search area?
What the network control packages was update in Manjaro 22.0.4 ?

What the packages and how can I restore for “investigate” this trouble?

Operating System: Manjaro 22 Linux KDE Plasma
Version: 5.26.5 KDE Frameworks Version: 5.103.0 Qt Version: 5.15.8
Kernel Version: 5.15.94-1-MANJARO (64-bit)
Graphics Platform: X11
Processors: 6 × Intel® Core™ i5-8400 CPU @ 2.80GHz
Memory: 7,7 GiB of RAM
Graphics Processor: NVE7
Manufacturer: Gigabyte Technology Co., Ltd.
Product Name: H310M H 2.0

Thanks everyone

Your ROUTER reboots? :thinking:

How can any system cause a reboot on another device just by connecting to it, without sending special-purpose commands to it? :face_with_peeking_eye:

I fail to understand how DHCP can cause a reboot of the router…

1 Like

I am no less surprised. I did it right after the update, but it became noticeable after when other devices suddenly lost the network. then it was noticed that when this computer is connected, the router reboots.
I thought that the problem was in the cable or network board (suddenly the connector was clogged and a short circuit occurred). I checked everything, cleaned it, replaced the connector on the cable.
Trouble repeated.
I connected another PC with the Windows – no trouble.
I connected another PC with the same Manjaro 22 – trouble was returns.
I was load life-usb with the Manjaro 21.3.7 – no trouble.

I came across a situation where, when connecting one device to wi-fi, there were problems with a limited connection for other devices on this network.
but with the same number of connected devices, when the same thing was absent, there were no “harmful” complications. that is, it’s not an overload of the router.

I will try to take packages by Wireshark via hub + another PC may be find out something new…

Can you tell us which router you use? Sounds more like a router problem.
Another ideas:

  • Do you use DHCP (IP addresses come from the router); if not, check that you don’t have double IP addresses
  • Does the router has a log which could be helpful?
  • Can this be a problem of Ethernet speed auto negotiation? Which speeds does the router support?
  • Possibly ‘ethtool ’ and ‘netstat -i ’ could give some hints. Replace with the name of your Ethernet as reported by ‘ip link show’. ethtool might not be installed by default. Netstat should not report errors (RX-ERR and TX-ERR are 0)

Eventually post the results

1 Like

A few years back, when torrenting was en vogue, my plaste router from a large German ISP was rebooted when it had to handle more than 150 concurrent connections

Maybe you’re spawning too many connections?

1 Like

i tried recording network traffic, but I can`t found anomalies

In last week upgrade the trouble was gone

But yesterday when I`m upgrade my OS the problem back

I was connect Watcher-PC via HUB to Router and tried connecting Mnajaro-Killer to HUB,
at the same time recording traffic with Wireshark

Watcher-PC is
Mnajaro-Killer is

link to gist with Wireshark record gist. github. com / yakhaSocial/9f7a558b33a10842ccb58c4b601b35b5

forum disable linking and file too long for post

That points to something going on the ISP side.

But it could also be an application or service as mentioned earlier by @mithrial

I found four distinctive devices

device ip mac
Cambridg_bb:2a:c0 1 e0:1d:3b:bb:2a:c0
HMDGloba_01:c2:a0 154 a8:cc:6f:01:c2:a0
Giga-Byt_bd:f6:f8 157 b4:2e:99:bd:f6:f8
RealtekS_53:44:58 251 00:e0:4c:53:44:58
  • device Giga-Byt_bd:f6:f8 is trying to connect to something using KDEConnect but fails
  • at some point a connection is established to RealtekS_53:44:58
  • at times device Giga-Byt_bd:f6:f8 is shouting in wind - getting no answer
  • at times device RealtekS_53:44:58 shouts in the wind - then reconnect with Giga-Byt_bd:f6:f8
  • the device Giga-Byt_bd:f6:f8 appears to be the epi center - perhaps the app KDEConnect is creating the issues.