The Installer Failed to Create a Partition

I have seen other threads in this forum with similar problems, but I can’t understand the solutions under them and I don’t trust myself to interpret them and potentially damage my computer.
I have used Manjaro GNOME for a while now, and felt I needed to switch. I flashed Manjaro KDE Plasma onto a USB and tried to install it from a live session.
I entered in my preferences, but most importantly: I did not change the partitioning setting. I barely understand how partitions work, I do not care about dual-booting, I simply want to install a different OS onto my computer. I want to erase my current disk, and replace it with the default for Manjaro KDE Plasma.
I clicked “Install”, and at 1% into the process, the installation failed, giving me this error message:

Error Message

The installer failed to create a partition on disk ‘SAMSUNG MZVLQ256HAJD-000H1’.

Create a new partition (238.17 GiB, ext4) on ‘/dev/nvme0n1’

Job: Create new partition on device ‘/dev/nvme0n1’

Command: sfdisk --force --append /dev/nvme0n1

Command: sfdisk --list --output Device,UUID /dev/nvme0n1

Job: Set the label on partition ‘/dev/nvme0n1p2’ to “root”

Command: sfdisk --part-label /dev/nvme0n1 2 root

Job: Create file system ‘ext4’ on partition ‘/dev/nvme0n1p2’

Command: mkfs.ext4 -qF /dev/nvme0n1p2

If I try to install a second time on the same live session, the options for resizing and replacing partitions in the installer disappear.
I can no longer boot into Manjaro GNOME from my hard drive, even though the installer detects it.
The OS history of my computer (if that helps) is Windows 11 → Linux Mint → Manjaro GNOME.
My main problem with other threads on this issue is that I cannot understand what their solutions entail. They mostly gloss over “format your partitions on HDD/SSD how you want them”, which seems to be the point where I am stuck at. (I’m not even sure what HDD or SSD are.) If someone could please help me, in simple terms, to understand and fix the problem, that would be extremely appreciated.

Disable KDE’s new automount feature, it breaks Calamares partitioning logic.

It’s in System SettingsRemovable StorageRemovable Devices → untick “On Attach” for “All Known Devices”.

It’ll be fixed with the next ISO release.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.