The forum PWA stopped working in Firefox on Android


#1

I have the forum pinned to the homescreen of my Android phone using Firefox (press the home+plus icon in the URL bar) so that it loads up like an app without any of the browser chrome present.

However, since yesterday, the pinned version of the forum is not loading properly anymore. It stalls at a white screen and the forum does not load. However, pretty much nothing has changed on my side since it worked and when it stopped working.

The weird thing is that when I open Firefox normally, the forum loads without a hitch. I have already deleted and re-added the forum, but that doesn’t solve my problem. I have rebooted the phone.

The last OS update on my phone has been a while back and Firefox was last updated on January 9th. I have absolutely used the forum on my phone after that date.

So maybe this is due to an update server side? Could someone confirm my issue? Could someone say if the forum software or server have been updated in the past 2 days? TIA!


#2

I confirm.
Fennec 64.0.2, LineageOS 15.1.


#3

Thanks. Let me add my details as well: OnePlus 3T, OOS 5.08 (Android 8.0.0), Firefox 64.0.2.


#4

Just tried it, and it works fine on my end. However, it took some time to load (about 10 seconds), in that time it was only showing a white screen.

Pixel 2, Android 9.0 Stock January patch level, Firefox 64.0.2


#5

Yes, an initial load will take like 10 seconds, that is normal.

I just let it sit at the white screen for like 5 minutes and it wouldn’t load completely.

Now the weird thing: I switched to the Firefox browser proper, opened the forum, switched back to the pinned-as-app instance and it had magically loaded the forum.

I have closed all apps and repeated the above and that appears to force the pinned-as-app instance to fully load the forum.

I may well have missed that behavior since January 9th when Firefox was updated, since the forum was already loaded up and running in the pinned-as-app instance. So maybe it’s a Firefox bug after all?

Any ideas?


#6

I don’t see it as a FF bug, rather than a feature.
The forum page/engine uses cookies a lot, to read/write read posts, because it seems to use Java-something for the nice infinite scrolling. After a FF update, or a network reset (like client or router IP chamge), the previous cookies cannot be used, or create a 404 error, or unlink/logout the user.
A combination of some or all of the above, is possibly the cause of your issue and a proper login on Main FF re-creates a nice connection relationship, between FF/Android and Discourse.
At least, that’s my feeling… :stuck_out_tongue_winking_eye:


#7

I also pin the forum to my home screen using this method. I have noticed that it has started to take longer to load the forums recently. Sometimes it will time out and fail to load. No matter if I am on WiFi or mobile data.

Phone: Sony Xperia XZ1 with Android P.


#8

Nope, not really. The logged-in state is really quite persistent as it should be with any Progressive Web App (PWA). I’ve had many of all the above and the logged-in state persisted, just needed to reload.

What happens now, is something else: the Discourse app is not being loaded properly somehow, but only in Firefox’s pinned-as-app instance. And it’s not cookies, because pinning the forum from a logged in and active state results in a pinned-as-app instance that will not load and hangs at a white screen.


#9

Then you know your stuff, better than myself!

I can only wait for the final solution (the real source of this problem), to enlarge my FF/Android/Discourse knowledge :wink:


#10

I work at a web development agency, but alas, I am not enough of a developer myself to troubleshoot it adequately. I usually write a detailed bug report and the dev team fixes it :innocent:


#11

Title renamed for clarity