The external monitor is disconnected

I tried to change the kernel to 517, but there were still DRM errors. I think it may be because the version of the official driver provided by manjaro is too old? I found through mhwd -l -d that the available NVIDIA versions are all 21 years old.

I tried to download the latest driver directly from NVIDIA’s official website, but I encountered many problems such as the lack of ‘kernel source’ package during installation

Hi Brother. I tried to degrade the kernel to 419 display, and there is no error in DRM. But GNOME is not started. But it is a message that can be turned to the display.

dont install drivers from other sites… you have installed the latest nvidia drivers… and the drm message may mean nothing, it was just a hint… and also dont install such old kernels, not good… post output from:
find /etc/X11/ -name "*.conf"

In kernel 5.17

find /etc/X11/ -name "*.conf"
cat /etc/mhwd.d/nvidia.conf

and post the output of the file

this file is empty.

## Generated by mhwd - Manjaro Hardware Detection

I have now switched to the solution of enabling the manjaro virtual machine on windows. I checked the properties of my display adapter under the windows system, and I found that my HDIM interface is actually mounted under the intel graphics card on windows. So on Linux it may be because of the driver problem of the intel graphics card. It has been stuck in the problem of Nvidia graphics card driver for a long time.

The output of lspci | grep -E 'VGA|3D' I provided earlier seems to confirm this point, nvidia only acts as a 3d controller on my laptop.

Finally, I am very grateful to Olli and brahma for your enthusiastic help. Although the final result is nothing, I have learned a lot of investigation methods and solutions. Thank you very much!

I solved the problem!
My laptop has two video output ports, one is HDMI and the other is MiniDp. My colleague lent me a MiniDp cable, and the external monitor can be used normally! I think this may be a notebook circuit design problem.
Thanks again for your help! @brahma @Olli
Also hope this solution will help others who encounter this problem.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.