The /etc/modprobe.d/ folder no longer works

the /etc/modprobe.d/ folder no longer works, I always use this folder to configure a module parameter, now this parameter does not change despite being set in a file inside this folder.

this is my file: /etc/modprobe.d/alsa-base.conf

# Disable snd-hda-intel power saving
options snd-hda-intel power_save=0 power_save_controller=N

when restarting I look for if the parameter changed in /sys/module/snd_hda_intel/parameters/power_save , and indeed it did not

It should be clarified that this worked in previous versions of manjaro

See here


I have no knowledge of the driver you are setting options for so I cannot comment on that portion.

However - the functionality of modprobe.d has not changed - I know because I have a vfio.conf which is loaded

$ modprobe -c grep | vfio_pci
options vfio_pci ids=8086:3e98

this has solved the problem, thank you very much

I have a modprobe option for snd_hda_intel in /etc/modprobe.d/ (not for power management) that is still working

TLP power options for audio devices can be customised using a .conf file in folder /etc/tlp.d/



This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.